Ubuntu

Font size adjust wont work with external subtitles

Reported by Owdy on 2006-04-01
22
Affects Status Importance Assigned to Milestone
Totem
Fix Released
Wishlist
totem (Ubuntu)
Low
Ubuntu Desktop Bugs
xine-lib (Ubuntu)
Wishlist
Unassigned

Bug Description

If i watch .div movies with external subtitle files (.sub), text change wont work if i use font tool under Totem settings.

I have to hack this if i want to change font size: ~/.gnome2/totem_config

# subtitle size
# { tiny small normal large very large huge }, default: 1
#subtitles.separate.subtitle_size:large

Totem 1.4.0 with Dapper drake. This happend with Breezy also.

Sebastien Bacher (seb128) wrote :

Thanks for your bug. Do you use totem-gstreamer or totem-xine?

Changed in totem:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info
Owdy (osku) wrote :

Eh, im not sure. It says Totem 1.4.0 - uses Streamer 0.10.4

Sebastien Bacher (seb128) wrote :

That's totem-gstreamer. Changing the font works fine for me. Does it work after restarting totem? Is that specific to one video? Do you have an URL to download one example?

Owdy (osku) wrote :

It does that with all divx movies with .sub files. It has allways done that.

Example file http://koti.mbnet.fi/oskunoma/test.sub

Owdy (osku) wrote :

Eh, there is something fishy going on with my totem. Now texts starts from wrong part of the movie etc. I dont get this.

Owdy (osku) wrote :

Okay, i changed to Totem-xine. Issue is back. I see text okay, but font setting isnt working.

Sebastien Bacher (seb128) wrote :

Does anybody else get that issue?

Changed in totem:
status: Needs Info → Unconfirmed
marx06 (hulik) wrote :

I have same problem - can change subtitles size in Settings but with no effect. Totem 1.2.1 with xine-lib 1.0.1 Breezy.

I got exactly the same problem here, I had to edit the totem_config file in order to change the subtitle size: a change in Totem's Preferences produces nothing

marx06 (hulik) wrote :

Yes, I did the same and it works well now.

shiechka (werchowyna) wrote :

I confirm - changing the subtitle font size doesn't take any effect - subtitles are all small whatever font I set.

Using totem-xine, fully updated Dapper.

Sebastien Bacher (seb128) wrote :

The issue is known if you use totem-xine:
http://bugzilla.gnome.org/show_bug.cgi?id=314123

Changed in totem:
status: Unconfirmed → Confirmed
Changed in totem:
status: Unknown → Confirmed
Owdy (osku) wrote :

This is still broken in Edgy.

danieltdp (danieltdp) wrote :

I get some weird stuff on fonts when using totem-xine too, but I am not sure if its related to this bug.

If I open avi files with subtitles in srt format, everithing works fine (all my options are respected: font size and color, for example).

When I get a DVD, the font looks really bad, like a small font scaled too much and its color goes back to white-black-transparent (which is not what I selected in preferences menu). Any selection I do in font preferences is ignored (font type, size, color, etc)

I tried to change totem config file with no sucess. My settings are just ignored with DVDs, just as when I did it in totem's front end

Changed in totem:
importance: Medium → Low
Robbert (robbertkrebbers) wrote :
Sebastien Bacher (seb128) wrote :

opening xine-lib task, it has to be built with freetype for that change

Changed in xine-lib:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
Changed in totem:
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

is that still an issue in hardy or intrepid?

Changed in totem:
status: Confirmed → Incomplete

I will try to check it out late at home and let you know

On Wed, Sep 3, 2008 at 12:01 PM, Sebastien Bacher <email address hidden> wrote:
> is that still an issue in hardy or intrepid?
>
> ** Changed in: totem (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> Font size adjust wont work with external subtitles
> https://bugs.launchpad.net/bugs/37587
> You received this bug notification because you are a direct subscriber
> of the bug.
>

A. Tombol (atombol) wrote :

Bug still present in Intrepid

Andreas Moog (amoog) wrote :

xine-lib is built with freetype-support since 1.1.7.

Changed in xine-lib (Ubuntu):
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

the jaunty version should work correctly

Changed in totem (Ubuntu):
status: Incomplete → Fix Released
Changed in totem:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.