Ubuntu

totem causes alt key press in openoffice every 30 seconds

Reported by Brijam on 2008-04-13
64
This bug affects 11 people
Affects Status Importance Assigned to Milestone
xine-lib (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: totem

Playing media in totem while using OpenOffice causes the Alt key to be triggered every 30 seconds.

Steps to reproduce:
play any file in Totem
Give OpenOffice the focus, no typing is necessary
In 30 seconds the Alt key will trigger, causing the File menu to be highlighted

Several other users appear to be having the same issue:
http://ubuntuforums.org/showthread.php?p=3661007#post3661007

The workaround is not to use totem.

Running an updated 7.10 64bit installation of Kubuntu on an HP dv9610us notebook.

Brijam (brian-opensourcery) wrote :

Confirming that this issue is still present in 8.04 / 64 bit.

Totem actually triggers the Alt key in Konqueror as well, and presumably other apps.

Pedro Villavicencio (pedro) wrote :

Thanks for your report, Do you use totem-gstreamer or totem-xine? Is this only reproducible on a 64bit environment? I've waited for about 3 minutes and nothing happens (I'm on 32bit installation though).

Changed in totem:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Brijam (brian-opensourcery) wrote :

I'm using totem-xine.

The thread above on ubuntuforums indicates one person is having the problem with xine, not Totem.

Carl (carllivitt) wrote :

I'm using 8.04 32-bit on a Lenovo Thinkpad Z60m. I can confirm the problem here, too. With Totem playing music, the alt key is registered every 30 seconds. Closing Totem stops it from happening.

I'm using totem-gstreamer (/usr/bin/totem -> /etc/alternatives/totem -> /usr/bin/totem-gstreamer)

Carl (carllivitt) wrote :

To clarify, the alt key is application independent. I first noticed when I was using MS Word in VMware, but it registers regardless of the application being used. It's not limited to OpenOffice as the original report suggests.

Pedro Villavicencio (pedro) wrote :

still an issue? i cannot reproduce this.

Pedro Villavicencio wrote:
> still an issue? i cannot reproduce this.

Hi Pedro-

I just tried and the issue is fixed for me. Thanks for the followup.

-B

Pedro Villavicencio (pedro) wrote :

thanks, closing the report, then.

Changed in totem:
status: Incomplete → Invalid
diurnambule (jonathan-melly) wrote :

Ubuntu 9.04 32 bits i386 : still same issue

José M. López-Cepero (cepe) wrote :

Ubuntu Jaunty, AMD64, same issue. Please reopen.

Incidentally, to me this happens with me-tv, which uses the xine engine. So I do not think that this is strictly a totem problem, but a libxine1 one.

affects: totem (Ubuntu) → xine-lib (Ubuntu)
Changed in xine-lib (Ubuntu):
status: Invalid → Incomplete
Changed in xine-lib (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Incomplete → New
bobince (bobince) wrote :

Same happens for me in totem-gstreamer 2.26.1-0ubuntu5 (Jaunty amd64). It's not xine-lib.

The effect that made me notice was that in XUL-based apps (Firefox, Thunderbird), pressing Alt causes any open menus to close. So while Totem is playing, any Firefox menus will spontaneously close every 30 seconds of playtime. Minor but irritating.

Under further investigation: the problem is caused by Totem attempting to disable the screensaver. If you go to Edit/Preferences/Display and tick 'Allow the screensaver to activate even when audio-only is playing', then Firefox menus only close every 30 seconds when you're playing video. If this option is not ticked, the menus will close every 30 seconds when you're playing only audio, as well.

It would seem Totem's method of subverting the screensaver is to simulate a press of the Alt key. There must be a better solution (fewer side effects) than this, surely?

bobince (bobince) wrote :

Further: the problem will not occur if one is running gnome-screensaver. This is probably why the issue isn't being reproduced by everyone.

lib/totem-scrsaver.c looks for org.gnome.ScreenSaver on DBUS. If it finds gnome-screensaver running, it sends an Inhibit message and stops there. If it doesn't, it assumes you're running some other brand of screensaver, and falls back to sending XTestFakeKeyEvents of the Alt key every 30 seconds. This behaviour has undesirable side effects as detailed here.

[And if, for example, you're not running *any* screensaver (because, for example, you happen to find them a frivolous waste of time), it's doing this for no purpose.]

Possible fix (1): change the ticky to a drop down with options 'Disable screensaver for audio and video'/'Disable screensaver for audio only'/'Never disable screensaver'

Possible fix (2): assume Ubuntu users will be using gnome-screensaver if anything, and remove the fake-key fallback (or compile WITHOUT_XTEST)

Possible fix (3): find a different X11 method for subverting the screensaver. A different key? Ctrl would seem to have fewer side-effects, but still is far from ideal. Is there eg. another obscure shifting key most keyboards don't have, or something like that?

Possible fix (4): invent a freedesktop standard for inhibiting screensavers, and use that exclusively.

MikeCamel (mike-hingston) wrote :

This has just started happening for me, and I'm not sure why. I've only noticed it since the New Year. Not sure if I got a new version of something then.

I'm using opneoffice-core 1:3.1.1-5ubuntu1 on amd64, karmic. I'm not running totem, or xine. And it's not just closing menus, but (as noted by the first reporter), but also opening them, too, which is very, very annoying, and makes oowriter unusable.

I had a long time yesterday when it _wasn't_ triggering, but I don't know what the difference was, and it's back again.

Any tips would be appreciated.

Oh, and I _am_ running gnome-screensaver.

MikeCamel (mike-hingston) wrote :

I've tracked this down to the app blueproximity, and will talk to the developer(s) there. Definitely connected to screensavers, though.

luchon (ichekryg) wrote :

I can confirm quitting blueproximity resolved this issue on my machine.

Cinquero (cinquero) wrote :

In my case the bad boy is in package xdg-utils, ie. /usr/bin/xdg-screensaver. It refuses to use dbus and runs gnome-screensaver-command --poke !

To disable that behaviour, run your app with

GNOME_DESKTOP_SESSION_ID='' xvdr

Same here. Also running bluebroximity and gnome-screensaver

Looks like the culprit is gnome-screensaver-command which is set as proximity command in blueproximity. When I run that command in a loop (without running blueproximity) I get the same behavior that the menu in OO opens and closes every 5 seconds.

Run the following batch script in a terminal window, then give focus to OO Writer:

#!/bin/bash
for (( ; ; ))
do
   gnome-screensaver-command -p
   sleep 5
done

Reinhard Tartler (siretart) wrote :

while the observation seems correct and since I've seen the implementation in gnome-screensaver-command, I totally agree that the defect is in gnome-screensaver-command.

However, this bugreport has been hijacked now since the original reporter confirms that he doesn't experience the symptom that he has reported anymore, so I'm closing this report.

Eberhard, please file a new bug against gnome-screensaver about this with your analysis and your testcase so that this bug gets the appropriate attention!

Changed in xine-lib (Ubuntu):
status: New → Fix Released

You're right. Sorry. Someone already reported it earlier today: bug #505789.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers