Change in dependency of libxine1 and broken new package

Bug #164801 reported by Chandru on 2007-11-24
8
Affects Status Importance Assigned to Milestone
xine-lib (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

I recently ran,

sudo apt-get dist-upgrade

To my horror I found that "libxine1" depended on gnome packages while I'm a KDE user. The fact is libxine1 depends on libxine1-plugins which depends on libxine1-gnome and so all this.

I know I can circumvent this by installing libxine1-misc-plugins instead and did so. Now none of my video files played with kaffeine I keep getting the error

No video drivers initialized

Why all this confusion what was wrong with the previous dependencies of libxine1? Also, why is libxine1-misc-plugins so badly broken?

Related branches

Chandru (chandru-in) wrote :

Forgot to add package hint while reporting

Tom Shaw (firephoto) wrote :

This issue is still present which causes a constant upgrade notification on kubuntu.

The problem seems to be that libxine1 has "required: libxine1-plugins or libxine1-misc-plugins" which was or should be a recommend since they pull in the gnome packages which aren't a default on a kubuntu system.

Chandru (chandru-in) wrote :

Exactly. Why don't u change the status of the bug to confirmed?

Reinhard Tartler (siretart) wrote :

xine-lib (1.1.8-3ubuntu1) hardy; urgency=low

  Merged from the current state of the debian packaging branch. Will appear
  in unstable shortly.

  [Darren Salt]
  * libxine1-dbg was missing some debug symbols. Fixed by building it after
    xine-lib's other arch:any packages.
  * Introduce a new package, libxine1-bin, which contains the binaries
    formerly in libxine1. Dependencies are moved and updated accordingly.
    thanks to Bill Allombert. (Closes: #454267)
  * Except for libxine1-doc, libxine1-bin and libxine-dev, symlink to
    libxine1-bin's documentation. (AUTHORS is now in libxine1-bin.)
  * Fix compilation of DXR3 support with external ffmpeg.
    This is currently only needed for compilation against libavcodeccvs-dev
    (from debian-multimedia). Untested with actual DXR3 hardware since I
    have none.

  [ Reinhard Tartler ]
  * Bug fix: "FTBFS with GCC 4.3: missing #includes", thanks to Martin
    Michlmayr and Daniel Schepler (Closes: #455438, #455322).
  * Bug fix: "libxine1-plugins: should not depend on libxine1-gnome",
    thanks to Hermogenes Hebert Pereira Oliveira. (Closes: #454162, LP: #164801)
    Instead, a new package is introduced: libxine1-all-plugins, which
    additionally depends on the gnome plugin.
  * remove the jack plugin. According to upstream it is unfinished and of
    poor quality. A rewrite is available in the 1.2 branch. LP: #152487

xine-lib (1.1.8-3) unstable; urgency=low

  [Darren Salt]
  * Patches from the 1.1.9 dev tree:
    - Silence "lacing: N" messages from the matroska demuxer.
    - Extra identifier for MPEG video (in AVIs etc.).
  * Tighten the dependencies of libxine1 and libxine1-plugins on libxine1-*
    packages.
  * Move deps on libxine1-{x,console} from libxine1-plugins to libxine1 to
    avoid further problems such as bug 448077.

  [ Reinhard Tartler ]
  * remove gs from build-deps
  * don't build the pulseaudio plugin. (Closes: #452211, #427991)

 -- Reinhard Tartler <email address hidden> Wed, 12 Dec 2007 22:23:32 +0100

Changed in xine-lib:
status: New → Fix Released
Chandru (chandru-in) wrote :

>> xine-lib (1.1.8-3ubuntu1) hardy; urgency=low

Will this fix not be available for Gutsy?

If it will be, then when can we expect it?

Tom Shaw (firephoto) wrote :

This is still broken on gutsy and the packages won't get updated with apt-get so I really think they should be pulled from backports.

This problem that is easily fixed means myself and many others I'm sure ignore the constant update notification in Kubuntu.

Chandru (chandru-in) wrote :

This bug is another example showing things are not tested for Kubuntu. The new dependencies, though unnecessary, work fine for gnome. But misc-plugins which don't depend on Gnome doesn't work.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers