cannot play audio on .3gp movies

Bug #125835 reported by Nicolò Chieffo on 2007-07-13
40
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xine-lib
Confirmed
Medium
ffmpeg (Ubuntu)
Undecided
Unassigned
ffmpeg-free (Debian)
Fix Released
Unknown
kaffeine (Ubuntu)
Wishlist
Unassigned
xine-lib (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kaffeine

kaffeine 0.8.4-0ubuntu3
libxine-extracodecs 1.1.4-2ubuntu3
libxine1 1.1.7-1ubuntu1
w32codecs 20061022-0medibuntu1

If I open a .3gp video made with my cellphone, I cannot hear audio. But I can see the mute video.
I've heard that the audio is coded in AMR

Christian González (droetker) wrote :

It doesn't work on mplayer either - a codec problem?
The funny thing is - on Windows, mplayer plays it WITH audio (At least the "3gp- Player" for Windows - which uses mplayer)

It does play (audio and video) using VLC, however, you do need to download a package from Medibuntu before getting the audio to work. I'm not really sure what package that is, but after setting up Medibuntu on my repo list, and after upgrading, the audio just worked on VLC. Hope this helps.

Please tell us which package is needed!

I've checked on VLC's codecs, and it has ffmpeg there. Could you verify if that's the package. I'm sorry, but I'm just not sure.

Changing status to Incomplete and leaving Importance to Undecided.

Changed in kaffeine:
status: New → Incomplete
Nicolò Chieffo (yelo3) wrote :

I have ffmpeg the codec in vlc preferences (but I can't hear audio)

is it possible that you tell me which packages you have from medibuntu?

I have the following:
1) libavcodec0d
2) libavformat0d and
3) libpostproc0d
all of them are ffmpeg libraries. It plays your 3gp.

Uh, that was a typo, i meant, I hope those packages plays you 3gps.

Nicolò Chieffo (yelo3) wrote :

I have them installed, from medibuntu. But vlc/totem does not play audio

[00000336] main decoder error: no suitable decoder module for fourcc `samr'.
It must be some other package!

Nicolò Chieffo (yelo3) wrote :

I'm attaching a .3gp movie so that we can all test from this file

Nicolò Chieffo (yelo3) wrote :

Have you tested my file?

Since I'm helping out by testing Gutsy, this gave me a chance to recreate this bug. I reinstalled Gutsy - Beta, and tried installing codecs from scratch. Now I can't play 3gpp files. Well, it plays, but no audio. I can't remember what I did or installed the last time to make this work. I'll be researching this. Will give updates.

Nicolò Chieffo (yelo3) wrote :

Thank you very much

Launchpad Janitor (janitor) wrote :

[Expired for kaffeine (Ubuntu) because there has been no activity for 60 days.]

Nicolò Chieffo (yelo3) wrote :

I still have the problem. Only vlc+medibuntu is able to play sound in my case

Changed in kaffeine:
status: Invalid → New
rothchild (marc-rothera) wrote :

I've been trying to work around this bug / issue I understand it's a licensing issue with the AMR codec there's more info here: http://66.102.9.104/search?q=cache:Yc48HTudC_cJ:www.penguin.cz/~utx/amr+penguin.cz&hl=en&ct=clnk&cd=2&gl=uk&client=firefox-a but unfortunately the actual penguin.cz site (and the build script for the amr code seems to be down :-( )

There's also a thread here: http://ubuntuforums.org/showthread.php?t=178455 and a fairly useful walk through here: http://www.thisismobility.com/blog/?p=156 although I've been getting stuck on how to bring the AMR codec and FFMPEG together in compilation.

Some people have said that I should just install realplayer and be done with it but the point is really that I don't want my machine littered with different media players and have to know that I need different ones for different files I just want one that just works ;-)

I can't find it again now but there is a SOC project on AMR and there's also a guide here with a link to the AMR codec from the phenomenally awfull 3gp website here: http://webcvs.freedesktop.org/gstreamer/gst-plugins-bad/ext/amrwb/README?view=markup&revision=1.1

Hope this gives someone with the appropriate wisdom the tools to make this happen by default in ubuntu (or perhaps a simple to use medibuntu package?)

Cheers
Child

Pander (pander) wrote :

Here is a converter for 3GP to MPEG:
http://www.miksoft.net/mobileMediaConverter.htm

Please provide support for 3GP in Ubuntu.

In , Darren Salt (dsalt) wrote :

Some codecs listed in ffmpeg_popular_codecs (in configure.ac) are not listed in src/libffmpeg/ff_{video,audio}_decoder.c. These, or reasons why not, should be added there and in src/xine-engine/buffer{.h,_types.c}.

In , Darren Salt (dsalt) wrote :

VC1 is done; see cset b9d8d256fe22.

In , Darren Salt (dsalt) wrote :

• Remaining "missing" video codecs:
 CODEC_ID_CLJR
 CODEC_ID_DNXHD
 CODEC_ID_DSICINVIDEO
 CODEC_ID_DXA
 CODEC_ID_FFH264
 CODEC_ID_FFV1
 CODEC_ID_FFVHUFF
 CODEC_ID_H263P
 CODEC_ID_MDEC
 CODEC_ID_MPEG2VIDEO
 CODEC_ID_MPEG2VIDEO_XVMC
 CODEC_ID_NONE
 CODEC_ID_PAM
 CODEC_ID_RAWVIDEO
 CODEC_ID_RV30
 CODEC_ID_RV40
 CODEC_ID_SNOW
 CODEC_ID_SP5X
 CODEC_ID_THP
 CODEC_ID_TIERTEXSEQVIDEO
 CODEC_ID_XAN_WC4
 CODEC_ID_XVID

 • Remaining "missing" audio codecs:
 CODEC_ID_AAC
 CODEC_ID_AC3
 CODEC_ID_ADPCM_ADX
 CODEC_ID_ADPCM_CT
 CODEC_ID_ADPCM_G726
 CODEC_ID_ADPCM_SBPRO_2
 CODEC_ID_ADPCM_SBPRO_3
 CODEC_ID_ADPCM_SBPRO_4
 CODEC_ID_ADPCM_YAMAHA
 CODEC_ID_AMR_NB
 CODEC_ID_AMR_WB
 CODEC_ID_DSICINAUDIO
 CODEC_ID_DTS
 CODEC_ID_DVAUDIO
 CODEC_ID_GSM
 CODEC_ID_IMC
 CODEC_ID_MP2
 CODEC_ID_MP3ADU
 CODEC_ID_MP3ON4
 CODEC_ID_MPEG4AAC
 CODEC_ID_MUSEPACK7
 CODEC_ID_PCM_S16BE
 CODEC_ID_PCM_S16LE
 CODEC_ID_PCM_S24BE
 CODEC_ID_PCM_S24DAUD
 CODEC_ID_PCM_S24LE
 CODEC_ID_PCM_S32BE
 CODEC_ID_PCM_S32LE
 CODEC_ID_PCM_S8
 CODEC_ID_PCM_U16BE
 CODEC_ID_PCM_U16LE
 CODEC_ID_PCM_U24BE
 CODEC_ID_PCM_U24LE
 CODEC_ID_PCM_U32BE
 CODEC_ID_PCM_U32LE
 CODEC_ID_PCM_U8
 CODEC_ID_QCELP
 CODEC_ID_SOL_DPCM
 CODEC_ID_SONIC
 CODEC_ID_SONIC_LS
 CODEC_ID_VORBIS
 CODEC_ID_WESTWOOD_SND1

 • Implemented in xine-lib-codec-support:
 CODEC_ID_VMNC

 [Edit log:
 2007-10-12 22:15 GMT - comment 6
 ]

I don't think we use the image decoders from libavcodec at all, so some of them shouldn't really be listed.

CODEC_ID_NONE // You don't want this

 // These are image codecs we don't really use from FFmpeg as it is.
 CODEC_ID_BMP
 CODEC_ID_GIF
 CODEC_ID_JPEG2000
 CODEC_ID_JPEGLS
 CODEC_ID_LJPEG
 CODEC_ID_PBM
 CODEC_ID_PGM
 CODEC_ID_PGMYUV
 CODEC_ID_PNG
 CODEC_ID_PPM
 CODEC_ID_TARGA
 CODEC_ID_TIFF

Fabián Rodríguez (magicfab) wrote :

AMR (the audio codec in 3GP) has important licensing restrictions and is covered by several patents. Currently there is no way to freely distribute it unless potentially breaking local laws.

I've documented what I found in a similar gstreamer-related bug:
https://bugs.edge.launchpad.net/ubuntu/+source/gst-plugins-ugly0.10/+bug/184555

This basically means there will most likely never be official support for AMR in Ubuntu unless this is resolved otherwise.

So, marking this as wishlist, incomplete for now.

Changed in kaffeine:
importance: Undecided → Wishlist
status: New → Incomplete
Craig Maloney (craig-decafbad) wrote :

I tried this with the Hardy Heron version of Kaffeine, and was able to play the 3GP movies available from Cranky geeks (http://crankygeeks.com). Please check with Hardy Heron and if it works, please close this bug. Thanks!

Have you got w32codecs installed?

Risto H. Kurppa (risto.kurppa) wrote :

What I found out was that ffmpeg from default repos doesn't have amr encodec in it, but by installing it form medibuntu you get the amr support and audio works. But as you already knew, in some countries this might be illegal. Hate those licensing issues..

Please, include at least AMR audio codecs (widely used in mobile phones, mostly with 3gp videos) support - now various Linux distros are patching xine-lib packages for AMR support, see for example this patch: http://sisyphus.ru/srpm/Sisyphus/xine/patches/2
Currently I can't hear sound when playing 3gp video with totem-xine (libxine-ffmpeg is installed on my system), while totem-gstreamer plays sound in same 3gp video without problems on same system with same ffmpeg installed.
You can get sample file with AMR audio from http://launchpadlibrarian.net/8969831/notti_mondiali.3gp
There are lots of bugreports about AMR support in various xine frontends, see for example at https://launchpad.net/bugs/125835

The AMR libraries are incompatible with GPL. Distributing binary builds of xine-lib linked against them is violating the GPL license xine is licensed with.

I suppose I should actually look for all the binary packages containing xine-lib linked with AMR support and ask for their removal.

In , Darren Salt (dsalt) wrote :

I see three possible solutions:

* Use libdl to access the AMR libs.

* Get agreement from everybody who holds copyright in the relevant source files to agree to an exception. (This is the "openssl solution".)

* Write GPL-compatible clones of the AMR libs.

That said, the only case that matters to us is when we're using statically-linked ffmpeg libs; otherwise, I see no problem with xine-lib knowing about AMR codecs and being able to use them should they be available.

Reinhard Tartler (siretart) wrote :

confirming that 'ffplay' from intrepid does play video but not audio on the provided test file.

Changed in ffmpeg:
status: New → Confirmed
Changed in ffmpeg-free:
status: Unknown → New
Fabián Rodríguez (magicfab) wrote :

I am asking other colleagues at Canonical what is the process to adding proper support (detection, installation, support for future updates, etc) in Ubuntu for this or other codecs. This Brainstorm suggestion may provide more context to anyone wondering why this is not supported in Ubuntu:
http://brainstorm.ubuntu.com/idea/316/

Reinhard Tartler (siretart) wrote :

bug is valid, but not easy to solve. see xine-lib upstream bug report about license status

Changed in xine-lib:
status: New → Confirmed
Changed in xine-lib:
status: Unknown → Confirmed
Reinhard Tartler (siretart) wrote :

the ubuntu part of this bug is tracked in bug #93849

Changed in ffmpeg:
status: Confirmed → Invalid
Pander (pander) on 2008-11-18
Changed in kaffeine:
status: Incomplete → Confirmed
kernel_script (kernelscript) wrote :

Bug https://bugs.launchpad.net/ubuntu/+bug/334947 is not a duplicate of this one, please fix.

Changed in ffmpeg-free (Debian):
status: New → Confirmed
Changed in ffmpeg-free (Debian):
status: Confirmed → Fix Released

** Changed in: ffmpeg-free (Debian)
      Status: Confirmed => Fix Released

Does this mean that we will be able to play 3gp with amr-encoded audio?

Changed in xine-lib:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.