[apport] totem-video-thumbnailer crashed with SIGSEGV in xine_list_get_value()

Bug #104651 reported by Richie Ward
42
Affects Status Importance Assigned to Milestone
xine-lib (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: totem

On Ubuntu Feisty, Was using MythTv Frontend then went to watch tv

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Mon Apr 9 04:26:01 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/bin/totem-video-thumbnailer
Package: totem-xine 2.18.1-0ubuntu3
PackageArchitecture: i386
ProcCmdline: /usr/bin/gnome-video-thumbnailer -s 128 file:///home/richie/mythtv/1001_20070409042540.mpg /tmp/.gnome_thumbnail.60VOQT
ProcCwd: /home/richie
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: totem
Stacktrace: #0 0xb75843a4 in xine_list_get_value () from /usr/lib/libxine.so.1
StacktraceTop: xine_list_get_value () from /usr/lib/libxine.so.1
Uname: Linux richie-desktop 2.6.20-14-generic #2 SMP Mon Apr 2 20:37:49 UTC 2007 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin mythtv plugdev scanner video

Revision history for this message
Richie Ward (richies) wrote :
Revision history for this message
Apport retracing service (apport) wrote : Symbolic stack trace

StacktraceTop:xine_list_get_value (list=0x81253c8, ite=0x0) at list.c:258
xine_get_next_video_frame (this_gen=0x81252d0, frame=0x80d4e38) at video_out.c:1266
bacon_video_widget_get_current_frame ()
main ()

Revision history for this message
Apport retracing service (apport) wrote : Symbolic threaded stack trace
Changed in xine-lib:
importance: Undecided → Medium
Changed in xine-lib:
status: New → Confirmed
Revision history for this message
Reinhard Tartler (siretart) wrote :

Thanks for taking your time to report this bug. You have reported a crash in the xine-lib library. In order to be able to actually fix this bug, we must be able to

  * reproduce it
  * check if it happens with the latest version
  * understand where it actually crashes

You can help with the first point by attaching an example file to this bug report. Please note that a proper attachment is preferred over a link to some remote site. Remote side that are password protected or otherwise restriced (like services like rapidshare.com and similar) are absolutely not acceptable.

For the 2nd point, the MOTUMedia team provide updated packages for xine-lib and ffmpeg in their PPA for past ubuntu releases. See http://launchpad.net/~motumedia/+archive for instructions how to enable that archive. Please add this repository to your /etc/apt/sources.list, update your system and make sure, that you have both packages 'ffmpeg-dbg' and 'libxine1-dbg' installed (use 'sudo apt-get dist-upgrade && sudo apt-get install libxine1-dbg ffmpeg-dbg'). This way, you can produce meaningful backtraces that help us with point 3. You can read https://wiki.ubuntu.com/Backtrace about how to create proper backtraces that help developers identifying the exact location of the crash.

Thank you for your cooperation.

Changed in xine-lib:
status: Confirmed → Incomplete
Revision history for this message
wolfger (wolfger) wrote :

6 months with no response. We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in xine-lib:
status: Incomplete → Invalid
Changed in xine-lib (Ubuntu):
status: Invalid → New
Revision history for this message
bhavin katira (bhavinkatira) wrote :

(gdb) n
22 engine = xine_new();
(gdb)
23 snprintf(configfile, sizeof(configfile), "%s%s", xine_get_homedir(), "/home/bhavin/.xine/config");
(gdb)
24 xine_config_load(engine, configfile);
(gdb)
26 xine_init(engine);
(gdb)

[New Thread 0xb7fd9b70 (LWP 13154)]
27 xine_engine_set_param(engine,0,0);
Missing separate debuginfos, use: debuginfo-install alsa-lib-1.0.23-1.fc13.i686 dirac-libs-1.0.2-3.fc12.i686 faad2-libs-2.7-1.fc11.i586 ffmpeg-libs-0.6-3.fc13.i686 gsm-1.0.13-2.fc12.i686 lame-libs-3.98.3-1.fc13.i686 libcdio-0.82-2.fc13.i686 libogg-1.2.0-1.fc13.i686 liboil-0.3.16-4.fc12.i686 libstdc++-4.4.5-2.fc13.i686 libtheora-1.1.1-1.fc13.i686 libva-freeworld-0.31.1-1.sds4.fc13.i686 libvorbis-1.3.1-1.fc13.i686 libvpx-0.9.6-1.fc13.i686 openjpeg-libs-1.3-7.fc13.i686 schroedinger-1.0.8-4.fc13.i686 speex-1.2-0.12.rc1.fc12.i686 vcdimager-libs-0.7.23-13.fc13.1.i686 x264-libs-0.0.0-0.27.20100130git3659b81.fc13.i686 xine-lib-extras-freeworld-1.1.18.1-1.fc13.i686 xvidcore-1.2.2-2.fc13.i686
(gdb)
29 ap = xine_open_audio_driver(engine,"none",NULL);
(gdb)
[New Thread 0xb75b7b70 (LWP 13155)]
31 vp = xine_new_framegrab_video_port(engine);
(gdb)
32 if(vp == NULL) {
(gdb)
37 stream = xine_stream_new(engine,ap,vp);
(gdb)
[New Thread 0xb63c2b70 (LWP 13156)]
[New Thread 0xb57f4b70 (LWP 13157)]
39 if (!xine_open(stream,mrl))
(gdb)
47 xine_play(stream,0,0);
Missing separate debuginfos, use: debuginfo-install lcms-libs-1.19-1.fc13.i686 libjpeg-6b-46.fc12.i686 libmng-1.0.10-4.fc12.i686 libv4l-0.7.91-1.fc13.i686
(gdb)
[New Thread 0xb4df3b70 (LWP 13158)]
55 printf(" b4 doing something\n");
(gdb)
 b4 doing something
56 xine_get_next_video_frame(vp,&myframe);
(gdb)

Program received signal SIGSEGV, Segmentation fault.
0x05392710 in xine_list_get_value () from /usr/lib/libxine.so.1
(gdb)
Single stepping until exit from function xine_list_get_value,
which has no line number information.
[Thread 0xb4df3b70 (LWP 13158) exited]
[Thread 0xb63c2b70 (LWP 13156) exited]
[Thread 0xb7fd9b70 (LWP 13154) exited]
[Thread 0xb57f4b70 (LWP 13157) exited]
[Thread 0xb75b7b70 (LWP 13155) exited]

Program terminated with signal SIGSEGV, Segmentation fault.
The program no longer exists.
(gdb)

Changed in xine-lib (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers