Unwanted workspace switching at screens edge

Bug #381155 reported by Duane on 2009-05-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Xfwm4
Unknown
Unknown
xfwm4 (Ubuntu)
Low
Unassigned

Bug Description

I'm using Xubuntu 9.04, fully updated.

The workspace will change anytime the mouse pointer reaches the edge of the screen. The "Wrap workspaces depending on the actual desktop layout" option is not selected in the Window Manager Tweaks options.
I expected the mouse pointer to stop at the edge of the screen, but it will select the next workspace.

Using fusion-icon, I can switch to KWIN, Compiz, or Metacity, and not have the problem, but changing back to Xfwm4, the problem will reoccur.

Duane (duanehubbard) on 2009-05-28
description: updated
Charlie Kravetz (charlie-tca) wrote :

Thank you for your suggestion. However, this is a feature of Xfce 4.6, and therefore is not a valid bug. Change to this would require more discussion, which should be done on an appropriate mailing list or forum. http://www.ubuntu.com/support/community/mailinglists might be a good start for determining which mailing list to use.

Changed in xfce4 (Ubuntu):
status: New → Invalid
Pasi Lallinaho (knome) wrote :

Charlie,

if I understood correctly, this happens even without dragging a window. If it should, then I am the one who has a bug.

I'm opening this again, as I'm not sure if it is invalid.

Changed in xfce4 (Ubuntu):
status: Invalid → New
Charlie Kravetz (charlie-tca) wrote :

This is not a valid bug. Please go to "Applications -> Settings -> window Manager; Advanced tab and uncheck "Wrap workspaces when pointer reaches the screen edge". If the mouse still changes desktops when reaching the screen edge, please log out and log back in. At this point, if it still happens, the bug may be reopened by changing status to new, and commenting that you have done this.

Changed in xfce4 (Ubuntu):
status: New → Invalid
Duane (duanehubbard) wrote :

It does happen when just moving the mouse, no window in tow.
I followed the "Applications -> Settings -> window Manager; Advanced tab and uncheck "Wrap workspaces when pointer reaches the screen edge". The box was unchecked. I checked the box, and restarted X, the problem still occurred, I unchecked the box, and restarted X again. Upon login, the problem is still occurring - in short the box makes no difference, though unchecking "Wrap workspaces when dragging a window off the screen" will prevent a workspace changing if I'm dragging a window.

Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Thank you for verifying the proper boxes checked and unchecked. I have forwarded this bug to the developers of the software. You can track it and make comments at: http://bugzilla.xfce.org/show_bug.cgi?id=5407

Changed in xfce4 (Ubuntu):
importance: Undecided → Low
status: Invalid → Triaged
Changed in xfce:
status: Unknown → Confirmed
affects: xfce4 (Ubuntu) → xfwm4 (Ubuntu)

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version.

Changed in xfwm4 (Ubuntu):
status: Triaged → Incomplete

Closing this report.

Changed in xfwm4 (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.