[SRU] xfwm4 4.12.5 for bionic

Bug #1796144 reported by Mike Neac on 2018-10-04
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xfwm4 (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Impact]

 * Please see the upstream bugs for some background:
   - Mozilla Bugzilla #1461539: [XFCE] window not maximized after fullscreen video
     https://bugzilla.mozilla.org/show_bug.cgi?id=1461539
   - Xfce Bugzilla #14514: Unable to maximize in both horizontal and vertical directions via X11
     https://bugzilla.xfce.org/show_bug.cgi?id=14514

 * Xfwm4 versions prior to 4.12.5 fail to maintain the window maximization state when exiting a fullscreen video.

 * As seen in comments 9 (https://bugzilla.mozilla.org/show_bug.cgi?id=1461539#c9) and 10 (https://bugzilla.mozilla.org/show_bug.cgi?id=1461539#c10), version 4.12.5 resolves this issue.

[Test Case]

 * In Firefox, follow these steps to enable the CSD window.
   1. Click the Hamburger menu, then select "Customize..."
   2. In the bottom section, uncheck the "Title Bar" option.
   3. Close the "Customize Firefox" tab.

 * With Xfwm 4.12.4 (bionic), follow these steps to reproduce the bug.
   1. Maximize the Firefox window.
   2. View a YouTube video.
   3. Click the Fullscreen button to enter make the video fullscreen.
   4. Press Escape to exit fullscreen.
   5. The window is no longer maximized.

 * With Xfwm 4.12.5, follow these steps to verify the bug is resolved.
   1. Maximize the Firefox window.
   2. View a YouTube video.
   3. Click the Fullscreen button to enter make the video fullscreen.
   4. Press Escape to exit fullscreen.
   5. The window is still maximized.

[Regression Potential]

 * Regression potential is low since this is a point release that only addresses bugs.

 * Since Xfwm4 is the window manager for Xfce, a crash could leave the user's windows undecorated and unable to be moved.

[Release Notes for 4.12.5]

Adam Purkrt (1):
      Typo in clientMoveTile

Andrey Alekseenkov (1):
      Fix logic error in bottom struts validation

Olivier Fourdan (11):
      Post release tag bump.
      netwm: avoid spurious warning on restart
      placement: Use primary monitor as default
      Use ximerama indices for _NET_WM_FULLSCREEN_MONITORS
      screen: Fix broken monitor index
      client: Make sure to redraw when removing maximized
      screen: Use computed screen size instead of xlib
      netwm: Fix adding maximized state
      client: Check when GTK_FRAME_EXTENTS has changed
      client: Check GTK_HIDE_TITLEBAR_WHEN_MAXIMIZED
      Release 4.12.5!

P. Pronk (1):
      client: Maximize on expected output

Unit 193 (1):
      Fix a spelling mistake.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfwm4 (Ubuntu):
status: New → Confirmed
Mattia (io-mattia98) wrote :

Yes, please backport 4.12.5 ASAP as it would fix this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1461539

It is a very annoying bug and it is fixed in 4.12.5 as stated in this comment (https://bugzilla.mozilla.org/show_bug.cgi?id=1461539#c10).

Thank you.

Sean Davis (bluesabre) on 2019-02-27
summary: - ubuntu 18.04 bionic xfwm4 backport 4.12.5
+ [SRU] xfwm4 4.12.5 for bionic
description: updated
description: updated
Sean Davis (bluesabre) wrote :

Attaching debian debdiff

Sean Davis (bluesabre) wrote :

Attaching full package debdiff

Changed in xfwm4 (Ubuntu):
status: Confirmed → In Progress
Brian Murray (brian-murray) wrote :

There has never been a point release update for xfwm. Can the issues regarding maximized windows not be fixed in xfwm version 4.12.4?

Given the regression potential for an update of xfwm4 what testing will be done to ensure that there are no regressions? Is there any automated testing of xfwm4?

Changed in xfwm4 (Ubuntu):
status: In Progress → Incomplete
Changed in xfwm4 (Ubuntu Bionic):
status: New → Incomplete
Changed in xfwm4 (Ubuntu):
status: Incomplete → Invalid
Sean Davis (bluesabre) wrote :

@brian-murray,

This appears to be the commit that resolves the issue with Firefox,
https://git.xfce.org/xfce/xfwm4/commit/?h=xfce-4.12&id=18575f3a098c7bbb3a43838c7745e01efa260997

But the other commits in this release also provide worthwhile bug fixes that would benefit LTS users. Each fix is targeted to an individual issue and is cherry-picked from the upstream Xfwm4 4.13 code.

Version 4.12.5 exists in Cosmic and Disco, and we haven't heard of any regressions from the update. As Xfwm4 does not have any automated testing, the updated package version would require some testing by the Xubuntu team and community.

Hello Mike, or anyone else affected,

Accepted xfwm4 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xfwm4/4.12.5-1ubuntu0.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in xfwm4 (Ubuntu Bionic):
status: Incomplete → Fix Committed
tags: added: verification-needed verification-needed-bionic
Sean Davis (bluesabre) wrote :

Tested and verified in Bionic.

Before:
1. Firefox window is maximized.
2. YouTube video is fullscreened.
3. Fullscreen video is exited.
4. Firefox window is no longer maximized.

After:
1. Firefox window is maximized.
2. YouTube video is fullscreened.
3. Fullscreen video is exited.
4. Firefox window is still maximized.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Changed in xfwm4 (Ubuntu):
status: Invalid → Fix Released
Łukasz Zemczak (sil2100) wrote :

Thank you for your verification. Please be sure to include information about the version number of the package you have tested during verification. It is essentially a requirement for a bug to be considered verified (as per the acceptance bug comment). This time I'll let it in without that, but just a heads up for the future!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfwm4 - 4.12.5-1ubuntu0.18.04.1

---------------
xfwm4 (4.12.5-1ubuntu0.18.04.1) bionic-proposed; urgency=medium

  * SRU backport to keep maximized windows after exiting fullscreen
    videos in Firefox (LP: #1796144)

 -- Sean Davis <email address hidden> Tue, 26 Feb 2019 22:13:52 -0500

Changed in xfwm4 (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for xfwm4 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.