Fullscreen window prevents other window to be raised

Bug #1394439 reported by Paulo Marcel Coelho Aragão on 2014-11-20
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Xfwm4
Fix Released
Medium
xfwm4 (Ubuntu)
Medium
Unassigned

Bug Description

Steps to reproduce the problem:

1. Open an application that can go fullscreen, such as vlc or geeqie, and go fullscreen.
2. With Alt-Tab, try to switch to another application. Here I tried to switch to a running gvim instance.

The result: The new application window is not shown at all, but I can infer that it has gained focus because even though the original fullscreen application is the only thing currently shown, it stops reacting to anything I type, such as <ESC> to stop fullscreen, and it only starts reacting if I switch back to it with Alt-Tab.

The expected result: The new application should be shown on top of the fullscreen application.

I'm running a fresh Xubuntu 14.10 installation, and xfwm4's version is 4.11.2-0ubuntu2.

Not sure what else might be relevant to inform here, but I can say that this happens independently of the applications involved, it suffices to go fullscreen with any application and try to switch to any other application with Alt-Tab — I tried with varied combinations of applications, and the result was the same, in other words, it's not tied to any specific application.

This didn't happen with Xubuntu 14.04.

I'll be more than glad and willing to help debug this.

Regards,
Paulo

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: xfwm4 4.11.2-0ubuntu2
ProcVersionSignature: Ubuntu 3.16.0-24.32-generic 3.16.4
Uname: Linux 3.16.0-24-generic x86_64
ApportVersion: 2.14.7-0ubuntu8
Architecture: amd64
CurrentDesktop: XFCE
Date: Thu Nov 20 00:24:32 2014
InstallationDate: Installed on 2014-11-15 (4 days ago)
InstallationMedia: Xubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
SourcePackage: xfwm4
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

W/ xfwm 4.11.2, probable regression from 4.10 - if i have a fullscreen app (say, terminal or ffx) in front of a non-fullscreen app and i focus the latter, focus is transmitted but the fullscreen app stays on top (and still hides the other one) instead of having it brought up to the front. Pretty sure in 4.10 this wasnt the case...

< gaston+> hmm another potential xfwm4 regression in 4.11.. have a fullscreen app, alt-tab -> the other apps are not brought in front of the fullscreen win, only focused..
<kalikian+> gaston: does the fullscreen app stay in front whilst the focus changes to the destined app? if so I'm seeing exactly that

On that matter, i have STR on a xinerama setup. have the window on top of fullscreen app, alt-tab to the fullscreen app -> the window disappears. Alt-tab to the hidden window -> doesnt come up. Focus other window on other screen with mouse, focus back the fullscreen window, focus back 'other window on other screen' - the previously hidden windowed app comes on top of fullscreen app, unfocused.

just to clarify, this doesnt happen with maximized windows, only fullscreen ones.

I can also confirm it's a regression - on two computers with xfwm 4.10, having a fullscreen window (be it a term or a firefox window), alt-tabbing to another window correctly brings it to the top, showing the window on top of the fullscreen one (and the xfce panel, if the said window is not fullscreen too)

Specifically this piece of code from the above commit causes the problem:

 c2 = myScreenGetClientFromWindow (screen_info, GDK_WINDOW_XID (gtk_widget_get_window ( passdata.tabwin->tabwin_list->data)), SEARCH_FRAME);
 g_message ("%p", c2);
 clientSetFocus (screen_info, c2, ev->time, NO_FOCUS_FLAG);

Nick, any idea ?

I can confirm that commenting out these 3 lines fixes the issue i'm seeing - will check if i get other regressions...

And i also have the strange feeling it's also fixing bug 11166 while at it.. will continue using it this way to confirm.

What bother me slightly is that it's unclear to me what the patch that introduced the regression was supposed to fix in the first place...

http://who-t.blogspot.ie/2009/12/on-commit-messages.html?m=1

*** Bug 11120 has been marked as a duplicate of this bug. ***

Changed in xfwm4:
importance: Unknown → Medium
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfwm4 (Ubuntu):
status: New → Confirmed
scytlae (scytale-gmail) wrote :

I'm using this workround:

/usr/bin/metacity --replace

put it in the list of start up applications (settings -> sessions and startup -> application autostart

Changed in xfwm4 (Ubuntu):
importance: Undecided → Medium

Should be fixed with git commit 0151f6b

yeah, reconfirming since that commit removes the lines i had to comment out to workaround it when i tested in comment 7.. that leaves bug 11166.

Changed in xfwm4:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfwm4 - 4.11.3-0ubuntu1

---------------
xfwm4 (4.11.3-0ubuntu1) vivid; urgency=medium

  * New upstream release.
    - Fix maximizing vetically or horizontally tiled windows. LP: #1397922
    - Revert "Experiment with button events." LP: #1394439
    - Use source indication in activate window. LP: #1292122
    - Determine the maximum host name length correctly. LP: #1233107
  * Drop 0001-fix-fullscreen-qt4-behavior-bug-8563.patch,
    02-remove-unused-maximize-button.patch, fixed upstream
 -- Jackson Doak <email address hidden> Sun, 15 Feb 2015 06:24:16 +1100

Changed in xfwm4 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.