Mouse wheel doesn't switch windows when focus following

Bug #1315623 reported by Richard Quirk on 2014-05-03
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Xfwm4
Fix Released
Medium
xfwm4 (Ubuntu)
Undecided
Unassigned

Bug Description

Activating focus follows mouse from Settings > Window Manager > Focus > Focus follows mouse breaks the panel's window buttons plugin so that the mouse wheel to switch windows no longer works.

To reproduce, set the focus follows mouse setting. Open a few windows. Move the mouse onto the panel, over the window buttons applet and scroll the mouse wheel up or down. Normall it swaps the currently active window to the next window on each scroll of the mouse, but with sloppy focus it gets stuck after swapping one window. You can compare the expected behaviour with when the Focus > click to focus setting is set.

This bug is apparently not present in Xfce 4.10.1 (tested by a fellow Xfce user running Arch). I'm running 14.04 Xubuntu, installed from scratch with a new profile. xfwm is 4.11.1 and xfce4-panel is 4.11.0.

I tried compiling xfce4-panel and reverting to the older plugins/tasklist/tasklist-widget.c file, but the bug must be more subtle than that. Some interaction bewteen xfwm and xfce4-panel.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xfwm4 4.11.1-2ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CurrentDesktop: XFCE
Date: Sat May 3 09:48:09 2014
SourcePackage: xfwm4
UpgradeStatus: No upgrade log present (probably fresh install)

In , Gleb-b (gleb-b) wrote :

If 'focus follows mouse' is enabled, clicking a window button in the taskbar raises the window but doesn't give it focus.
This behavior doesn't match the 4.10 release where the window does get focus.
Annoyingly this makes raising a window with one click, looking at it and then minimizing it with a second click impossible.

I'm running xubuntu 14.04 x64
xfwm4 version 4.11.1 (revision 2b800f4) for Xfce 4.10
xfce4-panel 4.11.0 (Xfce 4.10)

Richard Quirk (quirky) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfwm4 (Ubuntu):
status: New → Confirmed
Richard Quirk (quirky) wrote :

While the problem I reported is not exactly the same as the upstream bug 10747, I think the issue is closely related.

Changed in xfwm4:
importance: Unknown → Medium
status: Unknown → Confirmed

I can confirm this in 4.11. eg, you'll tap window foo in the taskbar to bring it to the foreground, but tapping it again won't minimize it unless you first bring window foo (or another window) to the foreground. Tested on Gentoo unstable.

In , unwohlpol (o-k) wrote :

I can also confirm this bug and want do provide some additional infos from a thread I started some time ago. Probably they can be useful for fixing:

http://forum.xfce.org/viewtopic.php?id=8772

Confirming bug on Ubuntu 14.04 LTS.

In , Narann (narann) wrote :

Created attachment 5736
Buttons activated

In , Narann (narann) wrote :

Hi all!

I also use focus on mouse and have this trouble.

I can click as much as I can on the label of a window, it doesn't minimize it...

What make everything weird is that when you click on every taskbar button they are all activated...

Notice I don't have any problem if I use the "Click to focus" (which I never use actually).

Thanks in advance and keep the good job!

Regards,

Dorian

In , Narann (narann) wrote :

Oups, my spec: Linux Mint 17 Qiana XFCE.

xfwm4: 4.11.1-2ubuntu-2
xfdesktop4: 4.11.6-1ubuntu-1

Need more infos?

Regression caused by bug #10508, marking this bug as duplicate of bug 11055 since this is actually a panel bug and not a window manager bug...

Dupe it - followup in 11055.

*** This bug has been marked as a duplicate of bug 11055 ***

The fix belongs in xfwm4 and not in the panel

*** Bug 11055 has been marked as a duplicate of this bug. ***

In , Narann (narann) wrote :

Thanks a lot! :)

Changed in xfwm4:
status: Confirmed → Fix Released
Richard Quirk (quirky) wrote :

Until this makes its way into xubuntu here's a ppa with Olivier's patch https://launchpad.net/~quirky/+archive/ubuntu/xfwm4

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.