Add support for tear-free compositing in Xfce

Bug #1294600 reported by Tamir on 2014-03-19
176
This bug affects 35 people
Affects Status Importance Assigned to Milestone
xfwm4 (Ubuntu)
Wishlist
Unassigned

Bug Description

Problem render windows (moving any window shows vertical stripes), PDF viewer in the entire font as if floating. While on the same hardware Ubuntu, Kubuntu normally. In FireFox when scrolling sometimes appear terrible brakes, as well as bands when scrolling. Video in dynamic scenes with stripes. When you install a composite window manager (compiz) everything is fine. There is a problem on Ubuntu 13.10 x64 (xfce) and Ubuntu 13.10 x86 (xfce).

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: xfwm4 4.10.1-2ubuntu1
Uname: Linux 3.14.0-031400rc7-generic i686
ApportVersion: 2.12.5-0ubuntu2.2
Architecture: i386
Date: Wed Mar 19 14:33:07 2014
InstallationDate: Installed on 2014-03-19 (0 days ago)
InstallationMedia: Xubuntu 13.10 "Saucy Salamander" - Release i386 (20131016)
MarkForUpload: True
SourcePackage: xfwm4
UpgradeStatus: No upgrade log present (probably fresh install)

Tamir (sugip) wrote :

It is a known limitation. Please take a look at the following upstream bug reports for more information:

https://bugzilla.xfce.org/show_bug.cgi?id=10407
https://bugzilla.xfce.org/show_bug.cgi?id=10439

Tamir (sugip) wrote :

Thanks for the links

summary: - Render windows xfwm4
+ Add support for tear-free compositing in Xfce
Tamir (sugip) on 2014-03-19
description: updated
description: updated
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfwm4 (Ubuntu):
status: New → Confirmed
Tol (reminov-tolyan) wrote :

Bugzilla on Xfce nor any movements can support .. and certificates expired resource (((.

David (davidmelkihan) wrote :

I confirm the limitation on Ubuntu 14.04 x86 (Xfce).
Bug appears on a laptop Acer Aspire V3 with Nvidia, specifications attached.

Tamir (sugip) wrote :

The bug has been confirmed on Xubuntu 14.04 x64 on my laptop Samsung for the AMD platform. Characteristics of the laptop attached.

Dima (dima-uvar) wrote :

confirms bug on xfce 4.11.4 on Ubuntu 14.04 trusty (x64)

Jackson Doak (noskcaj) on 2014-03-25
Changed in xfwm4 (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Triaged
Will (tcosprojects) wrote :

There seems to have been a regression. I had Xubuntu 14.04 Beta 2 installed and enabled tear-free compositing under the window manager settings. It worked initially and window movement was much smoother.

However, once I apt-get updated all the packages on the system the tear-free compositing stopped functioning after restarting.

Distro: Xubuntu 14.04 x64 Beta 2
GPU: Intel HD Graphics 2500

Larenge (daslevel) on 2014-04-15
no longer affects: xfwm4
Will (tcosprojects) wrote :

I am on Xubuntu 14.04. I ended up switching to compton and that resolved the tearing issue for me.

fabien29200 (fabien29200) wrote :

I confirm the bug on core i5 + nvidia machine and an intel celeron + i915.

I don't understand why this is a wish list bug.
In previous default installation of Xubuntu, this problem didn't exist.

This make Xubuntu (by default) really poor.

Waz (paviluf) on 2015-10-03
tags: added: wily xubuntu-exp
removed: saucy
Waz (paviluf) on 2015-10-03
tags: removed: apport-bug i386
Sean Davis (bluesabre) wrote :

We're beyond Feature Freeze at this point and don't have sufficient time or resources to fully confirm this fix. We've also spoken upstream and this fix won't be included in a new stable release of xfwm for quite some time, so we're very hesitant to include this in time for Wily. We may consider this patch for inclusion for 16.04.

Waz (paviluf) wrote :

I have built Xfwm4 myself, I tested it for weeks now and I can confirm that fix the tearing problem with Nvidia proprietary drivers.

I don't really care for me since I can build Xfwm4 myself but it's for all other people that are plagued with this for years now. I think it worth it to include it in Wily.

Anyway if someone is interested, this is how I build Xfwm4:

$ sudo apt-get install checkinstall git build-essential xfce4-dev-tools coffeescript pkgconf libgtk2.0-dev libglib2.0-dev libxfce4util-dev libxfce4ui-2-dev libxfconf-0-dev libwnck-dev libxfce4ui-1-dev exo-utils libepoxy-dev
$ git clone git://git.xfce.org/xfce/xfwm4
$ cd xfwm4/
$ ./autogen.sh --prefix=/usr --libdir=/usr/lib/x86_64-linux-gnu/ --disable-debug && make
$ sudo checkinstall -D make install
$ sudo reboot

Note that you simply have to enter a verison number compliant with debian policy like 4.12.4 and press enter when it hang.

jeremy, you have to clone the 4.12 branch and apply the patch(es) which you want to be backported for Ubuntu.
Testing git master with all the new changes may produce a different result.

Waz (paviluf) wrote :

You are right. Can you give me the commands to do that please ?
Thank you.

Waz (paviluf) wrote :

The development of Xubuntu 16.04 has started, so maybe we should include the fix now to have a lot of time to test it ?

Waz (paviluf) wrote :

Can you say if the fix will be included in 16.04 please ?
Thanks

tags: added: xenial
Waz (paviluf) wrote :

Should we understand that the fix will not be integrated in Xubuntu 16.04 ?

Waz (paviluf) wrote :

Can I have an answer please ?

Waz (paviluf) wrote :

I talked about this fix that fix the tearing with the Nvidia proprietary (http://git.xfce.org/xfce/xfwm4/commit/?id=8a67212860898ef02fee79f64fc774bc14ed769c) but, more important, there is also this fix that fix the tearing for everybody :

http://git.xfce.org/xfce/xfwm4/commit/?id=fee08eafa751a153ff93b04152ea66334141cac5

I really think that must be added to Xubuntu 16.04

Sean Davis (bluesabre) wrote :

I grabbed both of those commits and neither applies cleanly on top of xfwm-4.12.3. This indicates that there have been a significant amount of other changes in between.

To carry these commits, one of the following scenarios would have to happen:
- A new release in the xfwm 4.12.x series
- Xubuntu carries a git snapshot of xfwm

Neither of these scenarios are likely for 16.04. The upstream developer has indicated that these changes will not be included in another 4.12 release since there are so many significant changes. Xubuntu will prefer stability over feature set for LTS releases, which are supported for 3 years.

We may be able to revisit this in a future release, but this will probably not make it for 16.04

Waz (paviluf) wrote :

That's a bad news because a lot of people will deal again with tearing for years with the news LTS whereas there is already a working fix available...

Waz (paviluf) wrote :

What do you think of shipping an optional Xfwm4 git snapshot until the tearing fix make its way in an official version ?

Waz (paviluf) wrote :

Maybe in the form of a PPA ?

Hairong Zhu (hrzhu) wrote :

Having the same problem on Xubuntu 16.04, for Nvidia users, the tips on arch wiki work around the problem.
https://wiki.archlinux.org/index.php?title=NVIDIA&oldid=422714#Avoid_tearing_with_GeForce_GTX_500.2F600.2F700.2F900_series_cards

Waz (paviluf) wrote :

So Sean what do you think of shipping an optional Xfwm4 git snapshot, maybe in the form of a PPA ?

Sean Davis (bluesabre) wrote :

I'd really recommend building and installing it yourself if you are capable.

Otherwise (and I strongly recommend against using this PPA for anything other than xfwm4) you can find a daily package in my experimental PPA. I can't guarantee any support and it may be there today, gone tomorrow.

https://launchpad.net/~bluesabre/+archive/ubuntu/experimental

Sean Davis (bluesabre) wrote :

Xubuntu 19.10 now includes xfwm 4.13.1, which includes support for tear-free compositing. Check it out!

Changed in xfwm4 (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.