Activating a window from the taskbar doesn't focus it when 'focus follows mouse'

Bug #1292122 reported by Gleb Kozyrev on 2014-03-13
76
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Xfwm4
Fix Released
Medium
xfwm4 (Ubuntu)
Undecided
Unassigned

Bug Description

If 'focus follows mouse' is enabled, clicking a window button in the taskbar raises the window but doesn't give it focus.
This behavior doesn't match the 4.10 release and previous xubuntu versions where the window does get focus.
Annoyingly this makes raising a window with one click, looking at it and then minimizing it with a second click impossible.

I'm running xubuntu 14.04 x64
xfwm4 version 4.11.1 (revision 2b800f4) for Xfce 4.10
xfce4-panel 4.11.0 (Xfce 4.10)

Upstream report: https://bugzilla.xfce.org/show_bug.cgi?id=10747

Related branches

lp:~noskcaj/ubuntu/vivid/xfwm4/4.11.3
Sean Davis (community): Approve (xubuntu technical lead) on 2015-02-15
Ubuntu branches: Pending requested 2015-02-14
In , Gleb-b (gleb-b) wrote :

If 'focus follows mouse' is enabled, clicking a window button in the taskbar raises the window but doesn't give it focus.
This behavior doesn't match the 4.10 release where the window does get focus.
Annoyingly this makes raising a window with one click, looking at it and then minimizing it with a second click impossible.

I'm running xubuntu 14.04 x64
xfwm4 version 4.11.1 (revision 2b800f4) for Xfce 4.10
xfce4-panel 4.11.0 (Xfce 4.10)

Changed in xfwm4:
importance: Unknown → Medium
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfwm4 (Ubuntu):
status: New → Confirmed

I can confirm this in 4.11. eg, you'll tap window foo in the taskbar to bring it to the foreground, but tapping it again won't minimize it unless you first bring window foo (or another window) to the foreground. Tested on Gentoo unstable.

In , unwohlpol (o-k) wrote :

I can also confirm this bug and want do provide some additional infos from a thread I started some time ago. Probably they can be useful for fixing:

http://forum.xfce.org/viewtopic.php?id=8772

Confirming bug on Ubuntu 14.04 LTS.

In , Narann (narann) wrote :

Created attachment 5736
Buttons activated

In , Narann (narann) wrote :

Hi all!

I also use focus on mouse and have this trouble.

I can click as much as I can on the label of a window, it doesn't minimize it...

What make everything weird is that when you click on every taskbar button they are all activated...

Notice I don't have any problem if I use the "Click to focus" (which I never use actually).

Thanks in advance and keep the good job!

Regards,

Dorian

In , Narann (narann) wrote :

Oups, my spec: Linux Mint 17 Qiana XFCE.

xfwm4: 4.11.1-2ubuntu-2
xfdesktop4: 4.11.6-1ubuntu-1

Need more infos?

Regression caused by bug #10508, marking this bug as duplicate of bug 11055 since this is actually a panel bug and not a window manager bug...

Dupe it - followup in 11055.

*** This bug has been marked as a duplicate of bug 11055 ***

The fix belongs in xfwm4 and not in the panel

*** Bug 11055 has been marked as a duplicate of this bug. ***

In , Narann (narann) wrote :

Thanks a lot! :)

Gleb Kozyrev (gkozyrev) wrote :

A fix has been committed: http://git.xfce.org/xfce/xfwm4/commit/?id=1a20a88
Hopefully it will be applied to 14.04 LTS

Changed in xfwm4:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfwm4 - 4.11.3-0ubuntu1

---------------
xfwm4 (4.11.3-0ubuntu1) vivid; urgency=medium

  * New upstream release.
    - Fix maximizing vetically or horizontally tiled windows. LP: #1397922
    - Revert "Experiment with button events." LP: #1394439
    - Use source indication in activate window. LP: #1292122
    - Determine the maximum host name length correctly. LP: #1233107
  * Drop 0001-fix-fullscreen-qt4-behavior-bug-8563.patch,
    02-remove-unused-maximize-button.patch, fixed upstream
 -- Jackson Doak <email address hidden> Sun, 15 Feb 2015 06:24:16 +1100

Changed in xfwm4 (Ubuntu):
status: Confirmed → Fix Released

Thanks for fixing this. I just installed this and it seems to work. This bug had prevented me from upgrading two computers.

*** Bug 11530 has been marked as a duplicate of this bug. ***

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.