gutsy system freezes

Bug #123463 reported by Collins Richey
10
Affects Status Importance Assigned to Milestone
xfwm4 (Ubuntu)
High
Lionel Le Folgoc

Bug Description

I know I'm not the only one who has experienced system lockups lately.

I don't really have a way to characterize this, and launchpad just goes OOPS-548C287 when I try to report the problem.

Here's the scenario.

1. My systems (desktop and laptop) were installed from gutsy tribe 1 alternate, but I run xubuntu-desktop.

2. When the freeze occurs, muse still moves but no clicks from mouse to change desktop or select another option in the current window will work.

3. Someties I can ctl-alt-bksp to restart X, but mostly even this input will be ignored. Hard power-off reboot needed.

4. In all cases, Firefox is running, and I'm browsing email (gmail), forums, or financial site. One freeze was during a download.

5. Other background jobs (cron, print, etc.) that were in progress continue to run.

6. After reboot, no informational messages in /var/log/messages or /var/log/X.....

7. The desktop (nvidia card) and laptop (not nvidia or ati) have different video drivers.

8. This behavior started about 3 weeks ago. I am currently up to date to Tribe 2 +.

Related branches

Revision history for this message
Collins Richey (crichey) wrote :

It's looking like an XFCE bug. I've been running Gnome tonight, and no lockups.

Revision history for this message
Sitsofe Wheeler (sitsofe) wrote :

Thank you for your bug report.

Collins:
Can you still log in on the virtual consoles when this happens (Ctrl-Alt-F1 - Ctrl-Alt-F6, X is on Ctrl-Alt-F7)?

Revision history for this message
Collins Richey (crichey) wrote : Re: [Bug 123463] Re: gutsy system freezes

On 7/2/07, Sitsofe Wheeler <email address hidden> wrote:
> Thank you for your bug report.
>
> Collins:
> Can you still log in on the virtual consoles when this happens (Ctrl-Alt-F1 - Ctrl-Alt-F6, X is on Ctrl-Alt-F7)?
>
> ** Changed in: Ubuntu
> Status: New => Incomplete
>

It's the same situation as ctl-alt-bkspc, hit or miss. Half the time
the keyboard is totally locked; other times, mouse clicks to change
desktop, etc. are igore, but I can still ctl-alt-fn or ctl-alt-bksp.

--
Collins Richey
     If you fill your heart with regrets of yesterday and the worries
     of tomorrow, you have no today to be thankful for.

Revision history for this message
Collins Richey (crichey) wrote :

Net time this happens, I'll see if I can ssh in from my laptop.
Perhaps you could suggest things to look for if I can ssh in.

--
Collins Richey
     If you fill your heart with regrets of yesterday and the worries
     of tomorrow, you have no today to be thankful for.

Revision history for this message
Collins Richey (crichey) wrote :

I would really appreciate suggestions for debugging this. It appears to be exclusively some sort of interaction between Xfce and xorg. I've dropped back to gnome, and the problem does not repeat. At least half the time, I can escape to a console before the keyboard locks totally. If I blow away X and restart gui services, the problem comes back even quicker.

What can I look at from an alternate console that would help you with solving the problem?

Revision history for this message
Collins Richey (crichey) wrote :

I think you can close this bug now. I was never able to get any useful evidence. A few days ago, some xorg changes occurred (iput events? can't remember for shure). Now the problem is gone.

Revision history for this message
Joel Best (joelbest+launchpad) wrote :

I would just like to add that my friend and I are also experiencing this problem. We are both running the latest Xubuntu. I experienced it today so it is not fixed yet.

Revision history for this message
goto (gotolaunchpad) wrote :

Upstream has fixed this bug in their trunk. Please add this patch in xubuntu as well. FYI Redhat has also added the patch to their development branch https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=243735

Refer upstream bug: http://bugzilla.xfce.org/show_bug.cgi?id=3346

Changed in xfce:
status: Unknown → Fix Released
Revision history for this message
Jani Monoses (jani) wrote :

I've experienced this as well, when switching using the tasklist applet in the panel. Alt- tab usually works fine.
Something less annoying than a full reboot is Alt-SysRQ-K, since ctrl-alt-backspace did not work.

Changed in xfwm4:
importance: Medium → High
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

I wanted to wait for a 4.4.2 bugfix release, but it seems it won't come, so I'll patch the package.

Changed in xfwm4:
assignee: nobody → mrpouit
Revision history for this message
Collins Richey (crichey) wrote :

On 7/30/07, Lionel Le Folgoc <email address hidden> wrote:
> I wanted to wait for a 4.4.2 bugfix release, but it seems it won't come,
> so I'll patch the package.
>
> ** Changed in: xfwm4 (Ubuntu)
> Assignee: (unassigned) => Lionel Le Folgoc
>

Thanks. Just an FYI for the future. IMO, you should never wait for
anything to patch the system for a bug that results in a frozen
system. I've spent 3 weeks avoiding xubuntu because of this bug.

--
Collins Richey
     If you fill your heart with regrets of yesterday and the worries
     of tomorrow, you have no today to be thankful for.

Changed in xfwm4:
status: Triaged → In Progress
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

Hi,

I was aware of this bug (seen on Xfce Bugzilla), but as I didn't manage to reproduce it on my gutsy system, I chose to wait for a new bugfix release.
Moreover, as I'm not in the Xubuntu Team, I need to check/subscribe manually to every package/bug. And I only saw this one yesterday, otherwise I would have uploaded the fix sooner. ;)

Anyway, the fix for xfwm4 is ready, and will be uploaded tomorrow, with another fix for xfdesktop4 (for an issue with gtk2 2.11.x too).

Revision history for this message
Collins Richey (crichey) wrote :

On 7/31/07, Lionel Le Folgoc <email address hidden> wrote:
> Hi,
>
> I was aware of this bug (seen on Xfce Bugzilla), but as I didn't manage to reproduce it on my gutsy system, I chose to wait for a new bugfix release.
> Moreover, as I'm not in the Xubuntu Team, I need to check/subscribe manually to every package/bug. And I only saw this one yesterday, otherwise I would have uploaded the fix sooner. ;)
>
> Anyway, the fix for xfwm4 is ready, and will be uploaded tomorrow, with
> another fix for xfdesktop4 (for an issue with gtk2 2.11.x too).
>

Cool, thanks.

--
Collins Richey
     If you fill your heart with regrets of yesterday and the worries
     of tomorrow, you have no today to be thankful for.

Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

xfwm4 (4.4.1-2ubuntu2) gutsy; urgency=low

  * debian/patches/00_fix_xfwm4_hang.patch: fixes system freeze when linked
    with gtk2 2.11.x (see Xfce #3346). (LP: #123463)

 -- Lionel Le Folgoc <email address hidden> Tue, 31 Jul 2007 20:53:06 +0200

Changed in xfwm4:
status: In Progress → Fix Released
Revision history for this message
KL Gan (yjl-chn) wrote :

I am suffering this bug all through July (since upgraded to Gutsy)~~~~
And I did search on google for any help, but it is a little strange , it seems nobody met such a problem.
At the beginning I met this problem, I though it should be a XFWM4 bug. Even if I keep updating every day, this problem always occurs till today ( Aug. 2).

But I have a workaround , that's , using metacity (the default window manager of GNOME) to replace XFWM4 every time when I login XFCE4. This works well. (Of course I am keeping updating every day to confirm whether or not it has been fixed some day).

This morning, when I updated Gutsy, I noticed the bug fix log " * debian/patches/00_fix_xfwm4_hang.patch: fixes system freeze when linked with gtk2 2.11.x (see Xfce #3346). ". Huh, maybe this fix would work for this problem? Now I am using XFWM4 ( not metacity ) , till now no freezing.

Revision history for this message
KL Gan (yjl-chn) wrote :

Some information:
1) Reproduce:
It's easier to reproduce it if you keep following software running all together:
    ■ WM setting: Window gets focus while mouse pointer moves over.
    ■ terminal (xfce4-terminal or gnome-terminal )
    ■ firefox
    ■ gthumb (with a picture file opened )
    ■ gimp ( with a picture file opened )
    ■ thunar
    then keep switching between those windows, and do some operations you like, such as: move window, resize window, etc.

2) Emergency solution:
   Once you find any window does not responding, stop any operation IMMEDIATELY. (if you keep doing some operations, e.g. click in other window, try to switch to other workspace, etc. the system will freeze completely, that means you have no choice except shutting down)
   Then press CTRL-ALT-BKSPC , this can restart X, and you can login again.

Revision history for this message
Jani Monoses (jani) wrote :

KL Gan, do you reproduce this with the latest xfwm4 that was uploaded today by Lionel?

Revision history for this message
KL Gan (yjl-chn) wrote :

Till now, no system freezing occurs. I will keep checking it.

Revision history for this message
KL Gan (yjl-chn) wrote :

I think this bug has been fixed by this patch:
    * debian/patches/00_fix_xfwm4_hang.patch: fixes system freeze when linked
    with gtk2 2.11.x (see Xfce #3346)

Since I updated it on Aug. 2, no system freeze any more by using xfwm4.

Good job! Thanks!

Revision history for this message
Wietze Helmantel (helmantel) wrote :

I was about to enter a new bug report, but noticed this one instead. I started having system freezes yesterday after another upgrade session to gutsy (the ordinary every morning type of upgrade). The system freeze is unrecoverable unfortunately and rebooting the system is the *only* option. Does anyone encounter similar problems at the moment?

An ordinary every day session on my laptop would include running Compiz Fusion, Firefox, Evolution, Gnome Terminal, Pidgin, Tomboy notes, (...).

Revision history for this message
Wietze Helmantel (helmantel) wrote :

Update: I just had to reboot again after another system freeze. Since I expected something like this to happen, I had a terminal open with a tail on my syslog. When the system freezes, everything but the X server seems to continue in an ordinary fashion. Also, I noticed that messages concerning me pressing the power or suspend button are logged, so the system does seem to pick up these keypresses. Ctrl-Alt-backspace and Ctr-Alt-Fx do not do anything at all.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.