Xfwm4's 'dialog' window has an unused maximise-button

Bug #1177116 reported by Jackson Doak on 2013-05-06
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
Xfwm4
Fix Released
Low
xfwm4 (Ubuntu)
Low
Jackson Doak

Bug Description

The maximise button in ubiquity does nothing, this happenes both in a live session and the ubiquity stand-alone.
A screenshot is attached

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: ubiquity 2.15.1
ProcVersionSignature: Ubuntu 3.9.0-0.4-generic 3.9.0
Uname: Linux 3.9.0-0-generic i686
ApportVersion: 2.10-0ubuntu1
Architecture: i386
CasperVersion: 1.332
Date: Mon May 6 22:08:28 2013
InstallCmdLine: file=/cdrom/preseed/xubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
LiveMediaBuild: Xubuntu 13.10 "Saucy Salamander" - Alpha i386 (20130506)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jackson Doak (noskcaj) wrote :
Jackson Doak (noskcaj) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1177116

tags: added: iso-testing
Phillip Sz (phillip-sz) on 2013-05-07
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Chris Wilson (notgary) on 2013-05-27
Changed in hundredpapercuts:
milestone: none → papercuts-s-ubiquity
Colin Watson (cjwatson) wrote :

There isn't supposed to be a maximise button, I think. We don't have one when Ubiquity is running on Ubuntu desktop images.

the this is a bug in the themes of the various flavours, not ubiquity.

On Fri, Jun 7, 2013 at 10:12 PM, Colin Watson <email address hidden>wrote:

> There isn't supposed to be a maximise button, I think. We don't have
> one when Ubiquity is running on Ubuntu desktop images.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1177116
>
> Title:
> maximise button does nothing in Ubiquity
>
> Status in One Hundred Paper Cuts:
> New
> Status in “ubiquity” package in Ubuntu:
> Confirmed
>
> Bug description:
> The maximise button in ubiquity does nothing, this happenes both in a
> live session and the ubiquity stand-alone.
> A screenshot is attached
>
> ProblemType: Bug
> DistroRelease: Ubuntu 13.10
> Package: ubiquity 2.15.1
> ProcVersionSignature: Ubuntu 3.9.0-0.4-generic 3.9.0
> Uname: Linux 3.9.0-0-generic i686
> ApportVersion: 2.10-0ubuntu1
> Architecture: i386
> CasperVersion: 1.332
> Date: Mon May 6 22:08:28 2013
> InstallCmdLine: file=/cdrom/preseed/xubuntu.seed boot=casper
> initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
> LiveMediaBuild: Xubuntu 13.10 "Saucy Salamander" - Alpha i386 (20130506)
> MarkForUpload: True
> ProcEnviron:
> TERM=xterm
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: ubiquity
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hundredpapercuts/+bug/1177116/+subscriptions
>

Changed in ubiquity (Ubuntu):
importance: Undecided → Low
Jackson Doak (noskcaj) on 2013-07-10
tags: added: amd64 lubuntu
Changed in hundredpapercuts:
status: New → Confirmed
Jackson Doak (noskcaj) on 2013-07-21
Changed in xubuntu-artwork (Ubuntu):
status: New → Confirmed
Changed in lubuntu-artwork (Ubuntu):
status: New → Confirmed
Jackson Doak (noskcaj) on 2013-07-26
tags: added: bitesize

I believe this is a bug in the window managers, or in the way the window is called rather than the themes.

Changed in xubuntu-artwork (Ubuntu):
status: Confirmed → Invalid
Dimitri John Ledkov (xnox) wrote :

From screenshot it's hard to tell if ubiquity is running from the live session (e.g. Try $distro -> then launch ubiquity) or from ubiquity-dm (e.g. Install $distro straight away). Potentially window decorators can be wrong/different in one or both cases and possibly it needs to be fixed in multiple places.

As far as I remember we should not have maximize,resize,minimize buttons anywhere.

Simon Steinbeiß (ochosi) wrote :

This issue could be addressed by setting a different window-type in Ubiquity (http://www.gtk.org/api/2.6/gtk/GtkWindow.html#gtk-window-set-type-hint), certain types (e.g. menu) hide the maximize and minimize button.

Pasi Lallinaho (knome) wrote :

I can confirm the Maximize button is shown both when running via "Install now" and when running via the Live session. It doesn't work in either mode.

In the "Install now" -mode, only the maximize and the menu button are shown. When running via the Live session, also minimize and close-buttons are shown.

Pasi Lallinaho (knome) on 2013-09-18
Changed in lubuntu-artwork (Ubuntu):
status: Confirmed → Invalid
Simon Steinbeiß (ochosi) wrote :

From reading through ubiquity's code, it seems that it sets the window-type-hint to dialog, which seems fine.
Xfwm4 however shows maximize-buttons in all dialog windows, sometimes non-functional ones. I assume that this is a design decision in Xfwm4, but it can also be considered a bug.

Pasi Lallinaho (knome) wrote :

Lubuntu folks, if you still can confirm the same bug in Lubuntu, please file a new bug; it is different from this one.

affects: ubiquity (Ubuntu) → xfwm4 (Ubuntu)
summary: - maximise button does nothing in Ubiquity
+ Xfwm4's 'dialog' window has an unused maximise-button
Pasi Lallinaho (knome) on 2013-10-10
no longer affects: lubuntu-artwork (Ubuntu)
no longer affects: xubuntu-artwork (Ubuntu)
Changed in xfwm4 (Ubuntu):
status: Confirmed → Triaged
Dimitri John Ledkov (xnox) wrote :

If there is a window type hint that does not show maximize button under: xfwm4, compiz, metacity; it'd be happy to change the window type hint to a better one.

Changed in hundredpapercuts:
importance: Undecided → Low
status: Confirmed → Triaged
tags: added: patch

The patch can be tested by installing xfwm4 from my Testing PPA.

https://launchpad.net/~thad-fisch/+archive/test

Martin Pitt (pitti) on 2014-04-09
Changed in xfwm4 (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfwm4 - 4.11.1-2ubuntu2

---------------
xfwm4 (4.11.1-2ubuntu2) trusty; urgency=medium

  * Don't have a maximise button if it won't work. LP: #1177116
 -- Jackson Doak <email address hidden> Sat, 05 Apr 2014 07:34:09 +1100

Changed in xfwm4 (Ubuntu):
status: Fix Committed → Fix Released
Pasi Lallinaho (knome) on 2014-04-14
Changed in xfwm4 (Ubuntu):
assignee: nobody → Jackson Doak (noskcaj)

Windows with a fixed size (about dialogs,..) have an unnecessary maximize button.

xfwm4 4.11.1

Created attachment 5495
Remove unused maximize button

Changed in xfwm4:
importance: Undecided → Unknown
status: New → Unknown
Changed in hundredpapercuts:
status: Triaged → Fix Released
Changed in xfwm4:
importance: Unknown → Low
status: Unknown → Confirmed

*** Bug 11309 has been marked as a duplicate of this bug. ***

Tested the patch and it works as it should. Pushed to master:
http://git.xfce.org/xfce/xfwm4/commit/?id=78b5c3c48a187ae54d97369a738b8a18e31e459a

Changed in xfwm4:
status: Confirmed → Fix Released

Not completely fixed yet. Some ubiquity windows still have a maximize button and are not resizable.

http://www.zimagez.com/zimage/screenshot-081214-170915.php

tags: added: vivid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.