Ubuntu

GTK3 Grab/Move Triggered on Mouse Click

Reported by Adriano Macchietto on 2012-05-20
92
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Xfwm4
Unknown
Unknown
xfwm4 (Ubuntu)
High
Lionel Le Folgoc
Precise
Undecided
Unassigned
Quantal
High
Lionel Le Folgoc

Bug Description

When an app window such as evince is left clicked grab mode is automatically entered and the window moves somewhere else on the screen. This bug seems to occur in Xubuntu 12.04 with XFCE.

Some discussion of the same problem can be found here:

https://bbs.archlinux.org/viewtopic.php?id=140530

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk+3.0 (Ubuntu):
status: New → Confirmed
ian_hawdon (ian-hawdon) wrote :

This could be related to an issue i'm having. GTK3 applications are, for no apparent reason, highlighting text, moving sliders, when i put my mouse of them. Can't find any other posts about it, but this seems the closest. I don't know where to start bug reporting this one, as it's not tied to one specific application.

Pasi Lallinaho (knome) wrote :

Ian, that sounds like a different bug, so should be reported separately. If it's about GTK3, start from https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+filebug

Simon Steinbeiß (ochosi) wrote :

This bug is pretty reproducible for me, especially when trying to click the resize-grip as described in a duplicate bug-report.

I assume that users of regular Ubuntu don't experience this because they're using the Ambiance-theme, which doesn't show a resize-grip by default. Could any of you please test whether you can reproduce this bug with another gtk(3)-theme, preferably Ambiance?

It still occurs with Ambiance theme. The window can enter move mode when clicking anywhere in the window. It seems to occur when window focus is changed to the gtk3 window.

apsaras (c-launchpad1) wrote :

This bug happens for me. I'm using xubuntu 12.04 (xfce) and Greybird style (under Settings -> Settings Manager -> Appearance -> Style; is that what people mean by theme? I don't see an Ambiance option).

@apsaras you need to install the light-themes package

neptvn on ubuntuforums

http://ubuntuforums.org/showthread.php?s=3435adbbb8167ce869618b0a9d3286c0&t=1908474&page=2

posted a youtube video of the bug in question

http://www.youtube.com/watch?v=Ir2IDxFKBFA

It seems to affect only gtk3 apps.

upromis (promisman) wrote :

Same here on Ubuntu Studio 12.04 (Xfce) - left click on menu bar(empty space)/tool bar activates grab/move window mode which starts when left clicked inside window.
It looks like only gtk3 (nautilus, gnome terminal...) It does not matter which theme.
Thunar does not reacts this way.

AkhIL (akhilman) wrote :

Same problem can be reproduced when with menubar:
1. Open nautilus
2. Drag window by clicking and moving window with empty menubar or toolbar area
3. Click to any menu entry on menu bar.
4. Go out of menu
Sometimes window jumps right-down and becomes grabet until mouse click

And most annoying for me is ShotWell:
1. Open any image
2. Open color correction dialog
3. Move dialog somewhere
4. Click and drag levels slider
5. Release mouse button
Once again dialog jumps somewhere.

Bug seems related to xfwm both 4.8 and 4.10. I can't reproduce this bug with fluxbox

Debian Sid amd64

Conrad (conrad-couture) wrote :

This problem happens to me also. The application to which this happens most is Bluefish. I will click inside the Bluefish window to change tab or to select text and it will initiate a move window.

Jamie Macdonald (jamie-alban) wrote :

This happens to me on Ubuntu Studio 12.04 (Xfce)
has happened in nautilus, transmission
The window jumps across the screen away from the cursor, entering dragging mode.

The bug has been addressed upstream.

https://bugzilla.gnome.org/show_bug.cgi?id=675613

Now we just need to bring it down.

affects: gtk+3.0 (Ubuntu) → ubuntu
Changed in ubuntu:
importance: Undecided → High
status: Confirmed → Triaged
affects: ubuntu → xfwm4 (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfwm4 (Ubuntu Precise):
status: New → Confirmed
Changed in xfwm4 (Ubuntu Quantal):
assignee: nobody → Lionel Le Folgoc (mrpouit)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfwm4 - 4.10.0-2ubuntu1

---------------
xfwm4 (4.10.0-2ubuntu1) quantal; urgency=low

  * Merge from Debian experimental, remaining Ubuntu change:
    - debian/control: demote xfwm4-themes from Recommends to Suggests, per
      <https://blueprints.launchpad.net/ubuntu/+spec/other-p-xubuntu-cleanthemes>.
  * debian/patches:
    - 0002-Implement-NET_WM_MOVERESIZE_CANCEL-message-bug-8949.patch: added,
      fix window grab/move triggered on mouse click with gtk3. lp: #1001936

xfwm4 (4.10.0-2) experimental; urgency=low

  * debian/patches:
    - 0001-Revert-part-of-git-commit-8637c3a-as-this-breaks-del added, fix
      deletion of current workspace sometime deleting the last one.
 -- Lionel Le Folgoc <email address hidden> Sun, 29 Jul 2012 19:43:55 +0200

Changed in xfwm4 (Ubuntu Quantal):
status: In Progress → Fix Released

The same patch should work with the 4.8 branch. Can we get this fixed for 12.04?

Hello Adriano, or anyone else affected,

Accepted xfwm4 into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xfwm4/4.8.3-1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xfwm4 (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Pasi Lallinaho (knome) wrote :

Can confirm verification-done. We tested on two updated systems, one new installation and one live CD, and we didn't see the bug.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfwm4 - 4.8.3-1ubuntu1.1

---------------
xfwm4 (4.8.3-1ubuntu1.1) precise-proposed; urgency=low

  * debian/patches:
    - 01_implement-NET_WM_MOVERESIZE_CANCEL-message.patch: added,
      fix window grab/move triggered on mouse click with gtk3. lp: #1001936
 -- Lionel Le Folgoc <email address hidden> Wed, 15 Aug 2012 17:57:09 +0200

Changed in xfwm4 (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.