Ubuntu

ProSavage-DDR not correctly configured in all systems

Reported by bluegeek on 2004-10-06
6
Affects Status Importance Assigned to Milestone
xfree86 (Ubuntu)
Medium
Fabio Massimo Di Nitto

Bug Description

I have a Shuttle SK41G with an integrated ProSavage-DDR video card and a CRT
Monitor. I had to add an new option (Option "UseBios" "no") to the XF86Config-4
file as pointed at http://www.probo.com/timr/savage40.html
>>
ProSavage-DDR Refresh Rates A number of users have complained that they get
wacky refresh rates when using the 1.1.27t driver. There is apparently some kind
of conflict between this driver and the BIOS found on some ProSavage-DDR
motherboard that causes anything but the default refresh rate to be set wrong.
There are two workaround for this. One is to turn off the use of the BIOS by adding
     Option "UseBios" "no"
in the "Device" section of your XF86Config file. Another is to try the driver
below that was built from the 4.4.0 beta 2 source base. It works on 4.3.0, and
reportedly solves the refresh problem.
<<

Xfree works now in Ubuntu after adding this option and restarting GDM (I hope
Xorg will fix this in the future but it will be nice to have this option unset
in the this release).

blueboy@pandora-ubuntu:~ $ lspci
0000:00:00.0 Host bridge: VIA Technologies, Inc. VT8375 [KM266/KL266] Host Bridge
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8633 [Apollo Pro266 AGP]
0000:00:0a.0 Multimedia video controller: Brooktree Corporation Bt878 Video
Capture (rev 11)
0000:00:0a.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture
(rev 11)
0000:00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
0000:00:0c.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host
Controller (rev 46)
0000:00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 80)
0000:00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 80)
0000:00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 80)
0000:00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
0000:00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
0000:00:11.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
0000:00:11.5 Multimedia audio controller: VIA Technologies, Inc.
VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
0000:01:00.0 VGA compatible controller: S3 Inc. VT8375 [ProSavage8 KM266/KL266]
0000:00:00.0 Class 0600: 1106:3116
0000:00:01.0 Class 0604: 1106:b091
0000:00:0a.0 Class 0400: 109e:036e (rev 11)
0000:00:0a.1 Class 0480: 109e:0878 (rev 11)
0000:00:0b.0 Class 0200: 10ec:8139 (rev 10)
0000:00:0c.0 Class 0c00: 1106:3044 (rev 46)
0000:00:10.0 Class 0c03: 1106:3038 (rev 80)
0000:00:10.1 Class 0c03: 1106:3038 (rev 80)
0000:00:10.2 Class 0c03: 1106:3038 (rev 80)
0000:00:10.3 Class 0c03: 1106:3104 (rev 82)
0000:00:11.0 Class 0601: 1106:3177
0000:00:11.1 Class 0101: 1106:0571 (rev 06)
0000:00:11.5 Class 0401: 1106:3059 (rev 50)
0000:01:00.0 Class 0300: 5333:8d04

Hi,
   i created a slightly modified savage driver that i would like you to test.
Please do the following steps:

cd /usr/X11R6/lib/modules/drivers
mv savage_drv.o savage_drv.o.backup
wget http://people.ubuntulinux.org/~fabbione/savage_drv.o

Comment the Option "UseBios" "no" in the config file.
stop X and start X again.

Let me know if it works.

Basically I added a check to so that UseBios defaults to no if there is a
ProSavage-DDR
card, and it can still be overridden via the config file.

If you want this fix included into warty you need to tell me the results asap.
Otherwise it will be for the next release.

Fabio

bluegeek (bluegeek) wrote :

I've tested it following your instructions and now it works without the UseBios
option. Thanks a lot.

Thanks for the testing. The patch will be included in the next upload.

Fabio

Fix with xfree86_4.3.0.dfsg.1-6ubuntu24 upload.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.