AttributeError: 'PanelConfig' object has no attribute 'source'

Bug #1762779 reported by Alistair Buxton on 2018-04-10
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Xfce Panel Switch
Undecided
Unassigned
xfpanel-switch (Ubuntu)
Undecided
Unassigned

Bug Description

To reproduce:

1. Open the main system menu.
2. Drag an icon from the menu onto the panel.
3. Click "create launcher".
4. Open panel switcher.
5. Click "Save Configuration" button.
6. Click "Save Configuration" button.

Result:

Nothing happens. The window does not close, and clicking cancel no longer works either. The following error is printed on the terminal:

:~$ xfpanel-switch
Traceback (most recent call last):
  File "/usr/share/xfpanel-switch/xfpanel-switch/xfpanel-switch.py", line 221, in on_save_clicked
    self.save_configuration(name)
  File "/usr/share/xfpanel-switch/xfpanel-switch/xfpanel-switch.py", line 209, in save_configuration
    PanelConfig.from_xfconf(self.xfconf).to_file(filename)
  File "/usr/share/xfpanel-switch/xfpanel-switch/panelconfig.py", line 63, in from_xfconf
    pc.find_desktops()
  File "/usr/share/xfpanel-switch/xfpanel-switch/panelconfig.py", line 113, in find_desktops
    if self.check_desktop(desktop_path):
  File "/usr/share/xfpanel-switch/xfpanel-switch/panelconfig.py", line 87, in check_desktop
    bytes = self.get_desktop_source_file(path).read()
  File "/usr/share/xfpanel-switch/xfpanel-switch/panelconfig.py", line 125, in get_desktop_source_file
    if self.source is None:
AttributeError: 'PanelConfig' object has no attribute 'source'

It is also possible to repduce from the command line. Follow steps 1-3 above and then open a terminal and run

    xfpanel-switch save foo

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xfpanel-switch 1.0.6-0ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-13.14-generic 4.15.10
Uname: Linux 4.15.0-13-generic x86_64
ApportVersion: 2.20.9-0ubuntu4
Architecture: amd64
CurrentDesktop: XFCE
Date: Tue Apr 10 17:23:14 2018
InstallationDate: Installed on 2018-04-10 (0 days ago)
InstallationMedia: Xubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180410)
PackageArchitecture: all
SourcePackage: xfpanel-switch
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Alistair Buxton (a-j-buxton) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfpanel-switch (Ubuntu):
status: New → Confirmed
Kev Bowring (flocculant) wrote :

Not seeing this on the daily.

Kev Bowring (flocculant) wrote :

But can confirm on my install locally.

Sean Davis (bluesabre) on 2018-04-15
Changed in xfpanel-switch:
status: New → Fix Committed
description: updated
Sean Davis (bluesabre) on 2018-04-17
Changed in xfpanel-switch:
milestone: none → 1.0.7
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfpanel-switch - 1.0.7-0ubuntu1

---------------
xfpanel-switch (1.0.7-0ubuntu1) bionic; urgency=medium

  * New upstream bugfix and translation release.
    - Fixes AttributeError on save (LP: #1762779)
  * d/control:
    - Add build-depend on dh-python for recent packaging changes

 -- Sean Davis <email address hidden> Tue, 17 Apr 2018 06:16:30 -0400

Changed in xfpanel-switch (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints