Broken Launcher Icons in Xubuntu Classic Panel Dock

Bug #1575996 reported by Wes on 2016-04-28
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Xfce4 Panel Profiles
Fix Released
Undecided
Unassigned
xfpanel-switch (Ubuntu)
High
Unassigned

Bug Description

Legacy launcher icons for programs that are no longer installed, including the Ubuntu Software Center, AbiWord , GIMP, and GMusicBrowser are still present in Xubuntu 16.04 live session when the Xubuntu Classic Panel Theme is set. Clicking the icons will display an error message box "Failed to execute child process "/usr/bin/<packagename>" (No such file or directory)" , since those applications are no longer packaged by default in 16.04.

To reproduce, go to Settings -> Xfce Panel Switch , select "Xubuntu Classic" , click the apply configuration gears icon , and look at the dock on the bottom of the screen.

Find attached screenshot.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: xfdesktop4 4.12.3-2ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CasperVersion: 1.376
CurrentDesktop: XFCE
Date: Thu Apr 28 01:15:19 2016
LiveMediaBuild: Xubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xfdesktop4
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Wes (wesinator) wrote :
Wes (wesinator) on 2016-04-28
summary: - Ubuntu Software Center Icon Still Present in Xubuntu Classic Panel Dock
+ Broken Launcher Icons in Xubuntu Classic Panel Dock
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfdesktop4 (Ubuntu):
status: New → Confirmed
Revision history for this message
David Pearson (akxwi-dave) wrote :

Also affect early builds of Yakkety.. (16.10)

Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1575996

tags: added: iso-testing
Sean Davis (bluesabre) on 2016-05-14
affects: xfdesktop4 (Ubuntu) → xfpanel-switch (Ubuntu)
Revision history for this message
Sean Davis (bluesabre) wrote :

Two improvements that should be made here:
1) The more obvious one, the default launchers need to be updated for 16.04+
2) xfpanel-switch should be able to check if an executable exists before adding its launcher to the panel.

Changed in xfpanel-switch (Ubuntu):
importance: Undecided → High
tags: added: yakkety
Wes (wesinator) on 2017-10-26
tags: added: artful
Revision history for this message
Sean Davis (bluesabre) wrote :

Fix committed: https://bazaar.launchpad.net/~xfpanel-switch-dev/xfpanel-switch/trunk/revision/108

This change validates imported launchers, resets stored xfce4-panel settings, and no longer dies when the panel is not running.

Changed in xfpanel-switch:
status: New → Fix Committed
Sean Davis (bluesabre) on 2018-03-27
Changed in xfpanel-switch:
milestone: none → 1.0.5
Sean Davis (bluesabre) on 2018-03-27
Changed in xfpanel-switch:
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfpanel-switch - 1.0.6-0ubuntu1

---------------
xfpanel-switch (1.0.6-0ubuntu1) bionic; urgency=medium

  * New upstream bugfix and translations release.
    - Fixes broken launchers with Classic layout (LP: #1575996)
  * d/compat, d/rules:
    - Bump debhelper to 11
  * d/rules:
    - Bump Standards Version to 4.1.3
  * d/copyright:
    - Use secure URL for Format

 -- Sean Davis <email address hidden> Mon, 26 Mar 2018 21:35:01 -0400

Changed in xfpanel-switch (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers