xfonts-mona installs font to wrong directory

Bug #29724 reported by Jun Kobayashi on 2006-01-26
10
Affects Status Importance Assigned to Milestone
xfonts-mona (Ubuntu)
Medium
MOTU Reviewers Team

Bug Description

the fonts installed in /usr/X11R6/lib/X11/fonts/misc, but those should be installed in /usr/share/X11/fonts/misc/.

debdiff for the follows.

  * Change font install path to /usr/share/X11/fonts/misc.
  * debian/control:
    - add bdftopcf and xfonts-utils to Build-Depends-Indep field.
  * debian/compat:
    - set debhelper compatibility level to 4.
  * debian/copyright:
    - add copyright lines.
    - write up license description.

Ming Hua (minghua) wrote :

I like this patch, except one thing:

Since xutils depends on xfonts-utils, why is it necessary to add xfonts-utils to B-D-I separately?

We probably should do similar things to all bitmap fonts there, as there seem to be many CJK bitmap fonts, and some of them are heavily used.

Thank you for the comment.

It seems that xfonts-utils is not necessary on B-D-I, I omitted that.

Changed in xfonts-mona:
assignee: nobody → motureviewers
atie (atie-at-matrix) wrote :

For xfonts-baekmuk, it installs fonts to /usr/X11R6/lib/X11/fonts/75dpi and depends on xutils.

My question is that do we need to re-package all of them from now on for /usr/share/X11/fonts/misc without any hassel or is there a simply way to do the fix for time being regarding X in transition time.

When is flawless timing for doing this fix?

Ming Hua (minghua) wrote :

I have tested the second patch, it builds in pbuilder, installs well and seems to be working.

I'll see if I can find an MOTU to upload this.

Daniel Holbach (dholbach) wrote :

I uploaded it. Thanks a lot.

Changed in xfonts-mona:
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers