Cannot create an empty file on the desktop

Bug #754595 reported by gohai on 2011-04-08
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xfdesktop
Unknown
Unknown
xfdesktop4 (Ubuntu)
Low
Lionel Le Folgoc

Bug Description

Binary package hint: xfdesktop4

-Ubuntu 11.04 amd64
-Xubuntu 11.04 amd64
-Mythbuntu 11.04 amd64

When I open up the context menu on the desktop and select Create From Template > Empty File, no such file is being created.

This works inside a folder (I am using the default thunar) where I can bring up the context menu, select Create Document > Empty File and a file gets created.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xfdesktop4 4.8.1-1ubuntu2
Uname: Linux 2.6.39-020639rc1-generic x86_64
Architecture: amd64
Date: Fri Apr 8 14:40:34 2011
InstallationMedia: Xubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xfdesktop4
UpgradeStatus: No upgrade log present (probably fresh install)

WORKAROUND:
Please create the empty file in Thunar, the file manager. It will show up on Desktop.

Related branches

gohai (gottfried-haider) wrote :
tags: added: iso-testing
Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

I can reproduce this on an upgrade from Xubuntu 10.10 to Xubuntu Natty beta2. I am able to create folders on the Desktop, but not files.

Thanks for taking the time to make Ubuntu better!

Changed in xfdesktop4 (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in xfdesktop4 (Ubuntu):
importance: Medium → Low
Alessandro Losavio (alo21) wrote :

I have this problem too.

Xubuntu 11.04 Beta2 amd 64

Alessandro Losavio (alo21) wrote :

I have this problem too.

Mytbuntu 11.04 Beta2 amd 64

description: updated
Alessandro Losavio (alo21) wrote :

Gohai, could you change the status of the bug in xfdesktop New-->Confirmed ?

Thanks.

Charlie Kravetz (charlie-tca) wrote :

Ṕlease don't. The Xubuntu bug is already marked triaged. The upstream bug is marked new, which is the status on Xfce bugzilla. It will change when the developers at Xfce change it.

Il 12/04/2011 22:32, Charlie Kravetz ha scritto:
> Ṕlease don't. The Xubuntu bug is already marked triaged. The upstream
> bug is marked new, which is the status on Xfce bugzilla. It will change
> when the developers at Xfce change it.
But I have the same problem in Mythbuntu too. Do you think it is better
to change or not?
I would like your opinion please.

Thanks, Alessandro

gohai (gottfried-haider) wrote :

Alessandro: The bug is already taken care of - there is no use in changing status.

Alessandro Losavio (alo21) wrote :

Il 13/04/2011 14:07, gohai ha scritto:
> Alessandro: The bug is already taken care of - there is no use in
> changing status.
Ok. thanks for letting me clear the doubt.

Thancks, Alessandro

wobblybob (martincooper9) wrote :

I have this problem too.

Xubuntu 11.04 Beta2 [20110413.2] i386 iso testing, a new file cannot be created on the desktop and one created in the home folder cannot be copied and pasted to the desktop either via the right click menu [as it's greyed out] or using the shortcut keys. But the file can be dragged and dropped onto the desktop from the home folder.

Alessandro Losavio (alo21) wrote :

I have this problem too.
Xubuntu 11.04 Final amd64

Charlie Kravetz (charlie-tca) wrote :

This issue was reported to Xfce Bugtracker as seen above. It will not be fixed for Xubuntu 11.04 release until upstream has a fix for it. Thanks for helping improve Xubuntu.

description: updated
Francesco Ruvolo (ruvolof) wrote :

I found this bug on Oneiric alpha 1.

Alessandro Losavio (alo21) wrote :

I found this bug on Oneiric alpha 1 amd64 too.

Charlie Kravetz (charlie-tca) wrote :

Actually, this bug should be pretty easy to find, since it is in the release notes for Xbuntu 11.04. It was reported during the natty development cycle, and has been reported to upstream. There is no estimate for a fix, but as noted above, there is a really good workaround.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Lionel Le Folgoc (mrpouit) wrote :

It's fixed upstream in xfdesktop 4.8.2 that will be merged from Debian unstable after the alpha 1 release.

tkoun (tkoun) wrote :

any chance of getting this into the koshi ppa for maverick? that would be great for those of us still on maverick until natty gets the same level of stability
thanx a lot.

Changed in xfdesktop4 (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Lionel Le Folgoc (mrpouit)
Changed in xfdesktop4 (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfdesktop4 - 4.8.2-1ubuntu1

---------------
xfdesktop4 (4.8.2-1ubuntu1) oneiric; urgency=low

  * Merge with Debian unstable, remaining Ubuntu changes:
    - debian/patches:
      + xubuntu_hide-ugly-resize-grip.patch: disable resize grips for xfdesktop's
        root windows. lp: #709279
      + series: added.

  * Bugs closed by this new upstream release:
    - crash with SIGSEGV in g_closure_invoke() lp: #724816
    - crash with SIGSEGV in g_type_check_instance_is_a() lp: #733822
    - explicit gamin dependency dropped lp: #776503
    - crash on exit with xorg-server 1.10 lp: #711571
    - Cannot create an empty file on the desktop lp: #754595
 -- Lionel Le Folgoc <email address hidden> Sat, 11 Jun 2011 22:39:00 +0200

Changed in xfdesktop4 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.