Jaunty iso-testing click Applications menu, it disappears

Bug #325374 reported by Charlie Kravetz on 2009-02-04
50
Affects Status Importance Assigned to Milestone
xfdesktop4 (Ubuntu)
Critical
Unassigned

Bug Description

Binary package hint: xfdesktop4

RELEASE: Jaunty 9.04 Alpha4 release candidate
CD/DVD VARIANT: 32-bit and 64-bit, Xubuntu Alternate and Desktop
ISO BUILD: 20090204 Jaunty Alpha4 release candidate

SYMPTOMS: All Cd's, all versions, click on Applications menu, it disappears from the panel.

ProblemType: Crash
Architecture: i386
Disassembly: 0x0:
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/lib/xfce4/panel-plugins/xfce4-menu-plugin
Package: xfdesktop4 4.5.99.1-0ubuntu1
ProcCmdline: /usr/lib/xfce4/panel-plugins/xfce4-menu-plugin socket_id 16777256 name xfce4-menu id 1 display_name Xfce\ Menu size 24 screen_position 1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: xfdesktop4
StacktraceTop:
 ?? ()
 ca_cache_store_sound () from /usr/lib/libcanberra.so.0
 ca_lookup_sound_with_callback ()
 ca_lookup_sound () from /usr/lib/libcanberra.so.0
 alsa_driver_play ()
Title: xfce4-menu-plugin crashed with SIGSEGV in ca_cache_store_sound()
Uname: Linux 2.6.28-6-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

WORKAROUND: After the menu disappears, right-click the pane, left-click "add to panel"; left-click "Xfce Menu" . This adds Xfce Menu to the panel and allows you to continue. That menu does not disappear.

Charlie Kravetz (charlie-tca) wrote :
description: updated

This is a problem that xubuntu-default-settings isn't quite happy with Xfce 4.6. Removing this package, and then clobbering .config/xfce4 will cause a new xfconf database to be generated, although the Xubuntu branding will go poof if you do this.

Changed in xfdesktop4:
importance: Undecided → Critical
milestone: none → jaunty-alpha-5
status: New → Triaged

StacktraceTop:?? ()
ca_cache_store_sound (theme=0x91a1a64 "freedesktop",
ca_lookup_sound_with_callback (f=0x9653cb8,
ca_lookup_sound (f=0x9653cb8, sound_path=0x0, t=0x91ff470,
alsa_driver_play (c=0x91ffef0, id=0, proplist=0x930acf0,

Lionel Le Folgoc (mrpouit) wrote :

xubuntu-default-settings' config files have been migrated to xfconf, so this bug should hopefully be fixed.

Charlie Kravetz (charlie-tca) wrote :

I can confirm this is fixed in Jaunty 9.04 development version dated 2009-02-07.

Changed in xfdesktop4:
status: Triaged → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers