[MRE] Please update xfdesktop4 to 4.11.8 in Trusty

Bug #1365965 reported by Thaddaeus Tintenfisch on 2014-09-05
54
This bug affects 8 people
Affects Status Importance Assigned to Milestone
xfdesktop4 (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

[Impact]
A new upstream bugfix release of xfdesktop4 has been released. This fixes various minor issues which have been reported on launchpad:

Fixes in 4.11.8
- Infobar in desktop settings for <2 desktops (LP: #1365382)
- Background color resets when starting settings (LP: #1313728)
- Wallpaper spans multiple screens on reload (LP: #1312577)

Fixes in 4.11.7
- Desktop icons not alligned evenly from sides (LP: #595668)
- 'xfdesktop --reload' no longer cycles wallpaper image (LP: #1293287)
- Arrangement of desktop icons is not saved after resolution change (LP: #1307251)
- No confirmation prompt when force-deleting (SHIFT+DEL) (LP: #1315716)

On top of that, the accountsservice patch for xfdesktop4 has been updated in version 4.11.7-0ubuntu1 (utopic):

  * debian/patches/xubuntu_set-accountsservice-user-bg.patch: update
    patch to only update on first workspace filename change (LP: #1318307)

[Release Notes]
Version 4.11.8 - 2014-09-15

 - Fix xfdesktop --reload in spanning mode (Bug 10853)
 - settings: Fix background color loading
 - Add an --enable-debug option added to xfdesktop-settings
 - Fix icon loading for .desktop files (Bug 11078)
 - Don't show infobar when there's only 1 workspace (Bug 11134)
 - Remove the drag highlight code (Bug 10450)

Version 4.11.7 - 2014-08-11

 - Add an option to show hidden files (Bug 8132)
 - Add a --next option to force wallpaper changes (Bug 10754)
 - Add runtime debug support
 - Add a move to trash menu option (Bug 10980)
 - Change behaviour to behavior (Bug 8746)
 - Matias De lellis: Fix display desktop file that include extension
   in icon name
 - Matias De lellis: Fix missing thumbnail on xfdesktop when thumbler
   fails to create it.
 - Mauro Giubileo: Fix icon position saving on resolution change (Bug 10813)

Sean Davis (bluesabre) on 2014-09-27
summary: - [MRE] Please update xfdesktop4 to 4.11.7
+ [MRE] Please update xfdesktop4 to 4.11.8 in Trusty
Sean Davis (bluesabre) on 2014-09-27
description: updated
description: updated
Sean Davis (bluesabre) wrote :

Attaching full debdiff.

Changed in xfdesktop4 (Ubuntu):
status: New → In Progress

Hello Thaddäus, or anyone else affected,

Accepted xfdesktop4 into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xfdesktop4/4.11.8-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xfdesktop4 (Ubuntu):
status: In Progress → Fix Released
Changed in xfdesktop4 (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Jack Fromm (jjfrv8) wrote :

I upgraded to this 4.11.8 release but I can't verify this fix because I was not affected by bug 1313728 or 1312577 and I think there might still be an issue with bug #1365382. I added a description of the issue in that bug report. It seems so minor though that I don't want to mark this fix as verification-failed.

Scaramanga (scaramanga) wrote :

I tested version 4.11.8 that's available in -proposed.
I was affected by #1315716 and this is now fixed.
I am also affected by #1307251 but this was not fixed with the new version. It seems to behave differently now. If I move an icon away from the others it will stay there, but if I rearrange them next to each other they sometimes move around after I login. The new auto-arranged positions will be kept so it looks like xfdesktop just doesn't like some files/file names next to each other.

Also, after upgrading to this version my previous desktop icons placement was reset. So back up the desktop config files if you care about their current positions.

tags: added: verification-failed
removed: verification-needed
Mathew Hodson (mhodson) on 2014-12-09
tags: added: xubuntu
Eric Koegel (eric-koegel) wrote :

Scaramanga (scaramanga) What icons are having these issues? Is there a bug report for this regression so we can find and fix it? I don't know if it's ok to use this bug report to isolate your issue and try to fix it so I'd like to work off a different one. Let me know once you make one. Thanks!

Martin Spacek (mspacek) wrote :

I'm trying out this 4.11.8 proposed release because I was affected by bug 1307251 and bug 1315716. So far, both seem to have been fixed.

J (nopejpg) wrote :

I can confirm that bug 1315716 is resolved; I cannot speak for the others as they did not noticably effect me.

Martin Spacek (mspacek) wrote :

I just had icon positions reset on me on reboot, so it seems bug 1307251 is not fixed after all in xfdesktop 4.11.8.

Martin Spacek (mspacek) wrote :

Also, note that I have "Save session for future logins" disabled in the log out dialog. Not sure if that should matter. I imagine it shouldn't. Icon positions should always be saved between reboots.

description: updated

According to some testers, the icon position reset still occurs in some cases, so this particular bug is not fixed completely.
Now, should this new package be released as update and fix most of the mentioned bugs, or should we wait until the icon bug is fixed in a future version?

description: updated
Martin Spacek (mspacek) wrote :

I would say release the package as an update, close bug 1307251, and then see if anyone continues to complain about icon positions. My guess is there will be fewer reports, and they'll be trickier to diagnose. It probably deserves a new bug report.

I haven't had any other problems with 4.11.8 on trusty - there don't seem to be any regressions.

J (nopejpg) wrote :

I would also agree; definitely release some version that fixes bug 1315716 as it's a required to have a fully functional desktop.

There are no noticeable regressions or new bugs. Also, this updated version works just fine in utopic and vivid.

The icon position reset issue seems to occur less often which is an improvement.

tags: added: verification-done
removed: verification-failed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfdesktop4 - 4.11.8-0ubuntu0.1

---------------
xfdesktop4 (4.11.8-0ubuntu0.1) trusty; urgency=medium

  * New upstream development and bugfix release (LP: #1365965)
  * debian/patches/xubuntu_set-accountsservice-user-bg.patch: update
    patch to only update on first workspace filename change
 -- Sean Davis <email address hidden> Sat, 27 Sep 2014 16:53:04 -0400

Changed in xfdesktop4 (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for xfdesktop4 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Unfortunately, I stumbled upon the problem with the position and alignment of the desktop icons, after un upgrade on a laptop from Ubuntu 12.04 to Xubuntu 14.04 with xfdesktop4 4.11.8-0ubuntu0.1 i386. Any suggestions ? :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers