Desktop background turns to a dirty white color after switching theme

Bug #1302101 reported by oleg on 2014-04-03
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
Xfce4 Desktop
Fix Released
High
xfdesktop4 (Ubuntu)
Medium
Unassigned

Bug Description

When switching to a different theme (doesn't matter if it is default or installed by user) wallpaper turns to offwhite color/Trying to change to a different background doesn't work. Desktop icons are visible. Fixes itself after restart.

Description: Ubuntu Trusty Tahr (development branch)
Release: 14.04
package: xfdesktop4:
  Installed: 4.11.5-0ubuntu1
  Candidate: 4.11.5-0ubuntu1
  Version table:
 *** 4.11.5-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xfdesktop4 4.11.5-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-17.31-generic 3.11.10.3
Uname: Linux 3.11.0-17-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14-0ubuntu1
Architecture: amd64
CurrentDesktop: XFCE
Date: Thu Apr 3 21:02:28 2014
InstallationDate: Installed on 2013-12-03 (121 days ago)
InstallationMedia: Xubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016)
SourcePackage: xfdesktop4
UpgradeStatus: Upgraded to trusty on 2014-04-03 (0 days ago)

Appears to be regression caused by the recent style update change.

xfdesktop 4.11.5

(In reply to Thaddäus Tintenfisch from comment #0)
> Appears to be regression caused by the recent style update change.
>
> xfdesktop 4.11.5

I can reproduce this here on Mageia Linux x86-64 5. See:

https://bugs.mageia.org/show_bug.cgi?id=13134

For me the background disappears right on startup. I mention a relatively simple workaround of doing "pkill xfdesktop" or using xkill somewhere on the background, which appears to work for me.

Thanks to wally from Mageia for giving me a link to this bug.

Regards,

-- Shlomi Fish

Created attachment 5411
Don't chain up style_set

This should fix it, please test this.

(In reply to Eric Koegel from comment #2)
> Created attachment 5411 [details]
> Don't chain up style_set
>
> This should fix it, please test this.

thanks for the patch. I placed it in the Mageia source package and rebuilt and it appears to have fixed the problem.

Regards,

-- Shlomi Fish

(In reply to Shlomi Fish from comment #3)
> (In reply to Eric Koegel from comment #2)
> > Created attachment 5411 [details]
> > Don't chain up style_set
> >
> > This should fix it, please test this.
>
> thanks for the patch. I placed it in the Mageia source package and rebuilt
> and it appears to have fixed the problem.
>
> Regards,
>
> -- Shlomi Fish

I should note that I'm using Mageia Linux x86-64 5 on a Core i3 machine with the built-in i915 graphics adapter.

Eric, after applying your patch the wallpaper does not disappear anymore. Thanks!

oleg (olegich84) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfdesktop4 (Ubuntu):
status: New → Confirmed
Changed in xfdesktop:
importance: Unknown → High
status: Unknown → Fix Released

It's a usability issue that doesn't limit the functionality of a core package.

Changed in xfdesktop4 (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in hundredpapercuts:
status: New → Triaged
importance: Undecided → Medium

Fixed in xfdesktop4 - 4.11.6-1ubuntu1.

Changed in xfdesktop4 (Ubuntu):
status: Triaged → Fix Released
Pasi Lallinaho (knome) on 2014-04-14
Changed in xfdesktop4 (Ubuntu):
assignee: nobody → Thaddäus Tintenfisch (thad-fisch)
Logan Rosen (logan) on 2014-05-21
Changed in hundredpapercuts:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.