Help button doesn't open online help

Bug #1289411 reported by David Pires on 2014-03-07
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Xfce4 Desktop
Fix Released
High
Xfce4 Settings
Fix Released
Medium
libxfce4ui
Fix Released
Medium
libxfce4ui (Ubuntu)
Low
Jackson Doak
xfce4-settings (Ubuntu)
Low
Jackson Doak
xfdesktop4 (Ubuntu)
Low
Jackson Doak

Bug Description

Trusty box fully updated.

Steps to reproduce the bug:
Click Menu icon and navigate to Settings Manager -> Desktop.
Click on the 'Help' button of the Desktop Settings dialog.

Expected behavior:
Xfdesktop online documentation should open web browser at http://docs.xfce.org/xfce/xfdesktop/4.11/start.

Actual beahavior:
Help button isn't triggering the expected opening of the online documentation. In fact there's apparently no click event associated with the said button.

~$ apt-cache policy xfdesktop4
xfdesktop4:
  Installed: 4.11.3-2ubuntu1
  Candidate: 4.11.3-2ubuntu1
  Version table:
 *** 4.11.3-2ubuntu1 0
        500 http://pt.archive.ubuntu.com/ubuntu/ trusty/universe i386 Packages
        100 /var/lib/dpkg/status

~$ lsb_release -a && uname -r

Distributor ID: Ubuntu
Description: Ubuntu Trusty Tahr (development branch)
Release: 14.04
Codename: trusty
3.14.0-031400rc5-generic

Related branches

Trusty box fully updated.

Steps to reproduce the bug:
Click Menu icon and navigate to Settings Manager -> Desktop.
Click on the 'Help' button of the Desktop Settings dialog.

Expected behavior:
Xfdesktop online documentation should open web browser at http://docs.xfce.org/xfce/xfdesktop/4.11/start.

Actual beahavior:
Help button isn't triggering the expected opening of the online documentation. In fact there's apparently no click event associated with the said button.

~$ apt-cache policy xfdesktop4
xfdesktop4:
  Installed: 4.11.3-2ubuntu1
  Candidate: 4.11.3-2ubuntu1
  Version table:
 *** 4.11.3-2ubuntu1 0
        500 http://pt.archive.ubuntu.com/ubuntu/ trusty/universe i386 Packages
        100 /var/lib/dpkg/status

~$ lsb_release -a && uname -r

Distributor ID: Ubuntu
Description: Ubuntu Trusty Tahr (development branch)
Release: 14.04
Codename: trusty
3.14.0-031400rc5-generic

summary: - Help button of Desktop Settings UI doesn't open application's online
- help
+ Help button of Desktop Settings UI doesn't open online help
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfdesktop4 (Ubuntu):
status: New → Confirmed
tags: added: trusty
David Pires (slickymaster) wrote :

There's an upstream commit, from 2014-03-04, that addresses this issue -> http://git.xfce.org/xfce/xfdesktop/commit/?id=67a8cfb24fc4131e6cd74a52901e5389cc9b6757

Jackson Doak (noskcaj) on 2014-03-08
Changed in xfdesktop4 (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low

Created attachment 5381
[PATCH] Fix xfce_dialog_show_help

Commit d5467df1c64ff6cf6884cd7347a3c8c62c49b32e turned
xfce_dialog_show_help into a no-op function. This patch changes it
so that it will use xfce_dialog_show_help_with_version with NULL
for the version. This will restore the previous functionality.
The current xfce_dialog_show_help function is here:
http://git.xfce.org/xfce/libxfce4ui/tree/libxfce4ui/xfce-dialogs.c#n148

Created attachment 5382
[PATCH] Add support for versioned help desktop files

When dialogs are plugged into the settings manager app it would
be nice if they could define versioned help locations in their
desktop files. This patch adds that support.

This isn't a bug in xfdesktop since the help button won't
work for xfce4-settings or anything that calls xfce_dialog_show_help.
The fix for that bug is http://bugzilla.xfce.org/show_bug.cgi?id=10739
The other thing you bring up is more of a feature request - to point to
versioned docs. There's 2 commits in master for that:
http://git.xfce.org/xfce/xfdesktop/commit/?id=67a8cfb24fc4131e6cd74a52901e5389cc9b6757
http://git.xfce.org/xfce/xfdesktop/commit/?id=d27d14f242cbd94fcfbdf881d62c6e2b60f806a7
I pushed the 2nd commit because even if the change in xfce4-settings
never lands, the help button will continue to function. The requested
change for xfce4-settings is here:
http://bugzilla.xfce.org/show_bug.cgi?id=10740
Hope this helps!

Eric Koegel (eric-koegel) wrote :

Just an FYI, this bug isn't specific to xfdesktop.
Any xfce app that calls xfce_dialog_show_help won't
point to the online docs anymore (i.e. Thunar's
help button, even the help button of xfce4-settings-manager).
The bug is in libxfce4ui and there's a proposed fix in xfce's
bugzilla: https://bugzilla.xfce.org/show_bug.cgi?id=10739

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libxfce4ui (Ubuntu):
status: New → Confirmed
In , 8-nick (8-nick) wrote :

Applied

Changed in libxfce4ui:
importance: Unknown → Medium
status: Unknown → Fix Released

The non-versioned help patch was fixed
and xfdesktop now can do versioned help.
Marking resolved.

This bug was fixed in the package xfdesktop4 - 4.11.4-1ubuntu1

---------------
xfdesktop4 (4.11.4-1ubuntu1) trusty; urgency=medium

  * Merge from debian. Remaining changes:
    - debian/patches/xubuntu_improve-nautilus-interactions.patch: added,
      should prevent nautilus from taking over the desktop if xfdesktop is
      running (and vice-versa).
    - debian/patches/xubuntu_set-accountsservice-user-bg.patch: update the
      user background property of Accountsservice on backdrop change.

xfdesktop4 (4.11.4-1) experimental; urgency=medium

  [ Jackson Doak ]
  * New upstream bugfix release
  * Drop git-fix-segfault-on-session-start.patch, fixed upstream
 -- Jackson Doak <email address hidden> Wed, 19 Mar 2014 16:33:54 +1100

Changed in xfdesktop4 (Ubuntu):
status: Triaged → Fix Released
summary: - Help button of Desktop Settings UI doesn't open online help
+ Help button doesn't open online help

I can confirm it. Thanks for that.

Changed in xfdesktop:
importance: Unknown → High
status: Unknown → Fix Released
Changed in xfce4-settings:
importance: Unknown → Medium
status: Unknown → Confirmed
Simon Steinbeiß (ochosi) wrote :

Note: currently dialogs plugged into xfce4-settings-manager don't open a help page at all (which is why this bug affects xfce4-settings too).
There is a patch for this in the upstream bugreport that will hopefully be applied there soon, but we'll need to cherrypick it for 14.04 if we want the Help-buttons to do anything.

Jackson Doak (noskcaj) on 2014-03-21
Changed in xfce4-settings (Ubuntu):
status: New → In Progress
assignee: nobody → Jackson Doak (noskcaj)
Adolfo Jayme (fitojb) on 2014-03-22
Changed in libxfce4ui (Ubuntu):
importance: Undecided → Low
Changed in xfce4-settings (Ubuntu):
importance: Undecided → Low
Jackson Doak (noskcaj) on 2014-03-22
Changed in libxfce4ui (Ubuntu):
assignee: nobody → Jackson Doak (noskcaj)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libxfce4ui - 4.11.1-2ubuntu1

---------------
libxfce4ui (4.11.1-2ubuntu1) trusty; urgency=medium

  * Merge from debian experimental. (LP: #1289755) Remaining change:
    - Use dh-autoreconf to update libtool for ppc64el.
  * Add git-Fix-xfce_dialog_show_help.patch. LP: #1289411

libxfce4ui (4.11.1-2) experimental; urgency=medium

  [ Lionel Le Folgoc ]
  * debian/*.symbols: added.
  * debian/rules: override dh_makeshlibs to ignore libxfce4kbd-private.
  * debian/{vendorinfo,control}: update my email address.
  * debian/control: relax libxfce4ui-utils dependency on libxfce4ui-1-0.

  [ Yves-Alexis Perez ]
  * debian/libxfce4ui-{2,3}-0.lintian-overrides added, add lintian overrides
    for not having libxfce4kbd-private in symbols files.
 -- Jackson Doak <email address hidden> Sun, 23 Mar 2014 08:46:31 +1100

Changed in libxfce4ui (Ubuntu):
status: In Progress → Fix Released
Pasi Lallinaho (knome) on 2014-03-24
Changed in xfdesktop4 (Ubuntu):
assignee: nobody → Jackson Doak (noskcaj)
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1289411

tags: added: package-qa-testing
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-settings - 4.11.2-1ubuntu2

---------------
xfce4-settings (4.11.2-1ubuntu2) trusty; urgency=medium

  * Add 02_versioned-help-files.patch. (LP: #1289411)
    Thanks Eric Koegel
 -- Jackson Doak <email address hidden> Sat, 22 Mar 2014 09:20:53 +1100

Changed in xfce4-settings (Ubuntu):
status: In Progress → Fix Released
Changed in xfce4-settings:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.