xfdesktop-settings dialog not immediately displaying all available wallpapers

Bug #1282227 reported by ToZ on 2014-02-19
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xfdesktop
Fix Released
Low
xfdesktop4 (Ubuntu)
High
Jackson Doak

Bug Description

When first opening the Desktop settings dialog (xfdesktop-settings) the list of available wallpaper does not display. Instead, only one image displays and a fragment (highlight) of another. If I click in the wallpaper white space or go to one of the other tabs and return, the images are displayed properly. Looks like the initial draw of the applet isn't properly drawing all of wallpapers.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xfdesktop4-data 4.11.2-1ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-8.28-generic 3.13.2
Uname: Linux 3.13.0-8-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.13.2-0ubuntu2
Architecture: i386
CurrentDesktop: XFCE
Date: Wed Feb 19 14:06:50 2014
Dependencies:

InstallationDate: Installed on 2014-02-19 (0 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Alpha i386 (20140213)
PackageArchitecture: all
SourcePackage: xfdesktop4
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

It happens occasionally when opening xfdesktop-settings for the first time after session start or switching to another directory. A click on the preview area restores the missing/hidden thumbnails.

xfdesktop 4.11.2git-369fe22

ToZ (toz) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1282227

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfdesktop4 (Ubuntu):
status: New → Confirmed

Created attachment 5375
screenshot

It's estimated to have a moderate impact on a large portion of Ubuntu users.

Changed in xfdesktop4 (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
no longer affects: hundredpapercuts

Created attachment 5396
Fix for images not appearing in settings app

I finally found a way to recreate this bug. This patch
should fix the issue. Let me know if it works for you
since you encounter it more often than I do. Thanks!

I did several test runs and can confirm that your patch fixes the issue.

Thanks

Thanks for reporting the issue and testing the fix.
Pushed to master in:
http://git.xfce.org/xfce/xfdesktop/commit/?id=565ccdfd80f0b4c6e6c67314224bb5c8128177c2

Changed in xfdesktop:
importance: Unknown → Low
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfdesktop4 - 4.11.4-1ubuntu2

---------------
xfdesktop4 (4.11.4-1ubuntu2) trusty; urgency=medium

  * Add patches from upstream git:
    - git-desktop-icons-have-background.patch. LP: #1270261
      Makes desktop icons not have their own background
    - git-missing-images-in-settings-app.patch. LP: #1282227
      Fixes some images not appearing in xfdesktop settings
    - git-fix-default-icon-size.patch. LP: #1272057
      Explicitly define the desktop icon size
  * Refresh xubuntu_set-accountsservice-user-bg.patch to fix
    a memory leak. LP: #1295614
 -- Jackson Doak <email address hidden> Fri, 28 Mar 2014 07:16:04 +1100

Changed in xfdesktop4 (Ubuntu):
status: Triaged → Fix Released
Pasi Lallinaho (knome) on 2014-04-14
Changed in xfdesktop4 (Ubuntu):
assignee: nobody → Jackson Doak (noskcaj)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.