Desktop icon size is not explicitly defined

Bug #1272057 reported by Thaddaeus Tintenfisch on 2014-01-23
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Xfce4 Desktop
Fix Released
Medium
xfdesktop4 (Ubuntu)
Low
Jackson Doak

Bug Description

Before the user config file for xfdesktop4 is created , the desktop icon size is virtually set to "36". Upon opening the desktop settings dialog the icon size will be changed to "32".

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xubuntu-default-settings 14.04.0
ProcVersionSignature: Ubuntu 3.13.0-5.20-generic 3.13.0
Uname: Linux 3.13.0-5-generic i686
NonfreeKernelModules: fglrx
ApportVersion: 2.13.1-0ubuntu1
Architecture: i386
CurrentDesktop: XFCE
Date: Thu Jan 23 20:46:06 2014
InstallationDate: Installed on 2013-09-21 (124 days ago)
InstallationMedia: Xubuntu 13.10 "Saucy Salamander" - Alpha i386 (20130920)
PackageArchitecture: all
SourcePackage: xubuntu-default-settings
UpgradeStatus: Upgraded to trusty on 2013-11-08 (76 days ago)
modified.conffile..etc.xdg.xdg.xubuntu.lightdm.lightdm.gtk.greeter.conf: [modified]
modified.conffile..etc.xdg.xdg.xubuntu.xfce4.xfconf.xfce.perchannel.xml.xfce4.keyboard.shortcuts.xml: [modified]
mtime.conffile..etc.xdg.xdg.xubuntu.lightdm.lightdm.gtk.greeter.conf: 2014-01-23T15:20:41.296623
mtime.conffile..etc.xdg.xdg.xubuntu.xfce4.xfconf.xfce.perchannel.xml.xfce4.keyboard.shortcuts.xml: 2013-12-16T16:03:03.354635

Related branches

Hi. Hopefully this is the right place to report my problem. The steps to reproduce are:

1) Right click the desktop

2) Open "Desktop Settings..."

3) Icons on desktop change from size 36 ---> size 32.

It would be extremely easy not to notice this, but it makes the desktop much less attractive. Only happens on the first time opening the dialog, afterwards the setting stays at 32.

Notes: I am using Xfce 4.8 on Xubuntu 12.04

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xubuntu-default-settings (Ubuntu):
status: New → Confirmed
Elfy (elfy) wrote :

seeing this in the a2 image

Changed in xubuntu-default-settings (Ubuntu):
importance: Undecided → Low
Simon Steinbeiß (ochosi) wrote :

This has been fixed upstream: http://git.xfce.org/xfce/xfdesktop/commit/?id=09f4a5e334a6858369ea69cc62ddd381250c9d62

Maybe we can cherrypick this simple fix?

This should be resolved with the commit to master in:
http://git.xfce.org/xfce/xfdesktop/commit/?id=09f4a5e334a6858369ea69cc62ddd381250c9d62
Which also changes the default to 48 (to better match Thunar's default).

affects: xubuntu-default-settings (Ubuntu) → xfdesktop4 (Ubuntu)

Fixed in version 4.11.3-1ubuntu1.

Changelog entry:
- Update default icon size, spacing, and text proportion.

Changed in xfdesktop4 (Ubuntu):
status: Confirmed → Fix Released

I think that you also need to change this value:

diff --git a/src/xfce-desktop.c b/src/xfce-desktop.c
index 399d2fc..ef9c87e 100644
--- a/src/xfce-desktop.c
+++ b/src/xfce-desktop.c
@@ -839,7 +839,7 @@ xfce_desktop_class_init(XfceDesktopClass *klass)
                                     g_param_spec_uint("icon-size",
                                                       "icon size",
                                                       "icon size",
- 8, 192, 36,
+ 8, 192, 48,
                                                       XFDESKTOP_PARAM_FLAGS));

     g_object_class_install_property(gobject_class, PROP_ICON_FONT_SIZE,

Changed it to use DEFAULT_ICON_SIZE to make it less
error prone if the default size changes again in the
future. Pushed to master in:
http://git.xfce.org/xfce/xfdesktop/commit/?id=5203d9aa93e40dbddc81895fa60c8d1c99dd95f3
Thanks for spotting that!

C de-Avillez (hggdh2) wrote :

Bringing back to Triaged, per request on #ubuntu-bugs

Changed in xfdesktop4 (Ubuntu):
status: Fix Released → Triaged

An additional change has been committed upstream to resolve this problem completely.

http://git.xfce.org/xfce/xfdesktop/commit/?id=5203d9aa93e40dbddc81895fa60c8d1c99dd95f3

Changed in xfdesktop:
importance: Unknown → Medium
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfdesktop4 - 4.11.4-1ubuntu2

---------------
xfdesktop4 (4.11.4-1ubuntu2) trusty; urgency=medium

  * Add patches from upstream git:
    - git-desktop-icons-have-background.patch. LP: #1270261
      Makes desktop icons not have their own background
    - git-missing-images-in-settings-app.patch. LP: #1282227
      Fixes some images not appearing in xfdesktop settings
    - git-fix-default-icon-size.patch. LP: #1272057
      Explicitly define the desktop icon size
  * Refresh xubuntu_set-accountsservice-user-bg.patch to fix
    a memory leak. LP: #1295614
 -- Jackson Doak <email address hidden> Fri, 28 Mar 2014 07:16:04 +1100

Changed in xfdesktop4 (Ubuntu):
status: Triaged → Fix Released
Pasi Lallinaho (knome) on 2014-04-14
Changed in xfdesktop4 (Ubuntu):
assignee: nobody → Jackson Doak (noskcaj)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.