xubuntu 14.04 trusty thar desktop wallpapers selection shows empty

Bug #1271713 reported by GridCube on 2014-01-22
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
xfdesktop4 (Ubuntu)
Undecided
Unassigned

Bug Description

When testing the http://iso.qa.ubuntu.com/qatracker/milestones/310/builds/61655/ ISO for Xubuntu 14.04 if you go to the desktop preferences and try to change the desktop background you are presented with an empty list and the choice to locate your own personal images. No preset of images is offered to you, not even the default desktop background that is currently in use.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1271713

tags: added: iso-testing
tags: added: testcase xfdesktop
description: updated
tags: added: trusty
removed: testcase
Javier López (javier-lopez) wrote :

The ubiquity-slideshow-ubuntu package is responsible of show-casting images while installing Ubuntu. I don't see how this package may be related to this issue. I'll remove it and set the importance as medium, since it looks like an important issue which could affect a lot of users. Feel free to further comment if you have additional data or if you disagree with the importance and assigned package.

Thanks for taking the time to make Ubuntu better!

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

no longer affects: ubiquity-slideshow-ubuntu (Ubuntu)
Changed in xfdesktop:
status: New → Confirmed
Eric Koegel (eric-koegel) wrote :

Is this happening from virtualbox? Does installing
virtualbox-guest-utils virtualbox-guest-x11
and restarting fix the issue? If it does then
http://git.xfce.org/xfce/xfdesktop/commit/?id=05adaa59dbedd89b3e0ae6001ff367572c1be7d2
Should fix it.

GridCube (gridcube) wrote :

Yes, this is in virtualbox, installing the guest addons does seem to shield some results, http://goput.it/b71i.png

I will try to figure out how to install the patch and see if that makes any other difference

Eric Koegel (eric-koegel) wrote :

To test just the patch:

# required tools to get and build xfdesktop
sudo apt-get install git build-essential xfce4-dev-tools
sudo apt-get build-dep xfdesktop4
# get all the xfdesktop source from upstream
git clone git://git.xfce.org/xfce/xfdesktop
cd xfdesktop
# checkout the commit in question
git checkout 05adaa59dbedd89b3e0ae6001ff367572c1be7d2
# pull the patch out
git format-patch -1
# switch to the release commit
git checkout xfdesktop-4.11.3
# create a temp branch to test with
git checkout -b 4.11.3
# apply our fix
git am 0001-Fix-an-settings-issue-when-plug-names-aren-t-availab.patch
# build xfdesktop
./autogen.sh
make
sudo make install

Then you can kill xfdesktop and start it up again (it should load from
/usr/local/bin first). Once you're done testing you can do a
sudo make uninstall to get back to the version installed by Xubuntu.
You can also run git checkout master and then autogen/make/make install
to test all the latest xfdesktop changes upstream, if you like.

GridCube (gridcube) wrote :

Thanks for the detailed instructions Eric, i've tried the patch and the result is the same as just installing the guest additions, the list now shows full, but the thumbs for the wallpapers are empty, however resizing the window, or clicking on one of the empty thumbails loads them all. Just moving the windows does not update the thumbs.

affects: xfdesktop → xfdesktop4 (Ubuntu)

This bug was fixed in the package xfdesktop4 - 4.11.4-1ubuntu1.

From the xfdesktop 4.11.4 changelog:
* Better migration from previous versions:
  - Xfdesktop now does a better job of migrating any user settings
    from 4.10 and before to the new xfconf properties.
  - Fix an settings issue when plug names aren't available

Changed in xfdesktop4 (Ubuntu):
status: Confirmed → Fix Released
Brice Terzaghi (terzag) wrote :

Not sure it's a new bug, the same, or a consequence of the fix but I've installed Xubuntu 14.04 beta in a virtual machine a few days ago and when I go to the desktop settings, it displays two wallpapers, a blue "bar" where the third one should be and is completely stuck taking ~100% CPU, I have to kill the process. Thus, the desktop settings tool is completely unusable.

(Screenshot attached. Don't pay attention to the dock partly visible at the bottom, it's part of my host system.)

Simone (tecnopado) wrote :

the bug persist whit kernel :3.13.0-24-generic # 47... yesterday i've reinstalled the system whit clean installation..(whitout installing virtualbox!!) and the first thing i've seen on the new system after upgrade ,was the problem related this bug!! ..virtual box isn't the problem.. now i think it's a kernel problem!!! whit kernel 3.13.0-24#46 i have not seen any problems...

2lzy2P (rc602) wrote :

Xubuntu 14.04.1 AMD 64 on Lenovo Thinkpad L520. Bug happened after adding .jpg images copied from LXLE 14.04 to /usr/share/xfce4/wallpaper, chmod 644 *.jpg. etc...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers