Desktop items have background

Bug #1270261 reported by Elfy on 2014-01-17
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
xfdesktop
Fix Released
Medium
xfdesktop4 (Ubuntu)
Medium
Jackson Doak

Bug Description

On boot desktop icons have background.

Running xfdesktop --reload fixes it.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xfdesktop4 4.11.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-4.19-generic 3.13.0-rc8
Uname: Linux 3.13.0-4-generic x86_64
ApportVersion: 2.13.1-0ubuntu1
Architecture: amd64
CasperVersion: 1.336ubuntu1
CurrentDesktop: XFCE
Date: Fri Jan 17 18:35:38 2014
LiveMediaBuild: Xubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140117)
SourcePackage: xfdesktop4
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

lp:~noskcaj/ubuntu/trusty/xfdesktop4/git-patches
Sebastien Bacher: Approve on 2014-03-31

Created attachment 5300
left OK, right not properly themed

xfdesktop fails to apply the correct theme to desktop elements after starting the Xfce session. This happens quite often and can be fixed by reloading xfdesktop or adding an additional startup delay (1 sec) to xfdesktop.

Xubuntu 14.04 Daily Build
xfdesktop 4.11.2

Elfy (elfy) wrote :

Created attachment 5322
Wait for the settings manager at startup

If xfdesktop starts loading the icon view before the settings
manager has been set to the screen then the icons will appear
as if they aren't themed. This patch has xfdesktop wait for
the settings manager the same way it already does for the window
manager.
Let me know if this patch solves the issue for you.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfdesktop4 (Ubuntu):
status: New → Confirmed

The patch does not solve the problem. xfdesktop waits for xfwm4 and now additionally for xfsettingsd or simply starts after the 5sec timeout. In the latter case xfdesktop will not update its appearance once the slower starting xfsettingsd is up and running.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1270261

tags: added: iso-testing

Created attachment 5334
Refresh desktop on style changes

Xfdestkop's icon view doesn't update the icon labels when xfsettingsd
starts up. To work around that, refresh the desktop on a style change
event. Additionally gtk likes to send up to 10 style change events at
once, so this also adds a 1 second delay to ensure it's the last change
event that we respond to.

I couldn't figure out how to get the icon view to update the settings
for the icon text when xfsettingsd makes its changes. Let me know if
this fixes it, even if it's not my favorite way to work around the bug.

The new patch fixes this issue and also the related bug 10642.

Changing the desktop icon size twice seems to freeze xfdesktop now.

*** Error in `xfdesktop': free(): corrupted unsorted chunks: 0x09250310 ***
*** Error in `xfdesktop': malloc(): memory corruption: 0x094484d0 ***

Created attachment 5337
icon resize issue

git bisecting it shows it was this change that broke it:
http://git.xfce.org/xfce/xfdesktop/commit/?id=3aeedbb076b1315b56e43e798694425657569abe
This patch should fix the resize issue. Thanks for pointing out the bug.

I can confirm that the last patch resolves the resize issue.

Changed in xfdesktop4 (Ubuntu):
importance: Undecided → Low

Fixed in version 4.11.3-1ubuntu1.

Changelog entry:
- Refresh desktop on style changes

Changed in xfdesktop4 (Ubuntu):
status: Confirmed → Fix Released

This issue seems to be back in 4.11.4. I've encountered it several times already and will do some test runs without this particualar commit:

http://git.xfce.org/xfce/xfdesktop/commit/?id=81e3969103a4b2fc705322bd9afee4e415934f80

Changed in xfdesktop:
importance: Unknown → Medium
status: Unknown → Confirmed

Commit 81e3969103a4b2fc705322bd9afee4e415934f80 is indeed responsible for this regression.

Jackson Doak (noskcaj) on 2014-03-21
Changed in xfdesktop4 (Ubuntu):
status: Fix Released → Triaged
importance: Low → Medium
tags: added: regression-release

I'd rather not revert back if we can help it.

Since xfdesktop responds to xfsettingsd being
launched and exiting I'm going to assume the
style set messages do work and it might be a
simple race condition between the two at start.
Especially since both are waiting for the window
manager. Can you try killing xfdesktop, clearing
any saved sessions, starting xfdesktop with the
-D option, and restarting to see if that fixes
the issue. Thanks!

Adding the -D option did not help.

Changed in xfdesktop:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfdesktop4 - 4.11.4-1ubuntu2

---------------
xfdesktop4 (4.11.4-1ubuntu2) trusty; urgency=medium

  * Add patches from upstream git:
    - git-desktop-icons-have-background.patch. LP: #1270261
      Makes desktop icons not have their own background
    - git-missing-images-in-settings-app.patch. LP: #1282227
      Fixes some images not appearing in xfdesktop settings
    - git-fix-default-icon-size.patch. LP: #1272057
      Explicitly define the desktop icon size
  * Refresh xubuntu_set-accountsservice-user-bg.patch to fix
    a memory leak. LP: #1295614
 -- Jackson Doak <email address hidden> Fri, 28 Mar 2014 07:16:04 +1100

Changed in xfdesktop4 (Ubuntu):
status: Triaged → Fix Released
Sergio Schneider (spsf) wrote :

Just updated xfdesktop4 - 4.11.4-1ubuntu2. The problem is fixed, however introduced a new bug:
If you go to "settings/appearance/style and change from Greybird to any other theme you lose the desktop background completely.
Just reverts after log out/in

Steve Langasek (vorlon) on 2014-04-01
tags: removed: regression-release
Pasi Lallinaho (knome) on 2014-04-14
Changed in xfdesktop4 (Ubuntu):
assignee: nobody → Jackson Doak (noskcaj)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.