[needs-packaging] xfdashboard

Bug #1598503 reported by Unit 193 on 2016-07-02
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Debian
New
Unknown
xfdashboard (Ubuntu)
Wishlist
Unassigned

Bug Description

URL: http://goodies.xfce.org/projects/applications/xfdashboard/start
License: GPL-2+
Notes: Follows even/odd numbers for stable/development releases (eg, 0.6.x is stable, 0.5.x is development)

xfdashboard provides a GNOME shell dashboard like interface for use with Xfce desktop. It can be configured to run to any keyboard shortcut and when executed provides an overview of applications currently open enabling the user to switch between different applications. The search feature works like Xfce's app finder which makes it convenient to search for and start applications.

It's been packaged and uploaded to ppa:xubuntu-dev/extras for a little while now, with the packaging at https://git.launchpad.net/~xubuntu-dev/+git/xfdashboard (previously at https://bitbucket.org/xubuntu/xfdashboard)

This message paid for and approved by the Xubuntu developers team.

Sean Davis (bluesabre) wrote :

As Xubuntu Technical Lead, I agree with adding this to the archive. This application is pretty popular among our users and would certainly be a welcome improvement for them to not have to install it from a PPA. Our team would maintain packaging and fielding bugs and fixes.

tags: added: needs-packaging
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

Changed in ubuntu:
importance: Undecided → Wishlist
Jeremy Bicha (jbicha) wrote :

Hi, have you tried asking the Debian XFCE team to sponsor the initial upload?

Unit 193 (unit193) wrote :

pkg-xfce isn't really interested in the package.

Changed in debian:
status: Unknown → New
Jeremy Bicha (jbicha) on 2016-07-07
Changed in ubuntu:
status: New → In Progress
assignee: nobody → Jeremy Bicha (jbicha)
Jeremy Bicha (jbicha) wrote :

1. I recommend bumping your version number to 0.6.0-0ubuntu2 so that it's clearly higher than the PPA. Please set your version from 'devel' to UNRELEASED.
Please mention that this upload is the initial upload to Ubuntu and cite this bug.
Optionally, you could clear the old changelog entries since they were never "in Ubuntu".

2. Please move usr/lib/*/pkgconfig to libxfdashboard-dev.install
You'll need to set breaks/replaces for the move. [1] [2]

3. Look in libxfdashboard.pc at the Requires: line. You need to add the associated -dev packages
to libxfdasboard-dev's Depends.

4. Debug packages are created automatically now in Ubuntu and Debian [3]
If you care about upgrading users who may have the old debug packages installed, see [4]
On the other hand, that dh_strip option will not work in Ubuntu 14.04.

5. You don't need to disable silent rules, this is the default in Debian and Ubuntu now. [5]
(not the default for 14.04 but hopefully you won't need it there)

6. I would like you to use a .symbols file. [6]
To make the initial file, touch libxfdashboard0.symbols then build.
In your build log, you'll get a warning:
dpkg-gensymbols: warning: new libraries appeared in the symbols file: libxfdashboard.so.0
Paste the + lines under that into your .symbols file. Remove the + from the beginning of each line and the -0ubuntu* from the end of each line. That's it. When a new update adds new symbols, just add them to your .symbols file (leaving off the Debian/Ubuntu revision number from the end). An update should not remove symbols without bumping the soname.

7. Mark xfdashboard Multi-Arch: foreign and libxfdashboard-dev Multi-Arch: same

I am unsubscribing ubuntu-sponsors for now. Please go ahead and re-subscribe when you're ready.

--
[1] https://www.netfort.gr.jp/~dancer/column/libpkg-guide/libpkg-guide.html#id249952
The Debian Maintainer's Guide cautiously recommends the above, noting it's "somewhat outdated"
https://www.debian.org/doc/manuals/maint-guide/advanced.html
[2] https://www.debian.org/doc/debian-policy/ch-relationships.html#s-replaces
[3] https://wiki.debian.org/AutomaticDebugPackages
[4] https://anonscm.debian.org/git/pkg-vala/libgee.git/commit/?id=abb032
[5] https://bugs.debian.org/680686
[6] https://www.debian.org/doc/manuals/maint-guide/advanced.html#librarysymbols

Jeremy Bicha (jbicha) on 2016-08-04
Changed in ubuntu:
assignee: Jeremy Bicha (jbicha) → nobody
Sean Davis (bluesabre) wrote :

Jeremy, thanks for the feedback!

We've made the requested changes at https://git.launchpad.net/~xubuntu-dev/+git/xfdashboard

Re-subscribing ubuntu-sponsors.

Jeremy Bicha (jbicha) wrote :

Thank you, I uploaded to Ubuntu's new queue after making one minor change, changing the Breaks/Replaces to libxfdashboard0 (<< 0.6.0-0ubuntu2~). That final ~ will allow you to backport this version to your PPA if you wanted to.

I am unsubscribing ubuntu-sponsors now.

Unit 193 (unit193) on 2017-08-13
Changed in ubuntu:
status: In Progress → Fix Released
Jeremy Bicha (jbicha) on 2017-08-13
affects: ubuntu → xfdashboard (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.