Ubuntu

xfce keyboard crashes when selecting latam layout

Reported by Gregory M. Blumenthal Scharf on 2011-12-02
36
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xfce4-xkb-plugin
Unknown
Unknown
xfce4-xkb-plugin (Ubuntu)
Medium
Lionel Le Folgoc

Bug Description

xfce keyboard crashes when selecting latam layout

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: xfce4-xkb-plugin 0.5.4.1-1
ProcVersionSignature: Ubuntu 3.0.0-13.22-generic 3.0.6
Uname: Linux 3.0.0-13-generic i686
ApportVersion: 1.23-0ubuntu4
Architecture: i386
AssertionMessage: *** glibc detected *** /usr/lib/xfce4-xkb-plugin/xfce4/panel-plugins/xfce4-xkb-plugin: free(): invalid pointer: 0x21d50c05 ***
Date: Fri Dec 2 11:27:40 2011
ExecutablePath: /usr/lib/xfce4-xkb-plugin/xfce4/panel-plugins/xfce4-xkb-plugin
ProcCmdline: /usr/lib/xfce4-xkb-plugin/xfce4/panel-plugins/xfce4-xkb-plugin 20 18877580 xkb-plugin Keyboard\ Layouts Keyboard\ layouts\ setup\ and\ switch\ plugin
ProcEnviron:
 LANGUAGE=en
 PATH=(custom, no user)
 LANG=es_MX.UTF-8
 LC_MESSAGES=en_US.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: xfce4-xkb-plugin
StacktraceTop:
 __libc_message (do_abort=2, fmt=0xdbf080 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:189
 malloc_printerr (action=<optimized out>, str=<optimized out>, ptr=0x21d50c05) at malloc.c:6283
 _int_free (av=0xdfb400, p=0x21d50bfd) at malloc.c:4795
 __GI___libc_free (mem=0x21d50c05) at malloc.c:3738
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
Title: xfce4-xkb-plugin assert failure: *** glibc detected *** /usr/lib/xfce4-xkb-plugin/xfce4/panel-plugins/xfce4-xkb-plugin: free(): invalid pointer: 0x21d50c05 ***
UpgradeStatus: Upgraded to oneiric on 2011-10-14 (49 days ago)
UserGroups: adm admin cdrom dialout lp lpadmin netdev plugdev sambashare

visibility: private → public

StacktraceTop:
 __libc_message (do_abort=2, fmt=0xdbf080 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:189
 malloc_printerr (action=<optimized out>, str=<optimized out>, ptr=0x21d50c05) at malloc.c:6283
 _int_free (av=0xdfb400, p=0x21d50bfd) at malloc.c:4795
 __GI___libc_free (mem=0x21d50c05) at malloc.c:3738
 standard_free (mem=0x21d50c05) at /build/buildd/glib2.0-2.30.0/./glib/gmem.c:101

Changed in xfce4-xkb-plugin (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-xkb-plugin (Ubuntu):
status: New → Confirmed
Daniel Richard G. (skunk) wrote :

Rookie programming error in xkb-util.c. The attached patch (against git master) fixes it for me. Will forward to the upstream.

The attachment "xfce4-xkb-plugin-fix.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Changed in xfce4-xkb-plugin (Ubuntu):
status: Confirmed → Triaged
Changed in xfce4-xkb-plugin (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Lionel Le Folgoc (mrpouit)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-xkb-plugin - 0.5.4.3-1ubuntu1

---------------
xfce4-xkb-plugin (0.5.4.3-1ubuntu1) precise; urgency=low

  * debian/patches:
    - 01_fix-invalid-free.patch: added, fix crash when selecting latam layout
      (thanks Daniel Richard G. for the patch). lp: #899290
 -- Lionel Le Folgoc <email address hidden> Wed, 14 Mar 2012 19:58:26 +0100

Changed in xfce4-xkb-plugin (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.