xubuntu keyboard layout switch shortcuts are not remembered

Bug #548631 reported by Markhor on 2010-03-26
160
This bug affects 31 people
Affects Status Importance Assigned to Milestone
xfce4-xkb-plugin (Ubuntu)
Medium
Unassigned

Bug Description

i use keyboard layout indicator in xubuntu 10.04 beta (top right tray area, it shows a country flag of the current layout). I set layout switch shortcuts in preferences (Alt-Shift for example). It works. After i reboot the system, shortcuts are forgotten and do not work, so i have to set them once again.

Sorry that i do not know the package name.

WORKAROUND:
Use a different key combination than "Alt+Shift". For example, "Left Alt" or "Left Win" keys.

affects: ubuntu → xfce4-xkb-plugin (Ubuntu)
Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please attach your ~/.xsession-errors file. Does the plugin disappear, or the plugin is still on the panel and the shortcuts quit working. Do all keyboard shortcuts quit (Alt+F2 no longer works)?

Changed in xfce4-xkb-plugin (Ubuntu):
status: New → Incomplete
Markhor (markhor) wrote :

Plugin appears on the panel (USA flag i mean :)). All other shortcuts work fine (alt-F2 gets the launcher window just like it always did), and even my custom shortcut ctrl+space always launches xfce4-console.
I attached the file.

Charlie Kravetz (charlie-tca) wrote :

Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in xfce4-xkb-plugin (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Confirmed
Kılıç Köken (kilickoken) wrote :

When I set to Alt+Shift, it doesn't remember. But I tried "Left Alt" and "Left Win" keys. There's no problem with these two. They are remembered at the next reboot and always.

Markhor (markhor) wrote :

I want to add that Alt-Shift is forgotten after logout+login.

Markhor (markhor) wrote :

I found a temporary fix: in /etc/default/console-setup
replace

XKBOPTIONS=""

with

XKBOPTIONS="grp:alt_shift_toggle"

Lionel Le Folgoc (mrpouit) wrote :

I'm not able to reproduce this issue. Are you sure that the plugin did not crash on logout? Could you attach your config file: $HOME/.config/xfce4/panel/xkb-plugin-*.rc (if there are lots of them, it's usually because of crashes)?

Changed in xfce4-xkb-plugin (Ubuntu):
status: Confirmed → Incomplete
George (espritgr) wrote :

I have the same problem. When rebooting, the “Change layout option” is completely reset to nothing.
When I assign again Alt+Shift keys, it works fine for that session, but when I reboot, it is lost again.

After the assignment of the Alt+Shift keys, the plugin’s config file was showing the parameter “toggle_option=grp:alt_shift_toggle” but each time I rebooted it was reset to “toggle_option=”

My .xsession-errors file shows
 ** (xfwm4:1154): WARNING **: Unhandled keyboard shortcut
method return sender=:1.5 -> dest=:1.32 reply_serial=2

Vlaran (vlaran) wrote :

Same issue here on Xubuntu 10.10. Worse is that I experience this problem irregularly - sometimes the Keyboard Layouts plugin remembers the key combination after reboot and sometimes it does not and I was not able to discover what is this behavior tied to. There are no signs that the plugin crushed anytime and the config file gets modified in the same way as George described plus I also have the same warning entry in the .xsession-errors. I assign the Atl+Shift key combination.

Further on I would recommend to raise the importance of this bug. I am sure that there is a large number of people who use multiple keyboard layouts, especially in countries using alphabets where the letters can contain diacritical marks. I personally must use MS Windows at work and the layout switching is set to Alt+Shift combination by default there so I am used to that and I change the layout very very often (since I'm a web-developer). It is a great inconvenience when I need to set this option in Xubuntu again each time the plugin forgets it and for someone who is thinking about switching to Xubuntu from Windows, this might change his mind.

Daniel Castro (castromd) wrote :

Same problem here. After logout and login the keyboard layout change shortcut is lost.
Any workarounds for this?

Thanks!

Charlie Kravetz (charlie-tca) wrote :

@Daniel Castro:
There appears to be a couple of workarounds above. Comment #4 and Comment #6 look like valid workarounds. Have you tried them? Perhaps a different set of keypresses would work for you? This appears to concern using Alt+Shift. Using other keys does not cause this issue. Please try other keys and let us know if it works for you.

description: updated
febrile (febrile) wrote :

I also have this problem (Acer-AOD255, Xubuntu 10.10, switching us & th layouts with grp:shifts_toggle)

Comment #4's workaround doesn't work for me: the setting's lost on logout/login as before.
Comment #6's workaround (with grp:shifts_toggle) also doesn't work for me, and messes up font and icon settings.

It seems the upstream developers acknowledge there's limited support of XKB options for now:
http://goodies.xfce.org/projects/panel-plugins/xfce4-xkb-plugin
so it's a case of waiting (or getting involved upstream, for those who can)

Xarijus (xarijus) wrote :

I'm using xfce and can confirm this on MSI Wind U100.
I use left super key to toggle keyboard layouts and the shortcut is forgotten after every reboot / logout so I always get to manually edit "Keyboard Layouts Plugin" properties.

Charlie Kravetz (charlie-tca) wrote :

Could you attach your config file: $HOME/.config/xfce4/panel/xkb-plugin-*.rc (if there are lots of them, it's usually because of crashes)?

Lionel Le Folgoc (mrpouit) wrote :

No more reply, closing.

Changed in xfce4-xkb-plugin (Ubuntu):
assignee: nobody → Lionel Le Folgoc (mrpouit)
status: Incomplete → Invalid
dgtlmoon (dgtlmoon) wrote :
dgtlmoon (dgtlmoon) wrote :

please dont closet his bug, it's still biting me every few days unless i keep logging out

Changed in xfce4-xkb-plugin (Ubuntu):
status: Invalid → Confirmed
Changed in xfce4-xkb-plugin (Ubuntu):
assignee: Lionel Le Folgoc (mrpouit) → nobody

I can confirm this bug both on my work computer and on my personal notebook. Both are running xubuntu 11.04. I am attaching the xkb-plugin-5.rc file as requested in comment #14. This is the "proper" state of the file, i.e. after I have restored it to the desired settings after the shortcut key and/or the alternative keyboard layout were not configured upon login. I will upload the incorrect xkb-plugin file as soon as I get home.

As this thread in xfce's bugzilla suggests, the bug should be fixed in the latest version of xfce4-xkb-plugin, which is 0.5.4.1 (as opposed to 0.5.3.3 in both Ubuntu 11.04 and Debian Squeeze):

https://bugzilla.xfce.org/show_bug.cgi?id=6321

Lionel Le Folgoc (mrpouit) wrote :

0.5.4.1 is in oneiric, if someone wants to try.

Changed in xfce4-xkb-plugin (Ubuntu):
status: Confirmed → Incomplete
Changed in xfce4-xkb-plugin (Ubuntu):
status: Incomplete → Fix Released
LittleHorror (littlehorror) wrote :

Unfortunately, I experience this bug on Oneiric. Just switched to xfce, so haven't encountered it before and can't give any comments regarding previous versions.

Can only add that compose key position also gets forgotten.

xfce4-xkb-plugin: 0.5.4.1-1

Yan Zaretskiy (ian-zaretsky) wrote :

This bug affects me as well. I am using Xubuntu Oneiric on Acer Aspire One 721-3574, any key combination for switching layouts gets forgotten after reboot.

aka (vangop) wrote :

Same thing. No settings are saved. xubuntu 11.10

aka (vangop) wrote :

Hehe, guess u understand now why linux share in desktops is ~1%
A simple stupid language switcher applet is bugged for years...

Michal Palička (mpalicka) wrote :

Hello,

I am using Xubuntu Oneiric (amd64) = xfce4-xkb-plugin version 0.5.4.1-1.
The keyboard change layout option gets forgotten after reboot (at random).

I usually use the "Both Shift keys together" key combination.

The status of this bug "Fix Released" is inappropriate, since nothing has been fixed so far.
Please, reopen this bug. I would also vote for upgrading its priority.
It is a simple thing, but VERY annoying.

As "aka" mentioned, such bugs heavily discourage people from switching to Linux...

Lionel Le Folgoc (mrpouit) wrote :

No, it's not simple to fix without knowing what happens (the plugin has likely crashed on shutdown, that's why it lost its config, and in this case, we can't fix it if nobody provides a backtrace of the crash).

Michal Palička (mpalicka) wrote :

Hello,

I didn't mean that it was simple to solve this bug.
I understand that software bugs might get tricky sometimes.

I meant that the problem itself (i.e. switching keyboard layouts) may seem simple and not important at the first sight.
Especially for people who don't use multiple keyboard layouts.
That is why I asked for upgrading the importance of this issue.

----------

Anyway, how can I help you to get the backtrace?
Shall I attach my .xsession-errors file?

I found out, that the change layout key combination gets also forgotten during logout.
It is not necessary to reboot the machine.

uzdzislaw (uzdzislaw) wrote :

I experience this bug as well (Lenovo 3000 N200, fairly clean install of xubuntu lucid — but I see new versions have the same thing, xfce-xkb-plugin 0.5.3.3-1ubuntu3).

My .config/xfce4/panel/xkb-plugin-13220036240.rc (although the number is large, this is the only xkb-plugin-*.rc that is, or ever has been present there) looks like this (as intended) even after logout:

display_type=1
group_policy=0
default_group=0
never_modify_config=false
model=pc105
layouts=pl,ru
variants=,phonetic
toggle_option=grp:shifts_toggle
compose_key_position=compose:menu

Nevertheless, in the plugin itself the toggle and compose dropdowns are both set to "-" and neither keystroke (Shifts toggle, Compose on Menu) works. I attach my .xsession-errors; it contains the following line thrice:

(xfce4-xkb-plugin:6032): GLib-CRITICAL **: g_hash_table_destroy: assertion `hash_table != NULL' failed

I sure hope that helps, as xubuntu is my last resort in the *ubuntu world after I have experienced the horrors of Unity/GNOME 3 when upgraded my Ubuntu to natty and oneiric.

Marios Margaritis (9z0z) wrote :

Some additional info,

 1) it happens only on my 64bit machines, I have 2 each, 32bit is fine.
 2) the config file is not lost (xkb-plugin-6.rc) just ignored at login.

I hope you can solve this issue soon

Marios Margaritis (9z0z) wrote :

Temporary solution:

    setxkbmap -layout us,gr -variant euro -option 'grp:alt_shift_toggle,grp_led:scroll'

this command will set dual layout US Greek with Euro sign.

Putting it on Session autostart does not work since its overwritten by the bugged xfce layout,
so I made a launcher and I use it once per session when I need the 2nd layout (Greek in this example).

The plugin seems to crash randomly, losing it configuration in the process.

As stated above, if we want to still use the plugin (to switch, see the flag, etc) we cannot use a setxkbmap command on startup because the settings get overwritten by xkb-plugin (with blank ones).

Complicated temporary automated solution:
1. Set the desired options in the plugin
2. Copy the ~/.config/xfce4/panel/xkb-plugin-##.rc to some other file e.g. ~/.config/xfce4/panel/goodxkb.rc
3. Add this command to a startup job:

     sh -c "cp ~/.config/xfce4/panel/goodxkb.rc ~/.config/xfce4/panel/xkb-plugin-##.rc && pkill xkb"
    (change the ## to your number)

The pkill part is crucial to reload the plugin and its config.

Works for me. Any change in the options will only affect the current session. The goodxkb file would need to be modified or recreated for the changes to persist.

aka (vangop) wrote :

Thanks for the workaround, will try.
Is there any way to use more setxkbmap options with the plugin like grp_led:caps, or just combine several grp: ones(since the gui just has 1 option for layout switch)

Yes, it's possible to add more options in the .rc file simply with a comma after the setting. For example:

toggle_option=grp:lwin_toggle,grp:alt_caps_toggle

For the change to apply, just pkill xkb again
The plugin GUI will not like this though and will remove the extra stuff if you bring it up.

vishal goswami (goswamivm) wrote :

please fix this bug . it is not fixed yet, the workaround is also not full proof , it works sometimes and fails frequently..

Agreed, if this is marked as fixed I swear I'm moving back to GNOME or worse, Windows!

That being said, I think if you add "sleep 10 &&" before the cp command, it should work better. This ensures that the file replacement happens AFTER the plugin has loaded, which may not be the case on all systems.

Charlie Kravetz (charlie-tca) wrote :

Have you attempted to use the Workaround above? If that is so difficult for you, perhaps moving to an Operating System that works for you is better. Please do not put your threats in these comments. It tends to make the bug report harder to find the actual problems.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Of course I use the workaround, I made it. Nothing would please me more than to help others. Just don't treat it as a permanent fix. Thanks!

bryncoles (brunomatti) wrote :

I also have this but in Xubuntu 11:10 (also my first go at using Xubuntu, so cannot comment on the longevity of the bug). The keyboard shortcut I like to use is 'both shift keys together'. I am also happy (for now) to simply click the icon, as this still changes my layouts correctly.

I have tried the work arounds (and I don't consider 'use a different keyboard shortcut' to really be a valid workaround), and they don't help.

Let me know what additional information I can supply to help get this bug fixed. Let's make a great OS better, together!

Vlada Macek (macek) wrote :

I'm also affected by this annoying bug, but my experience differs from the above commenters.
Config forgetting almost always happens to both of our running X sessions (two users logged in at once through gdm after waking from the Suspend to RAM (triggered by the laptop lid close).

Sometimes it's ok, sometimes it forgets the layout switching key, sometimes the secondary layout disappears from the layouts list completely.

I can't confirm whether it happens after reboot too as we reboot very seldom.

I also don't think the plugin crashes as the flag is always displayed on the panel.

Ubuntu Oneiric, xfce4-xkb-plugin 0.5.4.1-1

Example of the forgotten state:
display_type=0
group_policy=2
default_group=1
never_modify_config=false
model=pc105
layouts=us,cz
variants=,
toggle_option=
compose_key_position=

State after I manually fix in Properties dialog; the only one line changes:
toggle_option=grp:alt_shift_toggle

Huge kudos to the developer who will finally squash this! It's tiring to configure the plugin several times a day for two sessions. Will gladly add info as needed.

LittleHorror (littlehorror) wrote :

This problem appears on both 32 an 64-bit machines in my case. It also appeared on Linux Mint (obviously) and openSuSE (also on both machines).

Bazmata (vladimir-damjanoski) wrote :

This problem occurred to me only when I had something other than "Use system defaults" configured for the keyboard layout through the settings manager (Settings manager, Keyboard applet, Layout tab).
When I set this to "Use system defaults", the keyboard pannel applet remembers the settings correctly and works as expected.
Please try and confirm if it helps for you as well.

V (sgt04b) wrote :

Not confirmed. In my case (IBM ThinkPad T40, Xubuntu 11.10) the configuration file
~/.config/xfce4/panel/xkb-plugin-4.rc is kept intact but I do experience the
forget-change-layout-option bug.
Strangely, xkb remembers the short-cut keys if I restart it with
pkill xkb.

V.

V (sgt04b) wrote :

Bear in mind that I have already defined the alternative keyboard in
Settings -> Settings Manager -> Keyboard -> Layout

V.

dont define it , just keep there system defaults and the problem is solved.

On Sat, Feb 4, 2012 at 10:46 PM, V <email address hidden> wrote:

> Bear in mind that I have already defined the alternative keyboard in
> Settings -> Settings Manager -> Keyboard -> Layout
>
> V.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/548631
>
> Title:
> xubuntu keyboard layout switch shortcuts are not remembered
>
> Status in “xfce4-xkb-plugin” package in Ubuntu:
> Fix Released
>
> Bug description:
> i use keyboard layout indicator in xubuntu 10.04 beta (top right tray
> area, it shows a country flag of the current layout). I set layout
> switch shortcuts in preferences (Alt-Shift for example). It works.
> After i reboot the system, shortcuts are forgotten and do not work, so
> i have to set them once again.
>
> Sorry that i do not know the package name.
>
> WORKAROUND:
> Use a different key combination than "Alt+Shift". For example, "Left Alt"
> or "Left Win" keys.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/xfce4-xkb-plugin/+bug/548631/+subscriptions
>

--
go.vishal

V (sgt04b) wrote :

@vishal goswami
Thanks mate!

I am now (after 3 reboots) confirming Bazmata's solution:-)

For morons like me, try:
  Settings -> Settings Manager -> Keyboard -> Layout -> Check "Use system defaults"
  Then define the "Change layout option" this time (hopefully) for good!

V.

Yes! I confirm this works on multiple machines. Which is strange because that did NOT work only a few months ago. Something must have changed, an update? Hopefully things will remain the same.
Should we open a new bug stating that the plugin conflicts with the Xfce settings manager when not set to use system defaults?

LittleHorror (littlehorror) wrote :

Is there a way to use this on multiuser system, where system-wide options (layout choices) differ for different users?

Also, there is no obvious way to configure Compose key position in XFCE without using panel applet. It is possible, however, by manually editing startup scripts, but this method creates problems for users who rely on a "point-and-click" way of swiching layouts.

Photon (michael-kogan) wrote :

I can confirm that vishal goswami's solution works here, too. Big thanks for the solution!

Dookie (nimrod97) wrote :

still exists in 12.04 beta2

vishal goswami (goswamivm) wrote :

Settings -> Settings Manager -> Keyboard -> Layout
dont define it , just keep there system defaults and the problem is solved.

On 4/14/12, Dookie <email address hidden> wrote:
> still exists in 12.04 beta2
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/548631
>
> Title:
> xubuntu keyboard layout switch shortcuts are not remembered
>
> Status in “xfce4-xkb-plugin” package in Ubuntu:
> Fix Released
>
> Bug description:
> i use keyboard layout indicator in xubuntu 10.04 beta (top right tray
> area, it shows a country flag of the current layout). I set layout
> switch shortcuts in preferences (Alt-Shift for example). It works.
> After i reboot the system, shortcuts are forgotten and do not work, so
> i have to set them once again.
>
> Sorry that i do not know the package name.
>
> WORKAROUND:
> Use a different key combination than "Alt+Shift". For example, "Left Alt"
> or "Left Win" keys.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/xfce4-xkb-plugin/+bug/548631/+subscriptions
>

--
go.vishal

PeterBocz (boczpeter) wrote :

It even forgets the settings on suspend/resume.
Linux Mint 12 / Oneiric

Marzata (marzata) wrote :

I confirm this in Xubuntu 12.04 LTS (precise). The xkb-plugin indicator is not working and its flag is also not clickable with the mouse. I tried the defaults as was mention above and I did reinstalled the plugin via Synaptic. Nothing helped. Any idea how to change keyboard layouts and fix this?

vishal goswami (goswamivm) wrote :

Actually, i installed ubuntu lts 12.04 to get rid of these never ending
problems.
On Apr 28, 2012 1:25 PM, "Marzata" <email address hidden> wrote:

> I confirm this in Xubuntu 12.04 LTS (precise). The xkb-plugin indicator
> is not working and its flag is also not clickable with the mouse. I
> tried the defaults as was mention above and I did reinstalled the plugin
> via Synaptic. Nothing helped. Any idea how to change keyboard layouts
> and fix this?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/548631
>
> Title:
> xubuntu keyboard layout switch shortcuts are not remembered
>
> Status in “xfce4-xkb-plugin” package in Ubuntu:
> Fix Released
>
> Bug description:
> i use keyboard layout indicator in xubuntu 10.04 beta (top right tray
> area, it shows a country flag of the current layout). I set layout
> switch shortcuts in preferences (Alt-Shift for example). It works.
> After i reboot the system, shortcuts are forgotten and do not work, so
> i have to set them once again.
>
> Sorry that i do not know the package name.
>
> WORKAROUND:
> Use a different key combination than "Alt+Shift". For example, "Left Alt"
> or "Left Win" keys.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/xfce4-xkb-plugin/+bug/548631/+subscriptions
>

Marzata (marzata) wrote :

I used the following instructions given from a Romanian gentleman and it worked. Source: http://askubuntu.com/a/113517

As the best previous answer appears to be commented afterwards by the user as not working anymore, I will give here an updated perfected version of a quite successful workaround. Sorry not to be able to provide a more scientific less empirical approach, I am not an advanced user, just had the luck to get what I want in this case and want to share this, maybe as a temporary patchwork. So, bare with me. I use Xubuntu, maybe some instructions are limited to that.

My solution is this (my case is English-US as default, second French, third Romanian standard - replace accordingly):

Go to Setting Manager - Keyboard - Layout, and set the languages in the preferred order (delete them and add them in order to achieve this). Go to the properties of the xkb plugin and make the same settings in the same order with the same default language.

Open the file /home/username/.config/xfce4/xfconf/xfce-perchannel-xml/keyboard-layout.xml
Edit it to look similar to this:

<?xml version="1.0" encoding="UTF-8"?>

<channel name="keyboard-layout" version="1.0">
  <property name="Default" type="empty">
    <property name="XkbDisable" type="bool" value="false"/>
    <property name="XkbLayout" type="string" value="us,fr,ro"/>
    <property name="XkbVariant" type="string" value=",,std"/>
  </property>
</channel>

Open the file /home/username/.config/xfce4/panel/xkb-plugin-##.rc
Edit it to look similar to this:

display_type=1
group_policy=0
default_group=0
never_modify_config=false
model=pc105
layouts=us,fr,ro
variants=,,std
toggle_option=grp:alt_shift_toggle
compose_key_position=

Open the file (as root) /etc/default/keyboard
Edit it accordingly:

XKBMODEL="pc105"
XKBLAYOUT="us,fr,ro"
XKBVARIANT=",,std"
XKBOPTIONS="grp:alt_shift_toggle"

Maybe not all these are necessary to make it work, but just in case...

Dmitri (ryba4) wrote :

This bug is still present in 12.04. Is the fix really released?

I'm running 12.04 with xubuntu-desktop on 3 different machines and they all have the same bug. The switching shortcut key is not remembered across sessions.

This is a very annoying issue as I constantly have to switch layouts. I'd like to contribute in fixing this. Comment #26 says that it's difficult to fix since it needs a backtrace of the (probable) crash of the applet. Fine, but can you provide the way to create this backtrace?

zhvihti (zhvihti) wrote :

Marzata's workaround above worked wonders, thanks a lot :))) I'm running Xubuntu 12.04 64bit.

The workaround is fine as long as you have a single user on your machine. Which is not my case.

I'm running Xubuntu 12.04 on four machines with no issues. Check the "Use system Defaults" in the keyboard settings then configure the panel plugin. No need to edit files.

vishal goswami (goswamivm) wrote :

I'm too running on 2 machines without any problem, just check the system
defaults, (uncheck and check if already checked). In keyboard settings.
Please let us know, those who have still got the problem, have upgraded or
it is a fresh install. I've done a fresh install on both the machines.
On Jun 8, 2012 12:36 AM, "Louis de Leseleuc" <email address hidden>
wrote:

> I'm running Xubuntu 12.04 on four machines with no issues. Check the
> "Use system Defaults" in the keyboard settings then configure the panel
> plugin. No need to edit files.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/548631
>
> Title:
> xubuntu keyboard layout switch shortcuts are not remembered
>
> Status in “xfce4-xkb-plugin” package in Ubuntu:
> Fix Released
>
> Bug description:
> i use keyboard layout indicator in xubuntu 10.04 beta (top right tray
> area, it shows a country flag of the current layout). I set layout
> switch shortcuts in preferences (Alt-Shift for example). It works.
> After i reboot the system, shortcuts are forgotten and do not work, so
> i have to set them once again.
>
> Sorry that i do not know the package name.
>
> WORKAROUND:
> Use a different key combination than "Alt+Shift". For example, "Left Alt"
> or "Left Win" keys.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/xfce4-xkb-plugin/+bug/548631/+subscriptions
>

Yup, it worked. Haven't setup my other machines, but I'm sure it'll fix the issue as well. Thanks!

Delta-Z (zinenko) wrote :

I don't understand how come this bug is still marked as "fix released". Who is assigned to this?
This bug is probably severely affecting productivity for most users outside US and UK.

Amir Mlk (a-malekpour-gmail) wrote :

The bug still exists in 12.10. Even after a simple suspend/resume the settings are reset back to the default. This is annoying as hell, enough to repel one back to Gnome.

zhvihti (zhvihti) wrote :

This bug is definitely not yet solved.

Bug still present in XUbuntu 12.04
Workaround #41 and #44 works.

do you need to attach any file?

Joachim Reiß (joareiss) wrote :

Can someone please fix this already. It annoys the hell out of me.

cguru (cguru-u) wrote :

I tried several solutions mention here. Even editing: .config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml
and setting the write protection with the immutable flag:
sudo chattr +i .config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml

Nothing seemed to solve the Problem. When I hit alt+F2, my xfrun4 won't come up. xfce4 keyboard manager was also unable to accept my changes and even removed my config entry when I hit alt+F2 for shortcut recording. I therefore assume that this configuration windows is broken.

Finally, I found a solution for me: when I hit alt+f2 in the gnome-terminal, it posted a capital P. Alt+F1 produced a capital Q.
So I assumed that my keybaord layout was broken.

So I went to "xfce4-keyboard-settings" ->keyboard layout tab (most right one) and removed my keyboard layout. After adding the same back again and relogin to xfce4, my keys did work.

vishal goswami (goswamivm) wrote :

try to set shift + caps lock for changing layouts . it works even after
several restarts for me.
On 15-Aug-2013 2:13 PM, "cguru" <email address hidden> wrote:

> I tried several solutions mention here. Even editing:
> .config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml
> and setting the write protection with the immutable flag:
> sudo chattr +i
> .config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml
>
> Nothing seemed to solve the Problem. When I hit alt+F2, my xfrun4 won't
> come up. xfce4 keyboard manager was also unable to accept my changes and
> even removed my config entry when I hit alt+F2 for shortcut recording. I
> therefore assume that this configuration windows is broken.
>
> Finally, I found a solution for me: when I hit alt+f2 in the
> gnome-terminal, it posted a capital P. Alt+F1 produced a capital Q.
> So I assumed that my keybaord layout was broken.
>
> So I went to "xfce4-keyboard-settings" ->keyboard layout tab (most right
> one) and removed my keyboard layout. After adding the same back again
> and relogin to xfce4, my keys did work.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/548631
>
> Title:
> xubuntu keyboard layout switch shortcuts are not remembered
>
> Status in “xfce4-xkb-plugin” package in Ubuntu:
> Fix Released
>
> Bug description:
> i use keyboard layout indicator in xubuntu 10.04 beta (top right tray
> area, it shows a country flag of the current layout). I set layout
> switch shortcuts in preferences (Alt-Shift for example). It works.
> After i reboot the system, shortcuts are forgotten and do not work, so
> i have to set them once again.
>
> Sorry that i do not know the package name.
>
> WORKAROUND:
> Use a different key combination than "Alt+Shift". For example, "Left
> Alt" or "Left Win" keys.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/xfce4-xkb-plugin/+bug/548631/+subscriptions
>

martinr (martinr1111) wrote :

This bug affects me since a relatively short wile too.
Was there a regression?
My default keyboard layout settings are lost after a re-login.
I'm on XUbuntu 12.04.5 LTS running on a 32 bit Intel platform.

martinr (martinr1111) wrote :

Additional information:
When I try Marzata's workaround stated above,
xfce4-xkb-plugin crashes.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.