Restarting X causes Xfce Xfapplet with Gnome System Monitor to fail

Bug #199803 reported by Robert
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xfce4-xfapplet-plugin (Ubuntu)
Low
Unassigned
Nominated for Lucid by Andrioid

Bug Description

Binary package hint: xfce4-xfapplet-plugin

I am using Xfce 4.4.1 on Gutsy. In my panel, I have an Xfapplet containing the Gnome System Monitor (since I prefer it to Xfce's system monitor).

If I restart X (Ctrl-Alt-Backspace), it's unable to reload the system monitor, and gives an error. The only way to get it back is to restart the computer (merely restarting X or logging off and logging in again doesn't work).

Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

Thanks for your bug report.
Is there any error message in ~/.xsession-errors when this bug occurs?

Changed in xfce4-xfapplet-plugin:
assignee: nobody → mrpouit
importance: Undecided → Low
status: New → Incomplete
Revision history for this message
Robert (robrwo) wrote :

Yes: cat ~/.xsession-errors |grep xfce4

** (xfce4-xfapplet-plugin:10695): WARNING **: Failed to load applet 'OAFIID:GNOME_MultiLoadApplet' (can't get CORBA object): Failed to resolve, or extend '!prefs_key=/apps/xfapplet/applet_20/prefs;orient=down;size=small

Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

Ok, this seems to be fixed in hardy, please reopen if it is not for you.

Changed in xfce4-xfapplet-plugin:
status: Incomplete → Fix Released
Revision history for this message
Robert (robrwo) wrote :

I'm running the latest Hardy, and it's still an issue for me.

Changed in xfce4-xfapplet-plugin:
status: Fix Released → Confirmed
Revision history for this message
Robert (robrwo) wrote :

I've noticed that it's sporadic: sometimes I can restart X and the problem seems fixed, other times not.

Revision history for this message
jedie (launchpad-net-jensdiemer) wrote :

confirm this bug. But i haven't a ~/.xsession-errors file.

In my case, the xfapplet has very high CPU load :(

Revision history for this message
Robert (robrwo) wrote :

I've had this problem again in Hardy (though it occurs less often, and I thought it might have been fixed).

Revision history for this message
huiii (a00ps) wrote :

it is not fixed,
xubuntu hardy 8.04 64bit
reset xserver leads to high cpu-load by xfce4-xfapplet,
is there a workarround?

Revision history for this message
huiii (a00ps) wrote :

this is so annoying:
always, when restarting X, with
ctrl-alt-backspace
or
sudo /etc/init.d/gdm restart
or in tty by doing
/etc/init.d/gdm stop / start,
I got 100% cpu load. rrrroaarrrr
so I always had to go back to tty (ctrl-alt-f1) and do
/etc/init.d/gdm stop
killall xfce4-xfapplet-plugin
/etc/init.d/gdm start

but now i have a very well working workaround: :)

sudo gedit /etc/gdm/PostSession/Default
add the command
killall xfce4-xfapplet-plugin
at the end right before exit 0:
save, now everytime you logout or do ctrl-alt-backspace
the applet will be killed without being deleted from panel.

sudo gedit /etc/init.d/gdm
add the command
killall xfce4-xfapplet-plugin
to line 83, it should look like this:
  stop)
 log_begin_msg "Stopping GNOME Display Manager..."
 start-stop-daemon --stop --quiet --oknodo --pidfile $PIDFILE --name gdm $SSD_ARG --retry 30 >/dev/null 2>&1
 killall xfce4-xfapplet-plugin
 log_end_msg 0

save, now you can work normal in tty and once you have to resatrt gdm, you will notice nothing anymore.

hope this helps the few, till its fixed.
cheers.

Revision history for this message
Charlie Kravetz (charlie-tca) wrote :

Is anyone experiencing this in a version of Xubuntu after 8.04? I tried to reproduce it in Lucid Lynx, but was unable to. xfapplet did close upon restarting X, but the system monitor did not close or quit working.

Changed in xfce4-xfapplet-plugin (Ubuntu):
assignee: Lionel Le Folgoc (mrpouit) → nobody
status: Confirmed → Incomplete
Revision history for this message
Lars Volker (lv) wrote :

Yes, I have been seeing the same behaviour as #9 since karmic i think. However it is still present in lucid. Usually after a relogin the system usage goes up to 100% for each instance of xfapplet set up. Here it happens for gnome sensors-applet as well as the clock and the link monitor.

What can i do to capture debugging data?

PS: Sorry for searching for a bug report on this so late.

Revision history for this message
Robert (robrwo) wrote :

I have only seen this happen once or twice in Karmic, and so far not at all in Lucid.

When it's happened, it has happened with the gnome system monitor. However, with Lucid I have has the Gnome System Monitor go up to 100% CPU a couple of times so far when I click on the applet to launch the monitor. So perhaps the issue is with the specific applet(s), and not Xfapplet.

Revision history for this message
Charlie Kravetz (charlie-tca) wrote :

Per comment #9, you are forcing X or GDM to restart. Did you have something crash or freeze to cause you to do this?

@Lars Volker: When the cpu goes to 100%, does it drop back down? Does it stay at 100%? If it does stay up, you could run a backtrace using https://wiki.ubuntu.com/Backtrace#Already%20running%20programs after setting up the debug symbols.

Revision history for this message
eval- (eval-) wrote :

Yesterday I switched to gnome from xfce4 because I could not find a way to switch desktops when clicking on the xfce4-panel tasklist with compiz, and I spent a fair bit of time trying to use the gnome window list applet (which switches desktops on click) inside an xfapplet as a workaround. Today I noticed the xfapplets are still running:

  PID PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
 6959 20 0 262m 15m 11m R 101 0.2 1111:26 xfce4-xfapplet-
12880 20 0 260m 13m 10m R 101 0.2 1090:52 xfce4-xfapplet-
21663 20 0 262m 15m 11m R 101 0.2 1169:02 xfce4-xfapplet-

I suspect they've been at 100% since last night. They are the only things seen when I "ps -ef | grep xfce" and the CPU usage never drops. I've not used the gnome system monitor, only window and task list.

Revision history for this message
Charlie Kravetz (charlie-tca) wrote :

For those users experiencing xfce4-xfapplet-plugin causing load to be 100%, please file a new bug report. This can be done after experiencing the issue using "ubuntu-bug xfce4-xfapplet-plugin".

Since the original issue, not being able to restart gnome-system-monitor when used with xfce4-xfapplet-plugin in the panel appears to be resolved in the latest release, Ubuntu 10.04, I am closing this report.

Thanks for helping improve Ubuntu and Xubuntu.

Changed in xfce4-xfapplet-plugin (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers