Ubuntu

xfce4-weather-plugin stopped updating and displaying weather data

Reported by Nikola M on 2011-11-09
56
This bug affects 9 people
Affects Status Importance Assigned to Milestone
xfce4-weather-plugin (Debian)
Fix Released
Unknown
xfce4-weather-plugin (Ubuntu)
High
Unassigned
Hardy
Undecided
Unassigned
Lucid
High
Lionel Le Folgoc
Maverick
High
Lionel Le Folgoc
Natty
High
Lionel Le Folgoc
Oneiric
High
Lionel Le Folgoc
Precise
High
Unassigned

Bug Description

Few days ago, xfce-weather-plugin stopped displaying weather data.
I am on Xubuntu 10.04 LTS 64-bit (amd64).
I use weather applet every day and it is much better then on Gnome and i truly miss its functioinality.

If I could assist by any means of fixing this bug, please ask me for additional info.
ubuntu-bug was unable to start and report bugs also due to unknown reason nere at me.

Thank you for reporting this issue. This is known upstream, with no developers available at this time to re-write the plugin.

The xfce4-weather-plugin is now broken. It will remain broken until a
change to the plugin is made or a new plugin written. The cause of
the breakage was a change in weather.com XML Data Feed used for the
weather data. Since this plugin was included in Xubuntu 11.10 and worked
until the end of October 2011, this will probably result in several bug
reports and complaints being generated.

The issue is explained in
http://mail.xfce.org/pipermail/goodies-dev/2011-October/003139.html .

Changed in xfce4-weather-plugin (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Changed in xfce4-weather-plugin (Ubuntu):
importance: Wishlist → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-weather-plugin (Ubuntu Hardy):
status: New → Confirmed
Changed in xfce4-weather-plugin (Ubuntu Lucid):
status: New → Confirmed
Changed in xfce4-weather-plugin (Ubuntu Maverick):
status: New → Confirmed
Changed in xfce4-weather-plugin (Ubuntu Natty):
status: New → Confirmed
Changed in xfce4-weather-plugin (Ubuntu Oneiric):
status: New → Confirmed
Changed in xfce4-weather-plugin (Ubuntu Oneiric):
status: Confirmed → Triaged
importance: Undecided → High
Lionel Le Folgoc (mrpouit) wrote :

This bug was fixed in the package xfce4-weather-plugin - 0.7.4-3

---------------
xfce4-weather-plugin (0.7.4-3) unstable; urgency=low

  * Brown paper bag release.
  * debian/patches/series added, so the patch is really applied.closes: #647749

 -- Yves-Alexis Perez <email address hidden> Fri, 18 Nov 2011 10:48:51 +0100

xfce4-weather-plugin (0.7.4-2) unstable; urgency=low

  * debian/patches:
    - 00_license added, change the license key for the one from CTW since it
      seems to work and brings back the feature. Temporary fix until a real
      solution is found. closes: #647749
  * debian/rules:
    - switch to debhelper with hardening support
  * debian/control:
    - update debhelper build-dep to 8.9.4 for hardening support.
    - add dpkg-dev 1.16.1 build-dep for hardening support.
    - drop cdbs and hardening-includes.
    - fix typo in long description.
  * debian/compat bumped to 9.

 -- Yves-Alexis Perez <email address hidden> Wed, 16 Nov 2011 22:48:59 +0100

Changed in xfce4-weather-plugin (Ubuntu):
status: Triaged → Fix Released
yesint (yesint4) wrote :

Is it possible to install patched package in Oneiric?

Changed in xfce4-weather-plugin (Debian):
status: Unknown → Fix Released
Changed in xfce4-weather-plugin (Ubuntu Oneiric):
assignee: nobody → Lionel Le Folgoc (mrpouit)
Lionel Le Folgoc (mrpouit) wrote :

Similar patch uploaded to oneiric-proposed, waiting for approval.

Changed in xfce4-weather-plugin (Ubuntu Natty):
status: Confirmed → Triaged
importance: Undecided → High
assignee: nobody → Lionel Le Folgoc (mrpouit)
Lionel Le Folgoc (mrpouit) wrote :

Uploaded to {natty,maverick}-proposed as well. Lucid and hardy packages will follow later.

Changed in xfce4-weather-plugin (Ubuntu Maverick):
status: Confirmed → Triaged
importance: Undecided → High
assignee: nobody → Lionel Le Folgoc (mrpouit)
Lionel Le Folgoc (mrpouit) wrote :

Uploaded to lucid-proposed too (support for hardy desktop installs stopped six months ago, and anyway any hardy chroot I create seems to be broken…).

Changed in xfce4-weather-plugin (Ubuntu Lucid):
status: Confirmed → Triaged
importance: Undecided → High
assignee: nobody → Lionel Le Folgoc (mrpouit)
Changed in xfce4-weather-plugin (Ubuntu Hardy):
status: Confirmed → Won't Fix

Hello Nikola, or anyone else affected,

Accepted xfce4-weather-plugin into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xfce4-weather-plugin (Ubuntu Oneiric):
status: Triaged → Fix Committed
tags: added: verification-needed
Changed in xfce4-weather-plugin (Ubuntu Natty):
status: Triaged → Fix Committed
Clint Byrum (clint-fewbar) wrote :

Hello Nikola, or anyone else affected,

Accepted xfce4-weather-plugin into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xfce4-weather-plugin (Ubuntu Maverick):
status: Triaged → Fix Committed
Clint Byrum (clint-fewbar) wrote :

Hello Nikola, or anyone else affected,

Accepted xfce4-weather-plugin into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xfce4-weather-plugin (Ubuntu Lucid):
status: Triaged → Fix Committed
Clint Byrum (clint-fewbar) wrote :

Hello Nikola, or anyone else affected,

Accepted xfce4-weather-plugin into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Works for me.

Excerpts from jean-philippe.guerard's message of Wed Dec 14 06:55:48 UTC 2011:
> Works for me.
>

jean-philippe, can you be more specific? Packages were pushed in to -proposed
for 4 releases today, so the best thing you could do is run

apt-cache policy xfce4-weather-plugin

And paste the output here.

Here it is:

$ LC_ALL=C apt-cache policy xfce4-weather-plugin
xfce4-weather-plugin:
  Installed: 0.7.4-1ubuntu0.1
  Candidate: 0.7.4-1ubuntu0.1
  Version table:
 *** 0.7.4-1ubuntu0.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ oneiric-proposed/universe i386 Packages
        100 /var/lib/dpkg/status
     0.7.4-1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ oneiric/universe i386 Packages

Clint Byrum (clint-fewbar) wrote :

perfect, thanks Jean-Philippe!

tags: added: verification-done verification-done-oneiric
Mike Kupfer (mkupfer37) wrote :

The Maverick package works fine, too.

xfce4-weather-plugin:
  Installed: 0.7.3-3ubuntu0.1
  Candidate: 0.7.3-3ubuntu0.1
  Version table:
 *** 0.7.3-3ubuntu0.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick-proposed/universe i386 Packages
        100 /var/lib/dpkg/status
     0.7.3-3build1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/universe i386 Packages

karmy (karmy5678) wrote :

The Lucid package works fine, too:

xfce4-weather-plugin:
  Installed: 0.7.3-2ubuntu0.1
  Candidate: 0.7.3-2ubuntu0.1
  Version table:
 *** 0.7.3-2ubuntu0.1 0
        500 http://archive.ubuntu.com/ubuntu/ lucid-proposed/universe Packages
        100 /var/lib/dpkg/status
     0.7.3-2 0
        500 http://archive.ubuntu.com/ubuntu/ lucid/universe Packages

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-weather-plugin - 0.7.3-2ubuntu0.1

---------------
xfce4-weather-plugin (0.7.3-2ubuntu0.1) lucid-proposed; urgency=low

  * debian/patches:
    - 00_license added, change the license key for the one from CTW since it
      seems to work and brings back the feature. Temporary fix until a real
      solution is found. lp: #888285
 -- Lionel Le Folgoc <email address hidden> Sun, 11 Dec 2011 16:14:39 +0100

Changed in xfce4-weather-plugin (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-weather-plugin - 0.7.3-3ubuntu0.1

---------------
xfce4-weather-plugin (0.7.3-3ubuntu0.1) maverick-proposed; urgency=low

  * debian/patches:
    - 00_license added, change the license key for the one from CTW since it
      seems to work and brings back the feature. Temporary fix until a real
      solution is found. lp: #888285
 -- Lionel Le Folgoc <email address hidden> Sun, 11 Dec 2011 12:33:58 +0100

Changed in xfce4-weather-plugin (Ubuntu Maverick):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-weather-plugin - 0.7.4-1ubuntu0.1

---------------
xfce4-weather-plugin (0.7.4-1ubuntu0.1) oneiric-proposed; urgency=low

  * debian/patches:
    - 00_license added, change the license key for the one from CTW since it
      seems to work and brings back the feature. Temporary fix until a real
      solution is found. lp: #888285
 -- Lionel Le Folgoc <email address hidden> Sun, 11 Dec 2011 11:54:03 +0100

Changed in xfce4-weather-plugin (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

I released the verified releases, keeping v-needed for natty which still needs to be tested. Thanks!

tags: removed: verification-done verification-done-oneiric
dino99 (9d9) wrote :
Changed in xfce4-weather-plugin (Ubuntu Natty):
status: Fix Committed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.