[SRU] Plugin needs updated for locationforecast-1.2

Bug #1377612 reported by Sean Davis on 2014-10-05
112
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Xfce4 Weather Plugin
Fix Released
Medium
xfce4-weather-plugin (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned

Bug Description

[Impact]
Please see upstream bug https://bugzilla.xfce.org/show_bug.cgi?id=10916

The previous locationforecast-1.1 has been deprecated and dropped. Because of this, users of the plugin in Precise and Trusty will find that it no longer works. The plugin simply displays NODATA.

This package requires patches for Precise and Trusty.

[Test Case]
Add the Weather plugin to the Xfce panel.
1. Right click on the panel, select Panel > Add New Items...
2. Select "Weather Update". Click "Add."
3. Right click on the newly added weather plugin, select Properties.
4. If possible, add your location.
5. Without the patch, the panel plugin will display "No Data" and will not function correctly.

[Regression Potential]
None.

(wrapper:23148): weather-WARNING **: Met.no LocationforecastLTS API states that this version of the webservice is deprecated, and the plugin needs to be adapted to use a newer version, or it will stop working within a few month. Please file a bug on https://bugzilla.xfce.org if no one else has done so yet.
weather-Message: getting http://api.yr.no/weatherapi/locationforecastlts/1.1/?lat=45.500000;lon=-73.583298;msl=82

In , Guy (guy-b) wrote :

The same here on xubuntu 12.04 LTS seens 3 days.

Thanks for reporting. If I haven't missed anything, a patch will be quite trivial, as there are not many API changes. Probably simply changing the URL will suffice. I'll try and test soon.

In , Guy (guy-b) wrote :

Thanks Harald,

I think too that's only a url problem. Let us know...

Cheers.

Simply using the new URL will not help.

The updated API version uses CamelCase symbol names instead of UPPERCASE
ones and has added some new names (like 'Drizzle'), which unfortunately
have not been documented (yet?).

What's more, the typo 'celcius' has been replaced by the fixed 'celsius',
which has not been documented too, but luckily the plugin will not be affected by that change.

Making symbol names uppercase is trivial, and very probably I can map the new symbol names to existing ones so they can be represented by existing icon themes. I have contacted met.no for more information so I can work on those patches.

Created attachment 5509
make-plugin-ready-for-met.no-locationforecast-1.2-API.patch

I have not received any replies from met.no yet, and though not much time has passed, I'm not very convinced I will. Nevertheless, I have created patches to deal with this problem, it would be great if someone could try them and verify that the results look sane.

The first one prepares the plugin for the new API 1.2, but still uses the old version 1.1. After applying this patch, you should see no differences to an unpatched plugin.

The second patch then switches to the new API 1.2. If you do an immediate comparison, you will probably notice differences in the forecasts, because the new API seems to produce different results than 1.1. If not, you will at least find that the WARNING no longer appears.

While I have tried to match the symbols as good as possible and these patches should keep the 0.8.3 plugin going for some while longer, I have decided to switch to openweathermap for the next feature release. Openweathermap has many benefits, many other clients use it and it has good documentation, especially in comparison to met.no.

At the moment, it is not advised to compile and use current git because there are problems with the update code, noticeable in sunrise/sunset values after 24 hours usage, though there should be no other issues and no crashes. I'm not sure if I will ever fix this, since I'll have to throw away code for openweathermap. Maybe I'll release a stable 0.8.4 (basically 0.8.3 with bug fixes but without new features) if I get to it before working on the provider switch, but I can't promise that.

Created attachment 5510
switch-to-met.no-locationforecastlts-1.2-api.patch

Only usable after applying patch #5509.

In , Guy (guy-b) wrote :

Thank you Harald for your work and patches. I would like to try them but I don't know how to patch them. If you could explain it shortly I will do it.

In short, you would have to build the plugin yourself, applying the patches before compiling. I won't have time to help you with this, but if you're interested you can find instructions in the README. However, if you haven't done this before, you will probably need to seek help elsewhere.

Meanwhile I have got an answer from met.no. They have documented the new symbols on another of their many web pages, so I will create a new, more complete patch soon, making attachment #5509 obsolete. They have also told me they will fix the other issues that they haven't been aware of until now.

Leaving this bug report open until a new version has been released.

In , Guy (guy-b) wrote :

Created attachment 5525
Screenshot

In , Guy (guy-b) wrote :

Comment on attachment 5525
Screenshot

Does it mean that you will do an 8.4 version ?

I take the opportunity to say that the forecasts window doesn't enlarge enough to see all the informations (font), the size is 14 here.

<email address hidden>: Please do not hijack bug reports.

(In reply to Harald Judt from comment #6)
> it would be great if someone could try them and verify that
> the results look sane.

Harald, I built the 0.8.3 source from http://archive.xfce.org/src/panel-plugins/xfce4-weather-plugin/0.8/ with the two patches you supplied for the 1.2 API. Both patches applied successfully, however the patches were all offset by quite a few lines.

I've been using the newly built plugin for several days now and have noticed no adverse behavior. The prior warnings about met.no versions are gone and all features appear to be working properly.

I can also verify that these patches work as expected.

Sean Davis (bluesabre) on 2014-10-05
summary: - Plugin needs updated for locationforecast-1.2
+ [SRU] Plugin needs updated for locationforecast-1.2
Changed in xfce4-weather-plugin:
importance: Unknown → Medium
status: Unknown → Confirmed

Just noting that the old API version was disabled a couple of days ago so a new release would be great.

One can download the 0.8.3-2 version deb or rpm file from:

http://pkgs.org/download/xfce4-weather-plugin

It works fine on 14.04 of Xubuntu, which is all I have tried it on.

Sean Davis (bluesabre) on 2014-10-11
Changed in xfce4-weather-plugin (Ubuntu Utopic):
status: New → Fix Released
Sean Davis (bluesabre) on 2014-10-11
description: updated
Changed in xfce4-weather-plugin (Ubuntu Trusty):
status: New → In Progress

Is there a patched source tarball available someplace? The binary packages for 0.8.3.2 have unresolved dependencies on my Ubuntu-12.0.4 and Centos-6.3 machines.

@JohnThompson

You can download the latest source codewith this command on terminal:

git clone git://git.xfce.org/panel-plugins/xfce4-weather-plugin

then

cd xfce4-weather-plugin

sh autogen.sh

Even if it says to type 'make', I suggest to type:

./configure --prefix=/usr

bacause its default prefix is /usr/local. If your XFCE installation is
in /usr/local dont' need to run configure

I compiled it today 2014-10-13 on Salckware 14.1 because it stopped to work (no data error).

Now it works again. Thanks developers for patching it.

Thanks... I found a src.rpm on the Fedora "Koji" site, used rpmbuild to patch the source tree and build my Centos rpm, then "make distclean" to clean out the binaries from the patched source tree, tarred up the patched sources and copied to my Ubuntu machine. Then "./configure --prefix=/usr" and "checkinstall -D" to build a Debian package. Installed the new package and all is well again...

Please beware that the current git version still has a bug in the update routine, I've already mentioned that above. Nothing too bad, it won't make anything crash, but the sunrise/sunset dates and therefore night time status will not be updated correctly (which you might only notice after a day, and then probably not every time). Refreshing the data manually via the context menu or a middle-click on the panel widget might solve this too.

I've only noticed a few moments ago there have already been a lot of changes since 0.8.3. I'm currently investigating into this bug, but debugging and testing takes time due to the nature of the bug. I'm not sure I will find a clean solution quickly, but if I can work around my bad design of the update routine, then I'll do a dirty fix and release 0.8.4. Could take a week, or maybe even a month, depending on what other stuff steals my time...

BTW: If you look at the README and the goodies homepage, you'll find detailed instructions on how to download the source and build the plugin. You can simply apply the two patches from this bug report on 0.8.3, and this way you won't have to care about the update bug at all.

Hello Sean, or anyone else affected,

Accepted xfce4-weather-plugin into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xfce4-weather-plugin/0.8.3-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xfce4-weather-plugin (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Elfy (elfy) wrote :

updated, version xfce4-weather-plugin 0.8.3 added to panel

found my location, works as expected

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-weather-plugin (Ubuntu Precise):
status: New → Confirmed

Sometimes, right-clicking on the applet and telling it to Refresh works; sometimes you just have to wait. It's getting less and less reliable, now, day by day. If it isn't updated soon, it will become completely useless.

I did the git command, autogen.sh. .\configure make make install, rebooted, still doesn't work.

What is the executable called and were should it reside?

Any additional suggestions? I use slackware 14.1

John Culleton

I use Salckware 14.1 too, 32 bit.

The command is:

./configure --prefix=/usr

make

make install

but *first* you *must* remove old package xfce-weather-plugin for not messing things.

As root do:

cd /var/log/packages

then

removepkg xfce4-weather-plugin*

When you removed the old package compile the git source. I built the 32 bit
package for Slackware 14.1. If you have a 32 bit system I can email you the package.

The night/day update bug should be fixed in git now.

Thank you, Harald. I noticed the night/day bug this morning for the first time.

(In reply to stef from comment #27)
> Thank you, Harald. I noticed the night/day bug this morning for the first
> time.

Please test then if you can still reproduce it with current HEAD. Either leave the machine running over night (the bug should be visible at 00:00 the next day, but it might be more easily visible after sunrise because of the icon), or suspend/hibernate and then resume the next day. Use more than one plugin instance if possible, choosing different locations in settings. I've tested it on two machines and it looks good now, but I had already thought I had fixed it in the past and was proven wrong.

Hello Harald, thenaks for your work on this.

I've compiled the git copy today due to the stock Xubuntu version of the weather plugin not functioning at all. I compiled at ~1200 on Oct 19th, 2014 but am experiencing the moon being shown despite it still being day here in NYC.

Refreshes and such don't seem to be doing enough to correct the icons, but if there are any compile options or anything you'd like me to do to facilitate fixing this, feel free to ask.

(In reply to Andrew from comment #29)
> Hello Harald, thenaks for your work on this.
>
> I've compiled the git copy today due to the stock Xubuntu version of the
> weather plugin not functioning at all. I compiled at ~1200 on Oct 19th, 2014
> but am experiencing the moon being shown despite it still being day here in
> NYC.

http://git.xfce.org/panel-plugins/xfce4-weather-plugin/commit/?id=8517e7c6b62fd932a89c9470ae27e3a837d74938

Please verify you have this commit using git log. If you don't, pull the latest changes and recompile, reinstall and restart the panel (or do that anyway and try again, just to be sure).

A weather icon set that always shows day/night for every symbol will be helpful, try this: http://schizo-ri.deviantart.com/art/Flat-Circle-Weather-Icons-466542065

@Harald

>Please test then if you can still reproduce it with current HEAD. Either leave >the machine running over night (the bug should be visible at 00:00 the next >day, but it might be more easily visible after sunrise because of the icon), or >suspend/hibernate and then resume the next day.

Hello Harald.

I tested the latest git version of plugin. I set up 3 different instances, 3 different locations and hibernated the PC around 23:00, when icons showed moon.
This morning I resumed from hibernation and icons showed sun and data were correctly updated. It seems that the night/day bug was gone. Anyway, if it will happen again I will report.

Thanks for your report.

I have detected another problem that occurs when setting up or changing a location that is in a different timezone; seems to have something to do with the timezone setting. Only xfce4-panel -r helps here.

Carey Underwood (cwillu) wrote :

Is there an update coming for precise? A locally built package with the same patches works on my system.

Pushed a few commits which should solve the update problems and other bugs. If someone here can, please pull and test if everything works fine now.

(In reply to Harald Judt from comment #33)
> Pushed a few commits which should solve the update problems and other bugs.
> If someone here can, please pull and test if everything works fine now.

Harald, I just did a git clone to a Slackware 14.1 x86_64 system and built from source into a package with no issues. The new plugin went into a panel with no problems and configuration worked well. Everything seems to be operational but I'll give it at least 24 hours to see if any strange behavior arises.

-- Mike

(In reply to Harald Judt from comment #33)
> Pushed a few commits which should solve the update problems and other bugs.
> If someone here can, please pull and test if everything works fine now.

I tested latest git. Hibernated PC around 23:00, two locations, Italy and Australia. Resumed PC in the morning, data and icons updated correctly for both istances. Running weather plugin on Slackware 14.1, 32 bit.

Thanks for the work you've done.

(In reply to stef from comment #35)
> (In reply to Harald Judt from comment #33)
> > Pushed a few commits which should solve the update problems and other bugs.
> > If someone here can, please pull and test if everything works fine now.
>
> I tested latest git. Hibernated PC around 23:00, two locations, Italy and
> Australia. Resumed PC in the morning, data and icons updated correctly for
> both istances. Running weather plugin on Slackware 14.1, 32 bit.
>
> Thanks for the work you've done.

Thanks for reporting. I've done my own tests with 5 locations on two machines, seems to be ok now. Let's see if there are other small or severe bugs left to fix. If not, 0.8.4 will be released soon (need to coordinate that with translators).

jdt37b (jdt37b) wrote :

Hello,
I confirm that "xfce-weather-plugin" in official repositories of Precise (versions 0.7 and 0.8) returns "no data".
With Precise, this bug appeared from apparently related 3.2.0-69 or 3.2.0-70 kernels.
kind regards.

Hi,
I can confirm that after installing from git, it seems it is working
fine.
I didn't check after hibernate though if icons night/day change, will
see tomorrow.
Thanks for your work, looking for the release.

--
Thierry
Get my Gnupg key:
gpg --keyserver pgp.mit.edu --recv-keys 59F29997

Sean Davis (bluesabre) wrote :

Please release the updated package into trusty-updates. Verification of the package in trusty-proposed has been completed and the current package in trusty is non-functional.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-weather-plugin - 0.8.3-1ubuntu0.1

---------------
xfce4-weather-plugin (0.8.3-1ubuntu0.1) trusty; urgency=medium

  * Add patches from upstream git to use locationforcast-1.2 (LP: #1377612)
 -- Sean Davis <email address hidden> Sat, 11 Oct 2014 16:12:57 -0400

Changed in xfce4-weather-plugin (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for xfce4-weather-plugin has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

*** Bug 11257 has been marked as a duplicate of this bug. ***

Hi,
Thank you so much Judt for the patch

Plugin stopped working ("no data"), I pulled from git and recompiled as stef 2014-10-13 14:58:50 CEST suggested

And sorry for the duplicate bu request

It is a very clean plugin

Thanks!

Vittorio, GMT+1, Italy, Opensuse 13.1

Thank you very much for fixing the xfce weatherforecast!
Dieter.

0.8.4 has been released with the fix.

Changed in xfce4-weather-plugin:
status: Confirmed → Fix Released
jdt37b (jdt37b) wrote :

Hello,
Today, i confirmed this bug with Precise.
With Xubuntu 12.04.5 LTS (Precise), kernel 3.2.0-70, and "xfce4-weather-plugin" 0.8.3" taken in the official repositories of Precise, weather date not appears for a few months : "pas de données disponibles" (no data).
(I read it's ok only with >= Trusty)
Thank you.

I'm using 0.8.6. But still details tab has this -
"Met.no sunrise API states that this version of the webservice
is deprecated, and the plugin needs to be adapted to use
a newer version, or it will stop working within a few months.
Please file a bug on https://bugzilla.xfce.org if no one
else has done so yet.".

I still get this as of today (06-18-2016):

Met.no sunrise API states that this version of the webservice
 is deprecated, and the plugin needs to be adapted to use
 a newer version, or it will stop working within a few months.
 Please file a bug on https://bugzilla.xfce.org if no one
 else has done so yet.

This is on Xubuntu 16.04 64 bit.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.