Ubuntu

xfce4-volumed crashed with SIGFPE in __libc_start_main()

Reported by Petr Tomeš on 2009-10-09
226
This bug affects 38 people
Affects Status Importance Assigned to Milestone
xfce4-volumed
High
Steve Dodier-Lazaro
xfce4-volumed (Ubuntu)
Medium
Unassigned
Declined for Karmic by Lionel Le Folgoc

Bug Description

Binary package hint: xfce4-volumed

crash

ProblemType: Crash
Architecture: amd64
Date: Fri Oct 9 15:25:27 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/xfce4-volumed
Package: xfce4-volumed 0.1.4-0ubuntu1
ProcCmdline: /usr/bin/xfce4-volumed
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-12.41-generic
Signal: 8
SourcePackage: xfce4-volumed
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 __libc_start_main () from /lib/libc.so.6
 ?? ()
Title: xfce4-volumed crashed with SIGFPE in __libc_start_main()
Uname: Linux 2.6.31-12-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (polkit-gnome-authentication-agent-1:1683): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (xfce4-mixer-plugin:1713): libxfce4mixer-CRITICAL **: xfce_mixer_get_track: assertion `GST_IS_MIXER (card)' failed

Petr Tomeš (ptomes) wrote :

StacktraceTop:xvd_calculate_avg_volume ()
xvd_mixer_init_volume ()
main ()

Changed in xfce4-volumed (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Changed from private to public

visibility: private → public
Changed in xfce4-volumed (Ubuntu):
status: New → Confirmed

same on karmic i386

Steve Dodier-Lazaro (sidi) wrote :

I didn't even notice this bug... It looks like a crash in gstreamer, though. I will have a look at it in a few weeks.

Changed in xfce4-volumed (Ubuntu):
assignee: nobody → Steve Dodier (sidi)

Hi

My error is error duplicate #589807

Extra info
The error occurs with a KeyBoard Logitech EX 100 ... My PC is an Athlon XP and occurred using a CD-Live Xubuntu 10.04

tags: added: bugpattern-needed
Frank Arnold (frog98146) wrote :

I just reported this bug and was told that this was a duplicate of this one OK so what was this person doing that was the same as I. This is with Ubuntu 9.10 Mine is with Xununtu 10.04 Live CD and I just loaded it as a live CD not on the HD. and the desktop showed up and all the programs loaded and then this error showed up. So I did nothing but load and was waiting for everything to load

It was stated that the person assigned to this bug would check it out in three weeks but here 6 months later it shows up again. So maybe instead of just saying these are all the same bugs maybe they should all be looked at and maybe a sullusion could be found. I know I work at a resturant and when there is a problem cleaning a table they don't just say OH he is just like Joe, Jim, Marry, and Tim no they look at what is John not doing to make it where John can do his job right.

Why don't you look at all these problems and see if you can correct them one by one. I was told to come here to see if there is a work around well I don't see one so what do I do now wait 6 months till some one else reports it and then see there is still no answer.

Sorry if it sounds like I have an attitude
This bug as you put it was reported by Petr Tomeš on 2009-10-09 as Bug #447209

Then almost a month latter
Steve Dodier on 2009-11-07
Changed in xfce4-volumed (Ubuntu):
assignee: nobody → Steve Dodier (sidi)
Steve Dodier wrote on 2009-11-07: #6
I didn't even notice this bug... It looks like a crash in gstreamer, though. I will have a look at it in a few weeks.

Now all these bugs and they are said to be the same

Duplicates of this bug

    * Bug #451206
    * Bug #453817
    * Bug #469039
    * Bug #476548
    * Bug #485882
    * Bug #491423
    * Bug #556198
    * Bug #578642
    * Bug #589084
    * Bug #589807
    * Bug #598005

OK so when well there be an answer with a work around or a fix, other then this is the same bug?

Roy Jamison (xteejx) wrote :

Please don't assign yourself unless you are actively developing with this bug report. Note: Triaging does not count in these instances.
Can someone tell us what happens when this crashes? Does it close, does it stall/hang? Is there anything which seems related, and how can we reproduce this?
Thank you.

Changed in xfce4-volumed (Ubuntu):
assignee: Steve Dodier (sidi) → nobody
status: Confirmed → Incomplete
Roy Jamison (xteejx) wrote :

@Frank: The majority of Ubuntu bug triagers are volunteers and cannot always come back to bug reports as quickly as we'd like. Nevertheless; the reason your bug was marked as a duplicate is because the Apport Retracer has determined that it is the same problem, and it does look pretty much the same. This bug report is about Xubuntu or Ubuntu with xfce4, which are essentially the same.

Lionel Le Folgoc (mrpouit) wrote :

> Please don't assign yourself unless you are actively developing with this bug report.

Sigh... Well, he's the upstream developer you know.

Lionel Le Folgoc (mrpouit) wrote :

@Steve: I agree it is likely a bug in gstreamer (probably Inst->track->max_volume - Inst->track->min_volume = 0, so the division cannot be done), but you should probably protect xvd_calculate_avg_volume() from that by not doing the division in this case (that was just from a quick look, the bug might be elsewhere).

Roy Jamison (xteejx) wrote :

Oops! Sorry about that. I thought someone had assigned themselves without working on it, my mistake. Keep up the good work :)

Frank Arnold (frog98146) wrote :

***Copy and Paste started***
Please don't assign yourself unless you are actively developing with this bug report. Note: Triaging does not count in these instances.
Can someone tell us what happens when this crashes? Does it close, does it stall/hang? Is there anything which seems related, and how can we reproduce this?
Thank you.
***Copy and paste End***

Teej
Number 1 I did not assign myself to anything
Number 2 I can try and repruduce it and see if I get the error again. I will report the findings here latter.

Teej OK here is what happen when I got the error when I reported the bug. I hope this helps.

What I was doing when I got this error = I run the Live CD for X-Ubuntu 10.04 It went through the install at the end the desk top came up and loaded.

What I expected to happen = to see the log in screen where I beleive we just hit enter enter

What happen instead = the error box open up with xfce4-volumed crashed with SIGFPE in __libc_start_main

Note to who ever reads this to try and fix this problem = After I clicked to report the bug and closed the bug report window every thing worked Now I use Ubuntu 10.04 on my desk top and as a duel boot on my laptop and 8.4 on the church desk top. On all these the the top menu reads Application Places System On X-Ubuntu 10.04 it read Application Places and the System is listed under Applications not as a menu Item. Also as a side note when I looked up under help to find the verion I was using it said I was using Ubuntu 9.10. The desk top was the one for 10.04 not the desktop in 9.10.

I have to talk with my roommate as the laptop I was loading (Live CDing not an install to hard drive) it on is his.

I hope this added info helps you all work this out.

Frank Arnold (frog98146) wrote :

Teej Sorry Disregard Number 1 I just saw your Oops comment.So I guess we just Oopsing it up in here

Frank Arnold (frog98146) wrote :

OK here is my follow up.

Here is what I did to cause this bug again

1 loaded CD
2 Reboot
3 pushed Enter key at screen with countries (picked US)
4 loaded install screen picked try without installing
5 loading screen (black with white letters Xubuntu)
6 Desk top loads (without me touching anything the Application Problem Pop up opens with error)
    Sorry, XFCE Volume
    Daemon Closed
    Unexpected
7 Took screen shot (will attach)

So that is what happen step by step

Should note that when I go to help It 's XUbuntu 9.10 the CD is XUbuntu 10.04 Live i386.iso
Also like I said before everything seems to be working without this program running

Here is the system I'm running the Live CD on

Toshiba 15.4 Laptop
Satellite A105-S4094
Intel Centrino Dou Cor Processor T2250
120g HD
2g Ram

I hope this helps

Kamikaze321 (d-gun) wrote :

Crash during login to OS

Thank you for your response and the added information. This bug is valid and confirmed again.

Changed in xfce4-volumed (Ubuntu):
status: Incomplete → Confirmed
Frank Arnold (frog98146) wrote :

@Charlie Kravetz

Thank you for reopening this.

By the way I loaded this on a P4 1.6 ghz, 1g ram, 80g hd.

It loaded fine, installed to hard drive and it did the same thing. Rebooted and I got a error.
File not found.
Load Gump>

The drive acted as if it had no OS on it. Don't know if this it related to this same bug. Installed like 3 times and the same results.

Here is what I did.

1 Load CD
2 pick install
3 everything installs
4 boot from HD
5 everything loads to desk top
6 gets error
   Pop up opens with error)
     Sorry, XFCE Volume
     Daemon Closed
     Unexpected
7 click to report
8 every thing works
9 close down PC
10 turn PC on get error
        File not found.
        Load Gump, Grip, grimp> something like that the file Linux is built on. Sorry I would load it again but don't want to have to load Win XP again.

I have to use this computer for my Business so I reloaded Win XP. will try again when the bug gets fixed I guess.

Ubuntu 8.4 and 10.04 is working fine on other computers and due boot on laptop. Hardly use win XP on laptop any more.

Hope You all can find a fix.

Steve Dodier-Lazaro (sidi) wrote :

I feel like a comment is needed from me, since I'm the person who was meant to fix this bug a long time ago. Here is why it has not and will probably never be fixed:

The bug is triggered on a limited set of hardware configurations, of which I own none. On the computer on which xvd was developed, it never crashed. On my alternative laptop, it crashed 4 times in six months, and I suspect this was due to another problem related to my not-so-stable Pulseaudio + Wine + crappy BIOS/Kernel setup.

The exact problem, as far as I can diagnose it, is a crash on track volume querying. I do not know any more. I can not use a debugger to find where it crashes since I can't reproduce the bug. I almost know nothing of GStreamer, so I am not able to quote reasons that would lead to a crash when a client application queries volume for an apparently valid track. I believe I assigned one of the duplicate reports to the GStreamer team, but got no answer.

#8, Frank, all these reports are automated reports of the same bug happening on different setups. Considering the number of reports, it affects a lot of people, yet a much bigger lot of people uses xvd without any problem. Do not think the problem is being disregarded, I just can not help it (see above as for why). It is rather pretentious of you to write "stop saying you'll fix it, and fix it". I spent hours looking for solutions to this problem, and if I could not find one, it's certainly not my fault.

#9, Teej, I should have assigned myself to the upstream project instead of the Ubuntu package, I'll grant you that. This is now done. Anyone able to diagnose the bug better than me and to step in for fixing it is free to assign oneself instead of me.

#12, Lionel, that would have caused a SIGFPE and not a SIGSEGV. The problem is below, unfortunately. However, you're right about the lack of sturdiness of the code (eventhough I know no configuration where the volume range could be 0). Opening a new report about that. Thanks.

#16, Frank, thanks for the hardware configuration. Would you be kind enough to check (with the lshw command) what model of sound card do you exactly own? Also, kernel versions (uname -a) and gstreamer versions (apt-cache policy libgstreamer-plugins-base0.10-0) might help any passer-by developer who knows about GStreamer.

#19, Frank, the other problem seems completely unrelated. Please open a new report against Xubuntu with the *exact* error messages you get.

Final comment: I need exact hardware/kernel/gstreamer configurations. There is no way for me to fix the bug, but anybody with the same configuration and who knows about debugging/development may be able to have a look. If you can reproduce the bug, a GDB trace of where it crashes (with the GStreamer debugging symbols installed, a nice function stack, and possibly some prints of the function parameters / local variables in where it crashes and the 1 or 2 functions above, plus the last function located in xvd) is more than welcome.

Changed in xfce4-volumed:
assignee: nobody → Steve Dodier (sidi)
importance: Undecided → High
status: New → Won't Fix
To post a comment you must log in.