xfce4-volumed crashed with SIGSEGV in __libc_start_main()

Bug #405060 reported by Andrew on 2009-07-26
192
This bug affects 22 people
Affects Status Importance Assigned to Milestone
xfce4-volumed
High
Steve Dodier-Lazaro
xfce4-volumed (Ubuntu)
Medium
Steve Dodier-Lazaro

Bug Description

Binary package hint: xfce4-volumed

Crash notification just appeared, immediately followed by one for Firefox. Everything seemed to continue working though!

ProblemType: Crash
Architecture: amd64
Date: Sun Jul 26 23:26:08 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/xfce4-volumed
Package: xfce4-volumed 0.1.1-0ubuntu1
ProcCmdline: /usr/bin/xfce4-volumed
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-4.22-generic
SegvAnalysis:
 Segfault happened at: 0x402e4a <g_log@plt+2594>: movslq 0x24(%rax),%rdi
 PC (0x00402e4a) ok
 source "0x24(%rax)" (0x00000024) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: xfce4-volumed
StacktraceTop:
 ?? ()
 ?? ()
 __libc_start_main () from /lib/libc.so.6
 ?? ()
 ?? ()
Title: xfce4-volumed crashed with SIGSEGV in __libc_start_main()
Uname: Linux 2.6.31-4-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Andrew (andrewfarri1) wrote :

StacktraceTop:xvd_mixer_init_volume (Inst=0x1e96690)
main (argc=<value optimized out>,

Changed in xfce4-volumed (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public
Steve Dodier-Lazaro (sidi) wrote :

Hello and thanks for your report,

May you please tell me if you have installed Karmic in a virtual machine or in a real system, and, if it's in a virtual machine, whether or not you have activated sound support for this virtual machine ?

May you please also check if you have PulseAudio running ? And finally, if you launch "xfce4-mixer", does it open normally or does it trigger an error dialog ? If it opens normally, do you have at least one available sound card ?

Thanks in advance.

Changed in xfce4-volumed (Ubuntu):
status: New → Incomplete
assignee: nobody → Steve Dodier (sidi)
Download full text (3.2 KiB)

Hi,

It's a normal installation on a single partition, along with several
other Linux distros on other partitions.

I've not activated Pulse Audio. Does this mean it's not running? I
can't check now because I messed Xubuntu up trying to activate the ATI
video driver! I might reinstall alpha 3 or wait for the next one, and
try again.

There was no error message when opening the sound mixer. I have had
trouble getting the sound to work though. Using the live CD, the mixer
gave a choice of two options, although there's only the one onboard
sound device. One of these worked OK on the live CD, but at first the
installation only showed the one that didn't work. I think one of the
updates fixed this, as it started listing both options with no other
action from me, and one worked OK, as with the live CD.

I hope this is some use.

Andrew Farrington

>----Original Message----
>From: <email address hidden>
>Date: 31/07/2009 21:50
>To: <email address hidden>
>Subj: [Bug 405060] Re: xfce4-volumed crashed with SIGSEGV in
__libc_start_main()
>
>Hello and thanks for your report,
>
>May you please tell me if you have installed Karmic in a virtual
machine
>or in a real system, and, if it's in a virtual machine, whether or
not
>you have activated sound support for this virtual machine ?
>
>May you please also check if you have PulseAudio running ? And
finally,
>if you launch "xfce4-mixer", does it open normally or does it trigger
an
>error dialog ? If it opens normally, do you have at least one
available
>sound card ?
>
>Thanks in advance.
>
>** Changed in: xfce4-volumed (Ubuntu)
> Status: New => Incomplete
>
>** Changed in: xfce4-volumed (Ubuntu)
> Assignee: (unassigned) => Steve Dodier (sidi)
>
>--
>xfce4-volumed crashed with SIGSEGV in __libc_start_main()
>https://bugs.launchpad.net/bugs/405060
>You received this bug notification because you are a direct
subscriber
>of the bug.
>
>Status in “xfce4-volumed” package in Ubuntu: Incomplete
>
>Bug description:
>Binary package hint: xfce4-volumed
>
>Crash notification just appeared, immediately followed by one for
Firefox. Everything seemed to continue working though!
>
>ProblemType: Crash
>Architecture: amd64
>Date: Sun Jul 26 23:26:08 2009
>DistroRelease: Ubuntu 9.10
>ExecutablePath: /usr/bin/xfce4-volumed
>Package: xfce4-volumed 0.1.1-0ubuntu1
>ProcCmdline: /usr/bin/xfce4-volumed
>ProcEnviron:
> LANG=en_GB.UTF-8
> SHELL=/bin/bash
>ProcVersionSignature: Ubuntu 2.6.31-4.22-generic
>SegvAnalysis:
> Segfault happened at: 0x402e4a <g_log@plt+2594>: movslq 0x24(%rax),%
rdi
> PC (0x00402e4a) ok
> source "0x24(%rax)" (0x00000024) not located in a known VMA region
(needed readable region)!
> destination "%rdi" ok
>SegvReason: reading NULL VMA
>Signal: 11
>SourcePackage: xfce4-volumed
>StacktraceTop:
> ?? ()
> ?? ()
> __libc_start_main () from /lib/libc.so.6
> ?? ()
> ?? ()
>Title: xfce4-volumed crashed with SIGSEGV in __libc_start_main()
>Uname: Linux 2.6.31-4-generic x86_64
>UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>

How safe is your data? Find out more about the issues at Tiscali Security Centre - http://www.tiscali.co.uk/security
_________________________...

Read more...

Steve Dodier-Lazaro (sidi) wrote :

Thanks for your output. I'll have a look at it. Could you please attach the following file to the report :

~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-mixer.xml

Thanks in advance. Let me know if it keeps crashing, and if it does, please attach the same file again, so I can check if anything changed.

Changed in xfce4-volumed (Ubuntu):
status: Incomplete → Triaged
Andrew (andrewfarri1) wrote :

As I said, I might not get the chance to try this installation again!
If I do, or if I reinstall, and anything like this happens, I'll
remember which file you want!

>----Original Message----
>From: <email address hidden>
>Date: 01/08/2009 13:56
>To: <email address hidden>
>Subj: [Bug 405060] Re: xfce4-volumed crashed with SIGSEGV in
__libc_start_main()
>
>Thanks for your output. I'll have a look at it. Could you please
attach
>the following file to the report :
>
>~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-mixer.xml
>
>Thanks in advance. Let me know if it keeps crashing, and if it does,
>please attach the same file again, so I can check if anything
changed.
>
>--
>xfce4-volumed crashed with SIGSEGV in __libc_start_main()
>https://bugs.launchpad.net/bugs/405060
>You received this bug notification because you are a direct
subscriber
>of the bug.
>
>Status in “xfce4-volumed” package in Ubuntu: Triaged
>
>Bug description:
>Binary package hint: xfce4-volumed
>
>Crash notification just appeared, immediately followed by one for
Firefox. Everything seemed to continue working though!
>
>ProblemType: Crash
>Architecture: amd64
>Date: Sun Jul 26 23:26:08 2009
>DistroRelease: Ubuntu 9.10
>ExecutablePath: /usr/bin/xfce4-volumed
>Package: xfce4-volumed 0.1.1-0ubuntu1
>ProcCmdline: /usr/bin/xfce4-volumed
>ProcEnviron:
> LANG=en_GB.UTF-8
> SHELL=/bin/bash
>ProcVersionSignature: Ubuntu 2.6.31-4.22-generic
>SegvAnalysis:
> Segfault happened at: 0x402e4a <g_log@plt+2594>: movslq 0x24(%rax),%
rdi
> PC (0x00402e4a) ok
> source "0x24(%rax)" (0x00000024) not located in a known VMA region
(needed readable region)!
> destination "%rdi" ok
>SegvReason: reading NULL VMA
>Signal: 11
>SourcePackage: xfce4-volumed
>StacktraceTop:
> ?? ()
> ?? ()
> __libc_start_main () from /lib/libc.so.6
> ?? ()
> ?? ()
>Title: xfce4-volumed crashed with SIGSEGV in __libc_start_main()
>Uname: Linux 2.6.31-4-generic x86_64
>UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>

How safe is your data? Find out more about the issues at Tiscali Security Centre - http://www.tiscali.co.uk/security
_______________________________________________________________________

Changed in xfce4-volumed (Ubuntu):
status: Triaged → In Progress
Dave Morley (davmor2) wrote :

Is still occuring on the alpha4 candidate cds

Steve Dodier-Lazaro (sidi) wrote :

Could someone experiencing the problem please try the latest version of xfce4-volumed (it should be packaged soon anyway) ?

bzr branch lp:xfce4-volumed
cd xfce4-volumed
./autogen.sh
./configure
make
killall xfce4-volumed
./src/xfce4-volumed

Changed in xfce4-volumed:
status: New → Triaged
importance: Undecided → Wishlist
assignee: nobody → Steve Dodier (sidi)
importance: Wishlist → High
Steve Dodier-Lazaro (sidi) wrote :

Could someone experiencing this bug please check that it doesn't happen anymore with the bzr trunk ?

Changed in xfce4-volumed:
status: Triaged → Fix Committed
Changed in xfce4-volumed (Ubuntu):
status: In Progress → Fix Committed
Mario Limonciello (superm1) wrote :

Is there a trunk deb anywhere? It would be a lot easier to get testers if so. I'm certainly still getting crashes.

Hi Mario,
You can try to build lp:xfce4-volumed .I'm honnestly not capable of properly
packaging every commit and of maintaining a PPA. I'm almost done for the
next release, which so far seems to be much more stable. I'm awfully sorry
for this damn crash message on every login in Karmic. I don't even
understand why it was crashing.

Lionel Le Folgoc (mrpouit) wrote :

Should be fixed with xfce4-volumed 0.1.4. Could you test and report? Thanks!

Changed in xfce4-volumed:
status: Fix Committed → Fix Released
Changed in xfce4-volumed (Ubuntu):
status: Fix Committed → Fix Released
Mukul Singhal (mukulsinghal) wrote :

It's working fine for me now.

where is the fix available ?
on motnh after being tagged fix-released, the same bug is still in karmic.

Steve Dodier-Lazaro (sidi) wrote :

This bug is fixed as far as I know. If you still have a problem with xfce4-volumed, please report a new bug to your distribution (using ubuntu-bug in your case). Also, make sure you attach ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-mixer.xml and make sure you do NOT have pulseaudio installed / running when the crash occurs.

tags: added: iso-testing
To post a comment you must log in.