Please drop the xfconf 4.6 migration script

Bug #587933 reported by Martin Pitt on 2010-05-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xfce4-utils (Ubuntu)
Undecided
Martin Pitt

Bug Description

Binary package hint: xfce4-utils

Now that lucid LTS is out, I think it's time to drop the xfconf migration script. This will eliminate a costly (Perl) script during boot, as well as avoid some 3 MB of Perl library dependencies.

Thanks for considering!

Martin Pitt (pitti) wrote :
Lionel Le Folgoc (mrpouit) wrote :

Hi,

Agreed, although it is automatically disabled after the first session startup, so it will only speed up one boot. ;)

However, your patch does not seem to handle the conffile removal.

I don't think I'll have time to upload that before thursday, so if you absolutely want it applied for the alpha, go ahead (otherwise I'll upload it next week-end). Thanks!

Changed in xfce4-utils (Ubuntu):
status: New → Confirmed

 assignee pitti

Hello Lionel,

Lionel Le Folgoc [2010-05-31 19:59 -0000]:
> However, your patch does not seem to handle the conffile removal.

Ah, right. I'll improve that. (Sorry, I didn't need that for the
project I was working on)

> I don't think I'll have time to upload that before thursday, so if you
> absolutely want it applied for the alpha

Nah, it's not urgent at all.

Thanks,

Martin
--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Changed in xfce4-utils (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) on 2010-06-01
Changed in xfce4-utils (Ubuntu):
status: Confirmed → In Progress
tags: added: patch-needswork
removed: patch
Martin Pitt (pitti) wrote :

Ah, I can push to the branch, so I just committed it directly, including upgrade handling. I tested it locally:

$ sudo dpkg -i xfce4-utils_4.6.2-1ubuntu2_amd64.deb
[...]
Vorbereiten zum Ersetzen von xfce4-utils 4.6.1-2ubuntu2 (durch xfce4-utils_4.6.2-1ubuntu2_amd64.deb) ...
Removing unmodified obsolete conffile /etc/xdg/autostart/xfconf-migration-4.6.desktop
[...]

Changed in xfce4-utils (Ubuntu):
status: In Progress → Fix Committed
tags: added: patch
removed: patch-needswork
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-utils - 4.6.2-1ubuntu2

---------------
xfce4-utils (4.6.2-1ubuntu2) maverick; urgency=low

  * debian/rules: Drop the 4.6 config migration script and autostart file,
    it's not needed for hedley and wastes boot time. (LP: #587933)
  * debian/control: Due to the change above, drop the libxml-parser-perl
    dependency to save some more disk space.
  * debian/preinst: Clean up migration script on upgrade. This needs to be
    kept until after the next LTS.
 -- Martin Pitt <email address hidden> Mon, 14 Jun 2010 12:01:15 +0200

Changed in xfce4-utils (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches