Ubuntu

xfce4-terminal create a zombie

Reported by Daniel Mehrmann on 2012-05-08
64
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
lxterminal (Ubuntu)
Undecided
Unassigned
xfce4-terminal (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,

I'm running Xubuntu 12.04 and every time i'm open a xfce4 terminal window it creates a zombie process as well:

daniel@Homer-Mobil:~$ ps -ely |grep -i terminal
S 1000 2909 1 0 80 0 14188 14593 poll_s ? 00:00:02 xfce4-terminal
Z 1000 2910 2909 0 80 0 0 0 exit ? 00:00:00 xfce4-terminal <defunct>

It happens only with the first terminal and the zombie process says good bye if the window get closed.
Well, it has no impact about the terminal and everything run smoothly, but it shouldn't happens.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xfce4-terminal 0.4.8-1ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic i686
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
Date: Tue May 8 13:12:37 2012
InstallationMedia: Xubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
ProcEnviron:
 LANGUAGE=de_DE:en
 TERM=xterm
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: xfce4-terminal
UpgradeStatus: No upgrade log present (probably fresh install)

tags: added: xfce4-terminal
ian ivy (tomek-cv) wrote :

Hi, same thing here. I am using Xubuntu 12.04 with latest 3.2.0-24-generic i686 kernel.

user@host> ps aux | awk '{ print $8 " " $2 }' | grep -w Z
Z 2471

user@host> ps -el |grep Z
F S UID PID PPID C PRI NI ADDR SZ WCHAN TTY TIME CMD
1 Z 1000 2471 2470 0 80 0 - 0 exit ? 00:00:00 xfce4-terminal <defunct>

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-terminal (Ubuntu):
status: New → Confirmed
ATIpro (somebody2112) wrote :

It's not only xfce4-terminal, but also lxterminal and may be related with vte.

$ ps -el |grep Z
F S UID PID PPID C PRI NI ADDR SZ WCHAN TTY TIME CMD
1 Z 1000 1760 1759 0 80 0 - 0 exit ? 00:00:00 lxterminal <defunct>

Dave Pusey (davepusey) wrote :

I'm getting this too on Ubuntu 12.04 Server

Cody P (codyp) wrote :

This is because of a bug in libvte9.

The path it uses for gnome-pty-helper is:

strings /usr/lib/libvte.so.9|grep gnome-pty-helper
/usr/lib/vte/gnome-pty-helper

whereas the libvte9 package puts it in:
/usr/lib/libvte9/gnome-pty-helper

ln -s /usr/lib/libvte9 /usr/lib/vte solves it until the package is fixed.

tags: added: libvte9 lxterminal
Cody P (codyp) wrote :
Axel Beckert (xtaran) wrote :

The referred Debian Bug refers itself to https://bugs.launchpad.net/ubuntu/+source/vte/+bug/864609 which is marked as fixed. But maybe it's not fixed in Precise? Should this be marked as duplicated? I at least have quite some Precise boxes with xfce4-terminal and lxterminal zombies.

Axel Beckert (xtaran) wrote :
Changed in debian:
status: Unknown → Fix Released
daniel CURTIS (krikras) wrote :

Hi. `xfce4-terminal` still creates an zombie process in Xubuntu 12.04.2 (with all installed updates). So, for me, this bug still is not fixed, because for example 'top' command shows; [ Tasks: (...) 1 zombie ]. This bug is still available in 'xfce4-terminal' ver. '0.4.8-1ubuntu1'. Some checks on zombie process etc.;

,-------[ zombie ck ]
| $ ps aux | awk '{ print $8 " " $2 }' | grep -w Z ]
| Z 3021
|
| $ ps -el |grep Z
| F S UID PID PPID C PRI NI ADDR SZ WCHAN TTY TIME CMD
| 1 Z 1000 3021 3020 0 80 0 - 0 exit ? 00:00:00 xfce4-terminal <defunct>
`-------

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.2 LTS
Release: 12.04
Codename: precise

Best regards!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lxterminal (Ubuntu):
status: New → Confirmed
Andreas Wirooks (nudgegoonies) wrote :

Same problem here with ubuntu 12.04 LTS with xfce4 installed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.