[SRU] xfce4-terminal 0.8.7.4, New upstream microrelease

Bug #1782327 reported by Sean Davis on 2018-07-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xfce4-terminal (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Sean Davis

Bug Description

[Rationale]

This is primarily a usability and translations release to improve the experience for all users.

Usability Improvements:
- Fix new tab being one pixel short under some GTK themes (e.g., Greybird) which led to changing the window geometry and losing a row (Xfce #13263)
- Add standalone Terminal Preferences item to Xfce Settings
- Add info on accels.scm to the man page
- Reduce the Preferences dialog height
- Keep the active tab when restoring a saved Xfce session.
- Convert "Relaunch" dialog to GtkInfoBar to make it less intrusive
- Add tooltips for "Set Title" popover elements

Bug Fixes:
- Tab became active if unclosed to the left of the current tab
- First show the terminal and then update its settings (Xfce #14322)

Translations:
Bulgarian, Catalan, Chinese (China), Chinese (Taiwan), Croatian, Czech, Danish, Dutch, English (Australia), French, German, Hebrew, Hungarian, Japanese, Lithuanian, Malay, Polish, Portuguese, Portuguese (Brazil), Russian, Turkish, Ukrainian

[Regression Potential]

Minimal. This is a point release with few core changes and a fair bit of testing by the Xubuntu team within the development PPAs.

[NEWS]
- Tab became active if unclosed to the left of the current tab
- Fix new tab being one pixel short under some GTK themes (e.g., Greybird) which led to changing the window geometry and losing a row (Xfce #13263)
- Resolve deprecation of vte_terminal_match_set_cursor_type()
- Add --preferences command line option and corresponding .desktop file: this allows to open a standalone Preferences dialog from Xfce Settings (Xfce #13249)
- Add command line options for setting text (foreground) and backround colors: --color-text and --color-bg, respectively (Xfce #4887)
- Add "Copy Input" action: it shows a popover and allows to copy the input to all tabs within the current window (Xfce #10047)
- Update URLs to use https protocol
- Add info on accels.scm to the man page
- Reduce the Preferences dialog height
- First show the terminal and then update its settings (Xfce #14322)
- Add command line option --active-tab which allows to specify active tab within a window. It also allows to keep the active tab when restoring a saved Xfce session.
- Convert "Relaunch" dialog to GtkInfoBar to make it less intrusive
- Add tooltips for "Set Title" popover elements
- Resolve the warnings gcc8 has introduced
- Translation updates: Bulgarian, Catalan, Chinese (China), Chinese (Taiwan), Croatian, Czech, Danish, Dutch, English (Australia), French, German, Hebrew, Hungarian, Japanese, Lithuanian, Malay, Polish, Portuguese, Portuguese (Brazil), Russian, Turkish, Ukrainian

Sean Davis (bluesabre) on 2018-07-18
description: updated
Sean Davis (bluesabre) wrote :

Attaching package debdiff.

description: updated
Changed in xfce4-terminal (Ubuntu Bionic):
status: New → In Progress
Simon Quigley (tsimonq2) wrote :

Sponsored.

Changed in xfce4-terminal (Ubuntu Bionic):
status: In Progress → Fix Committed
assignee: nobody → Sean Davis (bluesabre)
Robie Basak (racb) wrote :

SRU review:

I'm a bit dubious about new features like --preferences and --active tab being upstream "microrelease" updates. But SRU policy allows new features in an LTS, and they're new features that shouldn't affect existing users, so OK given they're trivial enough. Everything else looks fine, and thank you for calling these out in the SRU details in the bug description.

tags: added: verification-needed verification-needed-bionic

Hello Sean, or anyone else affected,

Accepted xfce4-terminal into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xfce4-terminal/0.8.7.4-0ubuntu0.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xfce4-terminal (Ubuntu):
status: New → Fix Released
Sean Davis (bluesabre) wrote :

Installed 0.8.7.4-0ubuntu0.18.04.1 on a completely up-to-date Bionic, then tested out the documented improvements. Everything seems to be working as intended. Verification done.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-terminal - 0.8.7.4-0ubuntu0.18.04.1

---------------
xfce4-terminal (0.8.7.4-0ubuntu0.18.04.1) bionic; urgency=medium

  * New upstream release (LP: #1782327)

 -- Sean Davis <email address hidden> Wed, 18 Jul 2018 06:11:42 -0400

Changed in xfce4-terminal (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for xfce4-terminal has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches