xfce4-terminal graphical corruption

Bug #145658 reported by Greg Toombs on 2007-09-27
4
Affects Status Importance Assigned to Milestone
xfce4-terminal (Ubuntu)
Medium
Unassigned

Bug Description

In gutsy, using the fglrx driver, xfce4-terminal sometimes has graphical corruption. This includes drawing incorrect characters or characters from a previous line. The most easily reproducible problem is that when you drag the window, the background of the terminal wherever there isn't a character becomes black.

$uname -a
Linux shuffles 2.6.22-12-generic #1 SMP Sun Sep 23 18:11:30 GMT 2007 i686 GNU/Linux

xfce4-terminal version 0.2.6-3ubuntu1 (gutsy)
linux-restricted-modules-2.6.22 version 2.6.22.4-12.3 (gutsy)

I'll include other information on request.

Greg Toombs (greg-toombs) wrote :

Thank you for your bug report. Do you still have this issue after updates ?

Changed in xfce4-terminal:
importance: Undecided → Medium
status: New → Incomplete
wolfger (wolfger) wrote :

Over 4 months without a response. We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in xfce4-terminal:
status: Incomplete → Invalid
Greg Toombs (greg-toombs) wrote :

Sorry about the delay. In Gutsy, this problem seems to be caused by a bug in fglrx, and only when compositing is enabled. There are a host of other rendering glitches that also occur when compositing is enabled. xfce compositing works "most of the time", but some windows often show garbage video memory. In Hardy none of these problems occur anymore, so I would mark this as 'fixed' rather than 'invalid'.

In case you're curious, I've also attached my xorg log.

Changed in xfce4-terminal:
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers