Would like to see color profile option added

Bug #1384381 reported by C. Jeffery Small
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xfce4-terminal
Fix Released
Wishlist
xfce4-terminal (Ubuntu)
Wishlist
Unassigned

Bug Description

This is an enhancement request.

Xubuntu 14.04.1
xfce4-terminal 0.6.3

I would like to see the ability to adjust the background and text colors be made available on a window-by-window basis. The ability to display terminal windows with different color schemes is often useful.

This could be done with commandline options similar to xterm (-bg, -fg, -cr, -hc, etc) or through saved color profiles which could we set on the commandline or selected from the terminal menu, as is done with gnome-terminal. xfce4-terminal operates from these other emulators in certain ways which makes replacing it with one of the other programs undesirable. Adding this color management featire would be the best solution.

Revision history for this message
In , Robert (robrwo) wrote :

It would be nice to have a means of changing the colours using the command-line (either explicitly specifying the colours, as with xterm, or specifying a profile, as with roxterm or gnome-terminal).

I use a script to open different terminals in different colours, based on how many existing terminal windows are open on the desktop. I've gotten this idea from colleagues who do something similar. For some of us who work with multiple terminals on a desktop, this is a helpful way of quickly identifying which terminal is connected to which server.

Revision history for this message
In , srdjan (srdjan-djenka) wrote :

Also, it would be great to have means of changing the colours dynamically from the terminal itself. Utilities that do that for other terminals:
xtermcontrol
dbus-send (roxterm)

Revision history for this message
Thaddaeus Tintenfisch (thad-fisch-deactivatedaccount) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/Xfce. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Thomas Ward (teward)
Changed in xfce4-terminal (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-terminal (Ubuntu):
status: New → Confirmed
Revision history for this message
In , Igor Zakharov (f2404) wrote :

*** Bug 14328 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Gitbot (gitbot) wrote :

Igor referenced this bugreport in commit ea503ad545b815f8f9642f53d404cf082c3ed55d

Add command line options for setting text (foreground) and backround colors

https://git.xfce.org/apps/xfce4-terminal/commit?id=ea503ad545b815f8f9642f53d404cf082c3ed55d

Revision history for this message
In , Igor Zakharov (f2404) wrote :

Added options --color-text and --color-bg.
The options parameters should describe a color per the following specification: https://developer.gnome.org/gdk3/stable/gdk3-RGBA-Colors.html#gdk-rgba-parse

Changed in xfce4-terminal:
importance: Unknown → Wishlist
status: Unknown → Fix Released
Revision history for this message
Theo Linkspfeifer (lastonestanding) wrote :

Fixed in version 0.8.7.4 (Xubuntu 18.04.1):

https://git.xfce.org/apps/xfce4-terminal/tree/NEWS

Changed in xfce4-terminal (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.