No tooltip is displayed on memory load plugin

Bug #1738439 reported by Volodya on 2017-12-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Xfce4 System Load Plugin
Fix Released
Medium
xfce4-systemload-plugin (Ubuntu)
Undecided
Unassigned

Bug Description

On 16.04 i was able to see a tooltip that showed the load of memory in percentage.
After upgrading to 17.10 this is no longer visible.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: xfce4-systemload-plugin 1:1.2.1-0ubuntu1
ProcVersionSignature: Ubuntu 4.13.0-19.22-generic 4.13.13
Uname: Linux 4.13.0-19-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.6
Architecture: amd64
CurrentDesktop: XFCE
Date: Fri Dec 15 16:55:50 2017
InstallationDate: Installed on 2017-12-14 (1 days ago)
InstallationMedia: Xubuntu 17.10 "Artful Aardvark" - Release amd64 (20171017.1)
SourcePackage: xfce4-systemload-plugin
UpgradeStatus: No upgrade log present (probably fresh install)

With version 1.2.1 there are no more tooltips displayed. Version 1.1.2 worked fine.

Filed a bug in GNOME's bug tracker about this, maybe they can fix it in Gtk3:

https://bugzilla.gnome.org/show_bug.cgi?id=782978

The workaround is to set the update the update interval > 0.5s for now

Volodya (volodya) wrote :
Changed in xfce4-systemload-plugin:
importance: Unknown → Medium
status: Unknown → Fix Released

*** Bug 14746 has been marked as a duplicate of this bug. ***

The minimum might need to be bumped to 600 ms. 500 ms cuts a bit too close and doesn't work for me.

Using the tooltip.c example from [1], the tooltip appears if I use 500 ms on my desktop and 501 ms on my laptop. And even though 500 ms works with tooltip.c on my desktop, xfce4-systemload-plugin still needs a bump to 0.6 because 0.5 doesn't work.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=782978

Thank you very much!

It works very well with values greater than 0.5 s.
The problem is solved and I am happy to retrieve this useful feature!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.