After a 8.10 -> 9.04 upgrade, keyboard shortcuts are broken

Bug #366828 reported by Steve Dodier-Lazaro on 2009-04-25
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xfce4-settings (Ubuntu)

Bug Description

After upgrading to Jaunty, my keyboard shortcuts stopped working.

I just couldn't find the reason why. I tried to manually edit the xml file for the shortcuts with very obvious ones (such as "z" for xfrun4), i tried resetting it to default, reinstalled a few xfce related packages incase of a bug, but I couldn't find the reason of the problem.

I'll attach any file needed, just tell me which ones would be needed (obviously i won't attach .config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml since it's the default one after i resetted it).

PS : i used to have gnome installed before the upgrade, but i did remove ubuntu-desktop, and i only had xubuntu-desktop when i upgraded.

Sarunas (sarunas-saulis) wrote :

I have very similar problem, not sure if bug is the same.

Xfce keyboard shortcuts that use numpad don't work. (same command works if shortcut doesn't use numpad)
Xfce window manager keyboard shortcuts only work after I reconfigure it (with the same value). After reboot they don't work again.

I have gnome, xfce and kde installed.
Originally installed version is 7.10, the bug occured after I switched from 8.10 to 9.04.

On my computer the shortcuts don't work either. Though it seems more like the other bug with compiz that has been reported #333309 (

<Alt>+F2 produces ;3Q on my xfce-terminal, etc...

Kay (noiq) wrote :

I had a quite similar problem, too. It was a bit different, as some still worked all right and the others were only remapped to the default. As Sarunas said, I had to reconfigure the keys to the same value after every new login.

For me the solution was to remove all the multiple occurrences of definitions (same "value" value) in .config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml, which were not set by myself. Now my shortcuts work fine.

I am not sure, but I think xfce prevents mappings like "z", as it would become impossible to type that key afterwards. Maybe you could try something like "&lt;Super&gt;z" or "&lt;Alt&gt;&lt;Control&gt;z" instead.

Sarunas (sarunas-saulis) wrote :

Thanks Kay,

removing multiple occurrences of same value made window manager shortcuts work.

Although I still cannot use shortcuts like Alt+KP_2 (strangely this works if I change it to use numpad down arrow and switch numlock off)

Ram Yalamanchili (ramyinc) wrote :

The problem definetely seems to stem from duplicate entries in:

I changed a few shortcuts to maximize/move windows, and they all had the default and the new key configurations in the same xml file. There were two entries for each of the keyboard shortcut i changed. Manually editing the xml file and removing the defaults helped fix my issue.

The editor for keyboard shortcut seems to be buggy.

It seems that this file is auto generated from your xfce 4.4 config when you
wipe it, so the first step for me was to completely wipe my 4.4 config
files, then the 4.6 ones (all from shell of course), and then to boot back
and have clean files generated.

Also, check that xfce4-settings-helper runs, either shortcuts won't work.

affects: xfce4 (Ubuntu) → xfce4-settings (Ubuntu)
Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this issue. How can I reproduce this issue? I have not ever used keyboard shortcuts, myself. Can you give me a basic step-by-step to put in some shortcuts and reproduce this issue, please.

Changed in xfce4-settings (Ubuntu):
status: New → Incomplete
Sarunas (sarunas-saulis) wrote :

I'm not using xfce for a while now but as far as I remember there are two places in xfce configuration where you can define keyboard shortcuts:

in 'keyboard settings' that can be accessed either from menu->settings->keyboard settings or menu->settings->all settings
in window manager settings

Try to add shortcut that is mentioned in one of previous posts: Alt+KP_2 and just run some application as an action.

Sorry but I don't remember that well what the exact problem was.

Steve Dodier-Lazaro (sidi) wrote :

Problems were coming from a xfce4-settings-helper daemon not running, I think we can safely mark the bug report as invalid.

Charlie Kravetz (charlie-tca) wrote :

Thanks for the reponses. I am taking Steve's advice and marking this report invalid.

Changed in xfce4-settings (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers