xfsettingsd doesn't open on login, making the system look ugly

Bug #1870641 reported by Leonardo Müller
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xfce4-settings (Ubuntu)
Triaged
Undecided
Unassigned

Bug Description

When testing the Xubuntu Beta live media, it was observed xfsettingsd may fail to open. The consequence of this is that the appearance of Xubuntu is ugly. Many icons are missing and other have colors such way they are barely visible.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: xfce4-settings 4.14.2-1ubuntu1
ProcVersionSignature: Ubuntu 5.4.0-21.25-generic 5.4.27
Uname: Linux 5.4.0-21-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu22
Architecture: amd64
CasperVersion: 1.442
CurrentDesktop: XFCE
Date: Fri Apr 3 23:59:49 2020
LiveMediaBuild: Xubuntu 20.04 LTS "Focal Fossa" - Beta amd64 (20200402)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=pt_BR.UTF-8
 SHELL=/bin/bash
SourcePackage: xfce4-settings
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Leonardo Müller (leozinho29-eu) wrote :
Revision history for this message
Leonardo Müller (leozinho29-eu) wrote :

The attached image show the problems with the themes. Notice how the desktop icons are very hard to see.

Revision history for this message
Leonardo Müller (leozinho29-eu) wrote :
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1870641

tags: added: iso-testing
Revision history for this message
Sean Davis (bluesabre) wrote :
Revision history for this message
Sean Davis (bluesabre) wrote :

This bug is similar, so please check the daily image tomorrow (20200413) to see if this issue is resolved.

xfce4-settings (4.14.3-0ubuntu1) focal; urgency=medium

  * New upstream bugfix release.
    - Fixes xfsettingsd crash with VNC (LP: #1837071)

 -- Sean Davis <email address hidden> Sun, 12 Apr 2020 12:15:12 -0400

Revision history for this message
Leonardo Müller (leozinho29-eu) wrote :

I tested the live media with sha256sum 009c846c5596d7b4454a7b8eb7ca804a53dd7c58abf2e438da68e91018958133 and I still observed this problem.

It's important to note that, if I run xfsettingsd after the live session starts, it starts fine. The problem is when the live session starts (after Ubiquity opens and choosing "Try Ubuntu"). Starting xfsettingsd later from the terminal or whisker menu works fine. It's only on live startup after Ubiquity.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-settings (Ubuntu):
status: New → Confirmed
Sean Davis (bluesabre)
Changed in xfce4-settings (Ubuntu):
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints