[SRU] Mouse fails to scroll apps in Xfce Settings Manager

Bug #1653448 reported by Kev Bowring on 2017-01-01
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Xfce4 Settings
Fix Released
Medium
xfce4-settings (Ubuntu)
Undecided
Unassigned
Cosmic
Undecided
Unassigned
Disco
Undecided
Unassigned

Bug Description

[Impact]

 * Preference dialogs embedded in xfce4-settings-manager 4.13.x are not scrollable.

 * This is a major decrease in usability, particularly with the preference dialogs
   which often require scrolling.

 * This package fixes the issue by enabling GDK_CORE_DEVICE_EVENTS, working around xinput2's subpixel handling triggering unwanted enter/leave-notify events.
   - Upstream xinput2 bug: https://bugs.freedesktop.org/show_bug.cgi?id=92681
   - Upstream xfce4-settings commit: https://git.xfce.org/xfce/xfce4-settings/commit/?id=b664ea04a235051fb27748bd01a6b7823d671e8b

[Test Case]

 * Open Notifications from the menu: Settings > Notifications, or via the terminal: xfce4-notifyd-config

 * Applications Tab is scrollable with mouse wheel.

 * Open Notifications from the Xfce Settings Manager: Personal > Notifications

 * Applications Tab fails to scroll with mouse wheel.

[Regression Potential]

 * Minimal: The patch only applies an env variable only to the Xfce Settings Manager.

[Original Report]
Open notifications from settings menu or via terminal.

Applications Tab is scrollable with mouse wheel.

Open notifications from Settings Dialogue.

Applications Tab fails to scroll with mouse wheel.

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: xfce4-notifyd 0.3.4-1
ProcVersionSignature: Ubuntu 4.9.0-11.12-generic 4.9.0
Uname: Linux 4.9.0-11-generic x86_64
ApportVersion: 2.20.4-0ubuntu1
Architecture: amd64
CurrentDesktop: XFCE
Date: Sun Jan 1 18:53:18 2017
InstallationDate: Installed on 2016-06-11 (204 days ago)
InstallationMedia: Xubuntu 16.10 "Yakkety Yak" - Alpha amd64 (20160611)
SourcePackage: xfce4-notifyd
UpgradeStatus: No upgrade log present (probably fresh install)

Kev Bowring (flocculant) wrote :
Kev Bowring (flocculant) on 2017-01-01
summary: - Mouse fails to scroll notifications in settings manager
+ Mouse fails to scroll apps in settings manager notification.
Changed in xfce4-notifyd:
importance: Unknown → Medium
status: Unknown → In Progress
Changed in xfce4-notifyd:
status: In Progress → Invalid
Sean Davis (bluesabre) wrote :

Also affects bionic.

tags: added: bionic
Changed in xfce4-notifyd (Ubuntu):
status: Invalid → Confirmed
Sean Davis (bluesabre) wrote :

Per the upstream bug, this affects xfce4-settings.

affects: xfce4-notifyd (Ubuntu) → xfce4-settings (Ubuntu)
Sean Davis (bluesabre) on 2018-03-10
affects: xfce4-notifyd → xfce4-settings

Scrolling with mouse fails in some plugins.

Apparently "This is a regression in xfce4-settings and unrelated to xfce4-notifyd - it affects all other plugged Gtk3 dialogs as well as far as I can tell." https://bugzilla.xfce.org/show_bug.cgi?id=13275#c5

summary: - Mouse fails to scroll apps in settings manager notification.
+ Mouse fails to scroll apps in settings manager.
Changed in xfce4-settings:
importance: Medium → Unknown
status: Invalid → Unknown

New upstream bug reported for xfce4-settings

Changed in xfce4-settings:
importance: Unknown → Medium
status: Unknown → Confirmed

Yes, it affects any scrolled window of plugged gtk3 dialogs.
The workaround I found is to click (left or right) and hold on any part of the scrolled window then mouse wheel works.
After the mouse button is released, it'll briefly work. I suspect it's not an issue about events passage, but related to focus.

Scrolling works if you click on the mouse wheel and keep scrolling it

*** Bug 14732 has been marked as a duplicate of this bug. ***

Another workaround:

$ GDK_CORE_DEVICE_EVENTS=1 xfce4-settings-manager

*** Bug 13317 has been marked as a duplicate of this bug. ***

Changed in xfce4-settings:
status: Confirmed → Fix Released

*** Bug 14879 has been marked as a duplicate of this bug. ***

This bug was fixed in the package xfce4-settings - 4.13.4-1ubuntu2

---------------
xfce4-settings (4.13.4-1ubuntu2) disco; urgency=medium

  * debian/patches/xubuntu_lp1653448.patch:
    - Fix scrolling in the settings manager (LP: #1653448)

 -- Sean Davis <email address hidden> Sun, 03 Mar 2019 07:55:14 -0500

Changed in xfce4-settings (Ubuntu Disco):
status: Confirmed → Fix Released
Sean Davis (bluesabre) on 2019-03-27
description: updated
summary: - Mouse fails to scroll apps in settings manager.
+ [SRU] Mouse fails to scroll apps in Xfce Settings Manager
Sean Davis (bluesabre) wrote :

Attaching cosmic debdiff.

Changed in xfce4-settings (Ubuntu Cosmic):
status: New → In Progress
Sean Davis (bluesabre) wrote :

Uploaded package version 4.13.4-1ubuntu1.18.10.1

Hello Kev, or anyone else affected,

Accepted xfce4-settings into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xfce4-settings/4.13.4-1ubuntu1.18.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in xfce4-settings (Ubuntu Cosmic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-cosmic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.