MIME type change incorrectly shows as Default

Bug #1391184 reported by Jack Fromm on 2014-11-10
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xfce4-settings
Fix Released
Low
xfce4-settings (Ubuntu)
Low
Unassigned

Bug Description

Running xfce4-mime-settings testcase ID 1581.
Last section tests changing "Open with:" setting in properties of file from Thunar. After changing a log file to open with AbiWord, if you open the MIME Type Editor and look at the setting for that type of file, it shows AbiWord as the Default instead of User Set. However, if you then set it back to default, it does set it back to the true default of Mousepad.
Verified that in Trusty, when you performed these steps, it did correctly show that the Open With property was "User Set".

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: xfce4-settings 4.11.3-0ubuntu3
ProcVersionSignature: Ubuntu 3.16.0-24.32-generic 3.16.4
Uname: Linux 3.16.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.7-0ubuntu10
Architecture: amd64
CurrentDesktop: XFCE
Date: Mon Nov 10 09:18:43 2014
InstallationDate: Installed on 2014-11-05 (4 days ago)
InstallationMedia: Xubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20141105)
SourcePackage: xfce4-settings
UpgradeStatus: No upgrade log present (probably fresh install)

Jack Fromm (jjfrv8) wrote :

Created attachment 5743
Highlighted mime type should say "User Set"

Running xfce4-mime-settings testcase ID 1581.
Last section tests changing "Open with:" setting in properties of file from Thunar. After changing a log file to open with AbiWord, if you open the MIME Type Editor and look at the setting for that type of file, it shows AbiWord as the Default instead of User Set. However, if you then set it back to default, it does set it back to the true default of Mousepad.
Verified that in Trusty, when you performed these steps, it did correctly show that the Open With property was "User Set".

xfce4-settings ver. 4.11.3-0Ubuntu3

Jack Fromm (jjfrv8) on 2014-11-10
Changed in xfce4-settings:
importance: Undecided → Unknown
status: New → Unknown
Changed in xfce4-settings:
importance: Unknown → Low
status: Unknown → Confirmed
David Pires (slickymaster) wrote :

Running the same testcase on today's Vivid Verver image, and at the last section of the test (... check that MIME Type Editor will correctly display a file association changed with another application) after right clicking the .log file in the file manager to select "Open with AbiWord" what I get in the step 2 is that The "Status" shows me "Default" and the "Default Application" shows me "Mousepad"

Elfy (elfy) wrote :

confirmed in updated vv

changing default in thunar previously set mimetype for log files to User Set - now remains as Default.

Changing application in mimetype editor does correctly change to User Set after change

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-settings (Ubuntu):
status: New → Confirmed
Changed in xfce4-settings (Ubuntu):
importance: Undecided → Medium
importance: Medium → Low

Created attachment 5879
Update mimeapps.list location (glib >= 2.41)

This patch fixes the described bug which is caused by the following glib change:

- moving ~/.local/share/applications/mimeapps.list to ~/.config/

https://git.gnome.org/browse/glib/commit/?id=6fd5a8c

Thanks for the patch! Tested and verified. I've merged this into trunk, and it will be available on the next release.

Changed in xfce4-settings:
status: Confirmed → Fix Released

Should be fixed in xfce4-settings 4.11.4-0ubuntu1. Please test and confirm.

Jack Fromm (jjfrv8) wrote :

Tested with xfce4-settings 4.11.4 and can confirm it is fixed.

Thanks.

Changed in xfce4-settings (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.