Onboard Keyboard appears on desktop when GNOME Services is checked

Bug #872515 reported by Charlie Kravetz on 2011-10-11
84
This bug affects 17 people
Affects Status Importance Assigned to Milestone
xfce4-session
Unknown
Unknown
xfce4-session (Ubuntu)
Low
Unassigned

Bug Description

RELEASE: Oneiric Ocelot
CD/DVD VARIANT: final candidate testing, Xubuntu 64bit Desktop cd
ISO BUILD: 2011-10-11

SYMPTOMS: When the user logs in to the desktop, Onboard Keyboard starts automatically

STEPS TO REPRODUCE:

1. install Xubuntu as normal
2. After restarting and updating, restart
3. go to menu -> Settings -> Settings Manager, Session and Startup
4. On the Advanced tab, check "Launch GNOME services on startup
5. close the Settings Manager
6. Reboot
7. Observe that Onboard Keyboard starts when you login now. Closing it works, but it will restart every login.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xfce4-session 4.8.2-1ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Tue Oct 11 14:43:56 2011
InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111011)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xfce4-session
UpgradeStatus: No upgrade log present (probably fresh install)

Charlie Kravetz (charlie-tca) wrote :
tags: added: iso-testing
madnick (dr-madnick) wrote :

I can confirm this, I am using the images of the same date but the i386 ISO.

Unmensch (unmensch) wrote :

Confirmed on one installation, but not on another.

I don't know if this helps, but I also had three locales installed on the installation where this happened, but these were incompletely installed at upgrade to oneiric. Reinstalling/resetting the locales seemed to solve the problem.

Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in xfce4-session (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Lionel Le Folgoc (mrpouit) wrote :

The GNOME compatibility code in Xfce needs to be improved unfortunately.

From /etc/xdg/autostart/onboard-autostart.desktop:
> […]
> Exec=onboard
> […]
> AutostartCondition=GSettings org.gnome.desktop.a11y.applications screen-keyboard-enabled
> […]
> OnlyShowIn=GNOME;Unity;

In GNOME, when the gsettings key 'org.gnome.desktop.a11y.applications' doesn't contain 'screen-keyboard-enabled', it won't start. But xfce4-session will autostart desktop files with 'OnlyShowIn=GNOME;' regardless, as it doesn't support 'AutostartCondition'.

There have been some discussions upstream to rework that part, but not sure it'll be ready for 4.10.

In the meantime, you can disable "gnome services' support" in xfce4-session (it's disabled by default), or only disable onboard from starting automatically.

Changed in xfce4-session (Ubuntu):
importance: Medium → Low
Forest (foresto) wrote :

Bug #893811 seems to be caused by the same underlying problem.

Jochen Fahrner (jofa) wrote :

How can I disable only onboard from starting automatically?

Austin Chu (eefi) wrote :

As a workaround until this bug is fixed, you can create the file ~/.config/autostart/onboard-autostart.desktop with the following two lines:

[Desktop Entry]
Hidden=true

This will override the autostart request in /etc/xdg/autostart/onboard-autostart.desktop. For more details on the freedesktop.org autostart speicification, see http://standards.freedesktop.org/autostart-spec/autostart-spec-latest.html .

Lionel Le Folgoc (mrpouit) wrote :

"GNOME services" autostart of desktop files has been rewritten in xfce4-session 4.10 (in quantal). This should fix this issue.

Changed in xfce4-session (Ubuntu):
status: Triaged → Fix Released

i can reproduce this bug also with ubuntu 12.04 with xfce from ppa:xubuntu-dev/xfce-4.10 ...

... i've simply uninstalled onboard...

I can confirm that this is still the case with Ubuntu 12.04 LTS newly installed during the spring of 2014, is there any other bug assigned to this problem on launchpad?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.