HTML code in logout-window

Bug #431849 reported by Lars Volker
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xfce4-session (Ubuntu)
Fix Released
Low
Lionel Le Folgoc

Bug Description

Binary package hint: xfce4-session

The logout windows contains the following in the first line:

<span size='large'><b>pimp abmelden</b></span>

Where pimp is my local username and I'm obviously using German localization.

The HTML should either be interpreted or removed.

ProblemType: Bug
Architecture: amd64
Date: Thu Sep 17 15:16:29 2009
DistroRelease: Ubuntu 9.10
Package: xfce4-session 4.6.1-1ubuntu1
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.34-generic
SourcePackage: xfce4-session
Uname: Linux 2.6.31-10-generic x86_64

Revision history for this message
Lars Volker (lv) wrote :
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

Hi,

Thanks for your bug report.
Are you sure there isn't a character between 'span' and 'size'?

Because the po/de.po file contains:
#: ../xfce4-session/shutdown.c:360
#, c-format
msgid "<span size='large'><b>Log out %s</b></span>"
msgstr "<span·size='large'><b>%s abmelden</b></span>"
            ^^^

This extra character is bogus (seems to be already fixed upstream), so it is probably the cause of your bug. I'll remove it in the next upload.

Changed in xfce4-session (Ubuntu):
assignee: nobody → Lionel Le Folgoc (mrpouit)
importance: Undecided → Low
status: New → Triaged
Revision history for this message
Lars Volker (lv) wrote :

Yes, there's this \cdot character in the string between span and size. Thanks for fixing it.

Changed in xfce4-session (Ubuntu):
status: Triaged → In Progress
Changed in xfce4-session (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-session - 4.6.1-1ubuntu2

---------------
xfce4-session (4.6.1-1ubuntu2) karmic; urgency=low

  * debian/patches:
    - 09_fix-typo-logout-dialog.patch: remove an extra character that breaks
      formatting with de_DE locale (LP: #431849)
    - series: include this new patch.

 -- Lionel Le Folgoc <email address hidden> Sat, 19 Sep 2009 12:09:38 +0200

Changed in xfce4-session (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers