xfce4-session-logout : buttons not localized except "Restart" and "Cancel"

Bug #228784 reported by Damien G.E.
6
Affects Status Importance Assigned to Milestone
xfce4-session (Ubuntu)
Fix Released
Low
Lionel Le Folgoc
Hardy
Fix Released
Low
Unassigned

Bug Description

Original subject : xfce4-session-logout : Incomplete French locale

1) Release version: Xubuntu 8.04 with non-english locale selected
2) Version of the package: xfce4-session (4.4.2-2ubuntu2)
3) When clicking on "exit" button (or typing command "xfce4-session-logout"), the logout panel applet appears with 7 choice buttons (Switch user, Log out, Reboot, Shut Down, Suspend, Hibernate, Cancel). As my language session is set french by default, all of this 7 buttons should be labeled in French (Changer d'utilisateur, Se déconnecter, Redémarrer, Eteindre, Suspendre, Hiberner, Annuler).
4) Here is the problem: Among the 7 choices buttons of the logout panel, only two are translated in French language ("Cancel' and "Restart"), the others are labelled in english.

Additional note:
 * This problem is not specific to French locale. All translations are missing for these buttons.
 * It is annoying for all Xubuntu users (and potential users) except English native speakers.

Revision history for this message
Damien G.E. (vauss) wrote :
description: updated
Damien G.E. (vauss)
description: updated
description: updated
description: updated
Florent (florent.x)
Changed in xfce4-session:
status: New → Confirmed
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

I'll try to fix it on intrepid. For hardy, someone will have to do a SRU.

Changed in xfce4-session:
assignee: nobody → mrpouit
status: Confirmed → In Progress
importance: Undecided → Wishlist
importance: Wishlist → Low
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

Fixed in xfce4-session 4.4.2-6ubuntu2 (intrepid).

Changed in xfce4-session:
status: In Progress → Fix Released
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

I don't know if it's ok for a SRU (it's not really a high-impact bug). Anyway, it's a regression from gutsy, so I'll prepare the packages, and we'll see.

Changed in xfce4-session:
assignee: nobody → mrpouit
status: New → In Progress
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

50 files changed, 32366 insertions(+)
This is too much changes for a SRU, and I don't have the time to get a minimal diff for each PO file, sorry. Maybe someone from the Xubuntu team will do it.

Changed in xfce4-session:
assignee: mrpouit → nobody
status: In Progress → Triaged
Revision history for this message
Florent (florent.x) wrote :

Here is a minimal patch for Hardy, against "4.4.2-2ubuntu2".

This SRU aims to fix a regression introduced with Hardy.
It has low risk, since there's only 3 files touched, no source code:
* debian/changelog
* debian/patches/series
* debian/patches/08_fix_xubuntu_translations.patch

The translation patch is minimal. For each PO file:
* it appends 7 new strings, specific for (x)ubuntu, with translations extracted from the last Intrepid tarball
* it changes case for 2 other strings
* it removes 1 obsolete string ("End Session", replaced with "Switch user")

Changed in xfce4-session:
status: Triaged → In Progress
Revision history for this message
Florent (florent.x) wrote :

debdiff changed:
* removed conflicting commented strings for languages: be, dz, gl, sk
* fix patch format (removed 1 directory level)

Revision history for this message
Florent (florent.x) wrote :

Built, installed and tested on PPA.
It works as expected.

Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

Thanks, I'll review the debdiff.

Changed in xfce4-session:
assignee: nobody → mrpouit
importance: Undecided → Low
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

I made some changes with Florent (drop uneeded parts of the patch, correct revision number...).
Waiting for Cody's ack. ;)

Revision history for this message
Cody A.W. Somerville (cody-somerville) wrote :

Could you please list the languages you fixed in the debdiff for the SRU?

Revision history for this message
Florent (florent.x) wrote :

Attached new debdiff.

All 49 languages are touched:
 * "Shut Down" -> "Shut down" and "Log Off -> "Log off" is changed for all languages
 * "Switch user" / "Suspend" / "Hibernate" are added only if available in Rosetta

Revision history for this message
Cody A.W. Somerville (cody-somerville) wrote :

ACK once you update the bug description to be accurate. :)

Changed in xfce4-session:
assignee: mrpouit → nobody
Florent (florent.x)
description: updated
Revision history for this message
Florent (florent.x) wrote :

Changed description to highlight the fact that it is not specific to French locale.
IMHO 99% of non-English users see this bug at least once a day since April 2008...

Revision history for this message
Cody A.W. Somerville (cody-somerville) wrote :

ACK. Please upload to -proposed.

Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

It seems it was accepted into -proposed today. It needs some testing now.

Changed in xfce4-session:
status: In Progress → Fix Committed
Revision history for this message
Florent (florent.x) wrote :

it works.

Revision history for this message
Steve Langasek (vorlon) wrote :

Thanks for confirming. Copying to hardy-updates.

Changed in xfce4-session:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers