xfce4-autostart-editor crashed with SIGSEGV

Bug #206867 reported by graey
32
Affects Status Importance Assigned to Milestone
xfce4-session (Ubuntu)
Medium
Lionel Le Folgoc

Bug Description

Binary package hint: xfce4-session

Autostart editor just crashes, doesn't show at all.

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Wed Mar 26 00:15:09 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/xfce4-autostart-editor
NonfreeKernelModules: nvidia
Package: xfce4-session 4.4.2-2ubuntu1
PackageArchitecture: i386
ProcCmdline: xfce4-autostart-editor
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: xfce4-session
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: xfce4-autostart-editor crashed with SIGSEGV
Uname: Linux 2.6.24-12-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev vboxusers video

Revision history for this message
graey (geertvandijk) wrote :
Revision history for this message
Apport retracing service (apport) wrote : Symbolic stack trace

StacktraceTop:xfae_item_new (relpath=<value optimized out>) at xfae-model.c:495
xfae_model_init (model=0x8088300) at xfae-model.c:136
IA__g_type_create_instance (type=134880672)
g_object_constructor (type=134880672, n_construct_properties=0, construct_params=0x0)
IA__g_object_newv (object_type=134880672, n_parameters=0, parameters=0x0)

Revision history for this message
Apport retracing service (apport) wrote : Symbolic threaded stack trace
Revision history for this message
Apport retracing service (apport) wrote : Stack trace with source code
Changed in xfce4-session:
importance: Undecided → Medium
Revision history for this message
Gauvain Pocentek (gpocentek) wrote :

Did you add autostarted applications yourself at some point? I can't reproduce the crash here.

Changed in xfce4-session:
status: New → Incomplete
Revision history for this message
graey (geertvandijk) wrote :

No, I was going to add fusesmb but it crashed before I even got to see the application. Now I'd also like to add superswitcher, but it still won't let me :P.
Any other way I can manually add these things without the xfce4-session app?

Revision history for this message
banewman (banewman) wrote : Todays' updates fixed this for me

The updates I got today has got the autostarted apps button functioning
for me.
Thanks.
Paul

Revision history for this message
Gauvain Pocentek (gpocentek) wrote :

graey: does it fix the problem for you as well?

Revision history for this message
Kadir Yucel (atomkarinca) wrote :

The problem isn't fixed yet (at least for me).

Revision history for this message
John Doe (johndoe32102002) wrote :

I am having the same problem. I am running:

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Wed Mar 26 00:15:09 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/xfce4-autostart-editor
NonfreeKernelModules: ati (radeon)
Package: xfce4-session 4.4.2-2ubuntu1
PackageArchitecture: i386
ProcCmdline: xfce4-autostart-editor
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: xfce4-session

Revision history for this message
Urs Fleisch (ufleisch) wrote :

I have this crash with Hardy Beta. To find out what happens I recompiled the program. Here is the backtrace:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb731e720 (LWP 13307)]
xfae_item_free (item=0x0) at xfae-model.c:508
(gdb) bt
#0 xfae_item_free (item=0x0) at xfae-model.c:508
#1 0x0804c167 in xfae_item_new (relpath=<value optimized out>) at xfae-model.c:495
#2 0x0804d365 in xfae_model_init (model=0x8084008) at xfae-model.c:136
#3 0xb7772f46 in g_type_create_instance () from /usr/lib/libgobject-2.0.so.0
#4 0xb7758242 in ?? () from /usr/lib/libgobject-2.0.so.0
#5 0x0809cd60 in ?? ()
#6 0x00000000 in ?? ()
(gdb)

Looking at xfae_item_new() in xfae-model.c, item is only allocated if "Type" is "Application", but at the end of the function passed to xfae_item_free(), where it is dereferenced, also if it is NULL. To reproduce the bug, you only need a desktop entry with a "Type" which is not "Application", e.g. adept_notifier_auto.desktop:

grep -n "Type=Service" /etc/xdg/autostart/*
/etc/xdg/autostart/adept_notifier_auto.desktop:21:Type=Service

Here's a little patch to fix the bug:

--- xfce4-session-4.4.2/xfce4-autostart-editor/xfae-model.c.orig 2007-11-17 20:31:05.000000000 +0100
+++ xfce4-session-4.4.2/xfce4-autostart-editor/xfae-model.c 2008-04-07 19:18:15.000000000 +0200
@@ -490,7 +490,7 @@ xfae_item_new (const gchar *relpath)
       xfce_rc_close (rc);

       /* check if we should skip the item */
- if (G_UNLIKELY (skip))
+ if (G_UNLIKELY (skip) && item)
         {
           xfae_item_free (item);
           item = NULL;

Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

I'll prepare the upload.
Thanks for the patch.

Changed in xfce4-session:
assignee: nobody → mrpouit
status: Incomplete → Triaged
Changed in xfce4-session:
status: Triaged → In Progress
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

Cody, it seems it needs your ACK (according to https://lists.ubuntu.com/archives/ubuntu-motu/2008-April/003544.html).
Please give it for this bug and Bug #214857, so that I can upload before Thursday, and hopefully the fix will be in the RC.
Thanks.

Revision history for this message
Cody A.W. Somerville (cody-somerville) wrote :

Ack.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-session - 4.4.2-2ubuntu2

---------------
xfce4-session (4.4.2-2ubuntu2) hardy; urgency=low

  * debian/patches:
    - 06_fix-es-translation.patch: fix two broken strings (LP: #214857)
    - 07_fix-autostart-editor-crash.patch: fix a xfce4-autostart-editor crash
      with desktop files containing a "Type" which is not "Application", thanks
      Urs Fleisch for the patch (LP: #206867)
    - series: refreshed.

 -- Lionel Le Folgoc <email address hidden> Mon, 14 Apr 2008 12:21:31 +0200

Changed in xfce4-session:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers