Will not logout or shutdown from guest-session

Bug #1855350 reported by Jarno Suni on 2019-12-05
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
Undecided
Unassigned
xfce4-session (Ubuntu)
Undecided
Unassigned

Bug Description

This is in Xubuntu 19.10, a regression from 18.04. xfce4-session 4.14.0-0ubuntu1. I enabled guest-session and logged in that. But there I can not log out or even shut down using the graphical way at least unless put Action Buttons on the panel and choose Switch User. If I run "xfce4-session-logout -l" I get error dialog saying:

Received error while trying to log out

GDBus.Error:org.freedesktop.DBus.Error.InvalidArgs:Type of message, "(yb)", does not match expected type"(b)"

And in standard output there is: "Received error while trying to log out, error was GDBus.Error:org.xfce.SessionManager.Error.Failed: Session manager must be in idle state when requesting a shutdown"

Jarno Suni (jarnos) on 2020-05-03
tags: added: eoan focal
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Changed in xfce4-session (Ubuntu):
status: New → Confirmed
Mika Katua (mikakatua) wrote :

Hi all,
It seems the problem is related to the guest session wrapper (/usr/lib/lightdm/lightdm-guest-session). As a workaround, it is possible to disable this wrapper removing the file /usr/share/lightdm/lightdm.conf.d/50-guest-wrapper.conf

Graham Jenkins (grahjenk) wrote :

Yes, I removed the wrapper, and I was then able to logout successfully.
But when I the logged in as a regular user, I had some problems with
selecting windows within my session.

On another host today, I observed that I'm now able to shutdown or
reboot from a guest session .. but can't logout. I'm not sure why
this is different, but I think it may be related an update to
gnome-shell that occurred during an package-update today.

summary: - Will not logout or shutdown form guest-session
+ Will not logout or shutdown from guest-session
Jarno Suni (jarnos) wrote :

Mika, I can confirm, oddly it helped renaming /usr/share/lightdm/lightdm.conf.d/50-guest-wrapper.conf to /usr/share/lightdm/lightdm.conf.d/50-guest-wrapper.conf.bak.
I am using 20.04 now.

Drew Woodard (drew-woodard) wrote :

I don't have much to add other than to say I am also experiencing this issue or one similar to it.
I am running xfce on ubuntu 20.04 in a kvm virtual machine. The system was configured to boot to a command prompt with “systemctl set-default multi-user.target”, so when I want to run xfce this is done with "startxfce4".

(problem description)
if you log in to xfce then immediately log out it will fail with one of these errors:
session manager must be in idle state when requesting a shutdown
gdbus.error:org.freedesktop.dbus.error.invalidargs: type of message, "(yb)", does not match expected type "(b)"
-
example scenarios:
reach the desktop, wait 45 seconds or more, try to log out, it works normally
reach the desktop, try to log out immediately, get an error, try a second time, sometimes it will work
reach the desktop, try to log out immediately, get an error, sit there doing nothing for a few seconds, sometimes it will log out
-
I tried playing around with the file 50-guest-wrapper.conf as others had mentioned, but I did not notice any difference.
I also have an identically-configured centos 8 vm and it does not have this issue.

(uninformed guess)
When reaching the desktop something related to lightdm or xfce is failing in the background, once a timeout is reached, things work as expected.

Lou (lou-gregory42) wrote :

Same problem for me (Xubuntu 20.04) and NOT a guest session. Two regular users here and this has happened to both.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers